c->xlib.lock

Bug #87390 reported by Martin Hamel on 2007-02-23
28
Affects Status Importance Assigned to Milestone
libx11 (Ubuntu)
Undecided
Unassigned
libxcb (Ubuntu)
Undecided
Unassigned
linux-restricted-modules-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

When I upgraded this morning, I was left with many application not working. All wine related application and openoffice. Probably some others. They throw the following error message when starting:

soffice.bin: xcb_xlib.c:50: xcb_xlib_unlock: l'assertion « c->xlib.lock » a échoué.
KCrash: Application 'soffice.bin' crashing..

I have a french version of kubuntu, that is why there is some french in the error message.

I looked around and found that it was related to the libx11-6 package. I downgraded libx11-6 to the edgy version and the application resumed working.

Some other problems did show up with the eady libx11-6. My keyboards dead keys are not working now. So it is not a perfect solution. But it is not surprising since I'm mixing versions now. I guess that I'm lucky that is somehow works. :-)

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you get a backtrace (https://wiki.ubuntu.com/DebuggingProgramCrash) of the crash? The problem is likely not to libx11, the new version of that package just trigger lock problem to other libraries. Is you distribution uptodate? wine, ooweb, oowriter works fine on my desktop

Changed in libx11:
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Rob2687 (rob2687) wrote :

Beryl (beryl-xgl) also has this lock / unlock problem.
That is the only app. I get that error with.

More info here for reference:
http://lwn.net/Articles/211808/

Download full text (3.9 KiB)

here is the backtrace when starting openoffice:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1247488304 (LWP 6605)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb7f21410 in __kernel_vsyscall ()
#7 0xb6c60df0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8 0xb6c62641 in abort () from /lib/tls/i686/cmov/libc.so.6
#9 0xb6c5a43b in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6821651 in xcb_xlib_unlock () from /usr/lib/libxcb-xlib.so.0
#11 0xb6fa7bd4 in ?? () from /usr/lib/libX11.so.6
#12 0x080ba2d0 in ?? ()...

Read more...

Martin Hamel (martin-komunide) wrote :

I'm up to date on feisty. I use Crossover with wine. But my Openoffice has
nothing special.

2007/2/23, Sebastien Bacher <email address hidden>:
>
> Thank you for your bug. Could you get a backtrace
> (https://wiki.ubuntu.com/DebuggingProgramCrash) of the crash? The
> problem is likely not to libx11, the new version of that package just
> trigger lock problem to other libraries. Is you distribution uptodate?
> wine, ooweb, oowriter works fine on my desktop
>
> ** Changed in: libx11 (Ubuntu)
> Importance: Undecided => Medium
> Status: Unconfirmed => Needs Info
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
Martin Hamel
(418)261-2222
<email address hidden>

Sebastien Bacher (seb128) wrote :

Looks like a problem with mesa. What version of the libgl1-mesa-glx package is installed? What videocard do you have? Do you use any binary driver that could divert the mesa libgl?

Martin Hamel (martin-komunide) wrote :

libgl1-mesa-glx is at version 6.5.2-3ubuntu1

I have a nvidia card with the binary driver that is in the feisty
repository: nvidia-glx version 1.0.9631+2.6.20.2-8.7

2007/2/24, Sebastien Bacher <email address hidden>:
>
> Looks like a problem with mesa. What version of the libgl1-mesa-glx
> package is installed? What videocard do you have? Do you use any binary
> driver that could divert the mesa libgl?
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
Martin Hamel
(418)261-2222
<email address hidden>

Timo Aaltonen (tjaalton) wrote :

Martin: try reinstalling nvidia-glx if that helps.

Martin Hamel (martin-komunide) wrote :

Reinstalling nvidia-glx does not cure the proble. But if I use the "nv"
driver instead of the "nvidia" driver, it works. Well then I don't have 3D
anymore. :-(

2007/2/26, Timo Aaltonen <email address hidden>:
>
> Martin: try reinstalling nvidia-glx if that helps.
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
Martin Hamel
(418)261-2222
<email address hidden>

haaland (haaland) wrote :

I've got the same bug, but I am using a radeon card, with the open radeon-driver. libgl1-mesa-glx is version 6.5.2-3ubuntu1.

Martin Hamel (martin-komunide) wrote :

I updated my xlibs this morning and the problem now exist with the "nv"
driver also. Things are just getting worst. :-(

2007/2/26, haaland <email address hidden>:
>
> I've got the same bug, but I am using a radeon card, with the open
> radeon-driver. libgl1-mesa-glx is version 6.5.2-3ubuntu1.
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
Martin Hamel
(418)261-2222
<email address hidden>

Sebastien Bacher (seb128) wrote :

Comments like that one are of no use. You are using an unstable distribution which is meant to get work done, problems happen and they are often fixed. If you don't want any breakage you probably want to consider sticking to a stable version of the distribution.

Sebastien Bacher (seb128) wrote :

What application is causing the problem with the nv driver? Could you get a backtrace?

Martin Hamel (martin-komunide) wrote :

Sorry if it seemed too negative. I did not want to complain. I just wanted
to comunicate. Anyway.. it was my fault this time. I did not test it well. I
thought I had the "nv" driver but it was not so. The problem is still
happening with the "nvidia" driver.

2007/2/27, Sebastien Bacher <email address hidden>:
>
> What application is causing the problem with the nv driver? Could you
> get a backtrace?
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
Martin Hamel
(418)261-2222
<email address hidden>

Changed in libx11:
status: Needs Info → Unconfirmed
gosh (jos-plompen) wrote :

I have the same problem with nvidia-glx-legacy 1.0.7184+2.6.20.2-9.8 on feisty running beryl and glxgears:

~$ glxgears
6954 frames in 5.0 seconds = 1390.729 FPS
6749 frames in 5.0 seconds = 1349.751 FPS
XIO: fatal IO error 22 (Invalid argument) on X server ":0.0"
      after 29 requests (29 known processed) with 0 events remaining.
glxgears: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted (core dumped)

Downgrading libx11-6 to the edgy version did this error disappear, but then other dependency problems came up

Justin (justin-justin-time) wrote :

I have the same problem but with the citrix ICA client. On both of my machines. All fully updated Feisty Fawn machines. 1 has the binaire nvidia driver from the repository: 1.0.9631+2

But on my laptop with the fglrx from ATI I got the some problem after the update two days ago.

I've got the same problem, if I start some application e.g. Savage (game) there is following Error:
xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

I've found some other people in different german speaking forums which have the same problem e.g with OOo. If they install the the Package from http://packages.debian.org/unstable/libs/libx11-6 the problem is solved. I don't want to do that because I wan't a clean Feisty System.

Some Specs about my computer:
http://hwdb.ubuntu.com/?xml=b222c842601aa7b4bd65b0bf544733d1
AMD 3800+, Nvidia GF 6800GT (nvidia-glx from repo)

Please ask if I can do something or you need more info.

Thanks for your work!

Davim (davim) wrote :

I get the same problem when starting beryl-xgl, I have a Xpress 200m and I'm using fglrx since I cant get 3d acceleration with the open drivers.

$ LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa beryl-xgl --replace &
[3] 31263

$ ************************************************** ************
* Beryl system compatiblity check *
************************************************** ************

Detected xserver : XGL

Checking Display :1.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

beryl-xgl: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

beryl-xgl: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
[1]+ Done LD_PRELOAD=/usr/lib/fglrx/libGL.so.1.2.xlibmesa beryl --replace
Cancelado (core dumped)

I fully agree to Davim.
I've got a Radeon Xpress 200M too and i also have these Problems with starting Beryl using fglrx+xgl
It would be lovely to see this fixed .

sandy.toast (sandy-toast) wrote :

Same problem here with a dell d620 laptop and nvidia binary driver.

ooo fails to start, wine fails to start, 3d apps fail to start.

e.g.
#glxinfo
name of display: :0.0
glxinfo: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted (core dumped)

I'm more than happy to provide more information, but I can't seem to get a core. ulimit -u unlimited still doesn't produce a core file when running the above.

Justin (justin-justin-time) wrote :

Why is this bug still "unconfirmed"? Is there any way we can speed up the progress... Any output needed or commands to run so we can help the maintainers of the package?

Sebastien Bacher (seb128) wrote :

do you still get that bug? A libxcb update has been uploaded to workaround the assertion for feisty and fix the problem then

Timo Aaltonen (tjaalton) wrote :

this upload should fix this, if not please reopen:

libxcb (1.0-1.1ubuntu1) feisty; urgency=low
 .
   [ Timo Aaltonen ]
   * debian/patches:
     - 100_allow_sloppy_lock.diff from Novell, workaround to the various
       'Assertion `c->xlib.lock' failed"' -bugs by setting an environment
       variable LIBXCB_ALLOW_SLOPPY_LOCK to any value and the check will
       simply be ignored.
   * debian/{control,rules}:
     - add quilt to Build-deps, and patchsys-quilt.mk to rules.
     - change Maintainer address.
 .
    [ Martin Pitt ]
    * 100_allow_sloppy_lock.diff: Reverse the patch logic for Feisty: Use
      sloppy locking by default for now, because we won't have time to discover
      and fix all broken apps. Setting LIBXCB_NO_SLOPPY_LOCK will enable the
      strict behaviour. This should be dropped right at the opening of
      Feisty+1.

Changed in linux-restricted-modules-2.6.20:
status: Unconfirmed → Rejected
Changed in libx11:
status: Unconfirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

oops, sorry seb, I should refresh the bug before posting :)

anyway, reopen if the issue remains

gosh (jos-plompen) wrote :

I installed all updates in Feisty, but still the same error occures:

$ glxgears
36 frames in 5.0 seconds = 7.183 FPS
13 frames in 5.2 seconds = 2.477 FPS
XIO: fatal IO error 22 (Invalid argument) on X server ":0.0"
      after 29 requests (29 known processed) with 0 events remaining.
glxgears: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted (core dumped)

gosh (jos-plompen) wrote :

Does not work for me.
I posted the similar comment on launchpad:

$ glxgears
36 frames in 5.0 seconds = 7.183 FPS
13 frames in 5.2 seconds = 2.477 FPS
XIO: fatal IO error 22 (Invalid argument) on X server ":0.0"
      after 29 requests (29 known processed) with 0 events remaining.
glxgears: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted (core dumped)

kind regards,
Jos

On 3/7/07, Timo Aaltonen <email address hidden> wrote:
>
> oops, sorry seb, I should refresh the bug before posting :)
>
> anyway, reopen if the issue remains
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
MSN: <email address hidden>
Skype: jos.plompen

sandy.toast (sandy-toast) wrote :

Same here, still broken:

`LIBXCB_ALLOW_SLOPPY_LOCK=true glxinfo`
name of display: :0.0
glxinfo: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted (core dumped)

haaland (haaland) wrote :

Same here, things still does not work. No Openoffice-applications work, in addition to applications using OpenGL (at least including beryl, ppracer, glxinfo, glxgears).

Setting the LIBXCB_ALLOW_SLOPPY_LOCK to true does not matter.

Justin (justin-justin-time) wrote :

Just updated everything again (including libxcb) + reboot.

Still get the same error on both of my systems.

Martin Hamel (martin-komunide) wrote :

Just a mail to the desperate: It works if you install the nvidia drivers
from the nvidia web site.

Good luck

2007/3/8, Justin <email address hidden>:
>
> Just updated everything again (including libxcb) + reboot.
>
> Still get the same error on both of my systems.
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
Martin Hamel
(418)261-2222
<email address hidden>

haaland (haaland) wrote :

Today's update fixed the issue for me, using the radeon-driver. Thanks!

libxcb and assosciated packages is now version 1.0-1.1ubuntu2, while libx11 and assosciates is 1.1.1-1ubuntu1.

Justin (justin-justin-time) wrote :

After the second update today the problem is also fixed for me! (nvidia system) I'll try my fglrx system in just a sec

gosh (jos-plompen) wrote :

This is fixed for me too.
But I now get another error:

 $glxgears
3078 frames in 5.0 seconds = 613.898 FPS
4380 frames in 5.0 seconds = 875.375 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":1.0
"
      after 16469 requests (32 known processed) with 0 events remaining.
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":1.0
"
      after 16469 requests (32 known processed) with 0 events remaining.

On 3/9/07, Justin <email address hidden> wrote:
>
> After the second update today the problem is also fixed for me! (nvidia
> system) I'll try my fglrx system in just a sec
>
> --
> c->xlib.lock
> https://launchpad.net/bugs/87390
>

--
MSN: <email address hidden>
Skype: jos.plompen

gosh (jos-plompen) wrote :

On 3/9/07, Jos Plompen <email address hidden> wrote:
>
> This is fixed for me too.
> But I now get another error:
>
> $glxgears
> 3078 frames in 5.0 seconds = 613.898 FPS
> 4380 frames in 5.0 seconds = 875.375 FPS
> XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":
> 1.0"
> after 16469 requests (32 known processed) with 0 events remaining.
> XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":
> 1.0"
> after 16469 requests (32 known processed) with 0 events remaining.
>
>
> On 3/9/07, Justin <email address hidden> wrote:
> >
> > After the second update today the problem is also fixed for me! (nvidia
> > system) I'll try my fglrx system in just a sec
> >
> > --
> > c->xlib.lock
> > https://launchpad.net/bugs/87390
> >
>
>
>
> --
> MSN: <email address hidden>
> Skype: jos.plompen
>

--
MSN: <email address hidden>
Skype: jos.plompen

Justin (justin-justin-time) wrote :

On the fglrx system the updated worked also.

Thank you

After the update it works now. :)

Many thanks!

Jamey Sharp (sharpone) wrote :

We believe that current libX11 from upstream git fixes the problems when GL-using apps exit on systems with the proprietary nVidia driver.

To the people who reported other bugs here: please ensure your X libraries are up-to-date, and if you can still reproduce the problem please supply a backtrace.

Timo Aaltonen (tjaalton) wrote :

Marking as fixed although libx11 in Gutsy doesn't use xcb so it cannot be tested.

Changed in libx11:
status: New → Fix Released
Che Guevara (che-guevara-3) wrote :

Setting back to confirmed as this bug is back for hardy

Changed in libxcb:
status: Fix Released → Confirmed
Jamey Sharp (sharpone) wrote :

On 12/18/07, Che Guevara <email address hidden> wrote:
> Setting back to confirmed as this bug is back for hardy

If you can confirm this bug, then you have an obligation to provide a
lot more information. Many quite different problems were reported in
this Launchpad bug, and many things have changed since they were
originally reported. I still consider this particular report resolved,
until proven otherwise.

0) Are all your packages fully up to date?
1) What did you test?
2) How did it break?
3) Provide a backtrace from the assertion failing. (libxcb1.1 now
   automatically generates one for you, on glibc systems like Linux.)
   You may need to install debug packages to get a complete backtrace.
4) What version do you have installed of any libraries in the backtrace?
   (I don't have an Ubuntu install handy, so don't just tell me "the
   newest ones"--I don't know if that's current from upstream.)
5) Does your test work when LIBXCB_ALLOW_SLOPPY_LOCK is set?

In other words, *please* read the history of this bug report and answer
the questions already given. :-)

Download full text (3.4 KiB)

0) yes
1) open-vm-tools (vmware-user)
2) does not run, gets an assertion.
3)
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7a75767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb7a758b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb7e0929d]
#3 /usr/lib/vmware-tools/bin32/vmware-user [0x80521ba]
#4 /usr/lib/vmware-tools/bin32/vmware-user [0x804f2e0]
#5 /usr/lib/vmware-tools/bin32/vmware-user [0x804f81d]
#6 /usr/lib/vmware-tools/bin32/vmware-user [0x804bbd3]
#7 /usr/lib/vmware-tools/bin32/vmware-user [0x806d8c8]
#8 /usr/lib/vmware-tools/bin32/vmware-user [0x8057225]
#9 /usr/lib/vmware-tools/bin32/vmware-user [0x804b9fd]
#10 /usr/lib/libglib-1.2.so.0 [0xb7d975a3]
#11 /usr/lib/libglib-1.2.so.0 [0xb7d97bfd]
#12 /usr/lib/libglib-1.2.so.0 [0xb7d9845f]
#13 /usr/lib/libglib-1.2.so.0(g_main_run+0x3f) [0xb7d985df]
#14 /usr/lib/libgtk-1.2.so.0(gtk_main+0xbf) [0xb7ca4e0f]
#15 /usr/lib/vmware-tools/bin32/vmware-user [0x804c400]
#16 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7a8e450]
#17 /usr/lib/vmware-tools/bin32/vmware-user [0x804b7c1]
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7a75767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb7a7581e]
#2 /usr/lib/libX11.so.6 [0xb7e085f8]
#3 /usr/lib/libX11.so.6(XQueryExtension+0x26) [0xb7df70c6]
#4 /usr/lib/libX11.so.6(XInitExtension+0x3b) [0xb7debe2b]
#5 /usr/lib/libXext.so.6(XextAddDisplay+0x53) [0xb7dbc443]
#6 /usr/lib/vmware-tools/bin32/vmware-user [0x80743a9]
#7 /usr/lib/vmware-tools/bin32/vmware-user(XPanoramiXQueryVersion+0x14) [0x807441c]
#8 /usr/lib/vmware-tools/bin32/vmware-user [0x80748ab]
#9 /usr/lib/vmware-tools/bin32/vmware-user [0x804f0c5]
#10 /usr/lib/vmware-tools/bin32/vmware-user [0x804f81d]
#11 /usr/lib/vmware-tools/bin32/vmware-user [0x804bbd3]
#12 /usr/lib/vmware-tools/bin32/vmware-user [0x806d8c8]
#13 /usr/lib/vmware-tools/bin32/vmware-user [0x8057225]
#14 /usr/lib/vmware-tools/bin32/vmware-user [0x804b9fd]
#15 /usr/lib/libglib-1.2.so.0 [0xb7d975a3]
#16 /usr/lib/libglib-1.2.so.0 [0xb7d97bfd]
#17 /usr/lib/libglib-1.2.so.0 [0xb7d9845f]
#18 /usr/lib/libglib-1.2.so.0(g_main_run+0x3f) [0xb7d985df]
#19 /usr/lib/libgtk-1.2.so.0(gtk_main+0xbf) [0xb7ca4e0f]

4)
dpkg -l libxcb-xlib0 libx11-6 libxext6 open-vm-tools-gui libglib1.2ldbl libgtk1.2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================================-======================================-============================================================================================
ii libglib1.2ldbl 1.2.10-19build1 The GLib library of C routines
ii libgtk1.2 1.2.10-18.1build2 The GIMP Toolkit set of widgets for X
ii libx11-6 2:1.1.3-1ubuntu1 X11 client-side library
ii libxcb-xlib0 1.1-1 X C Bind...

Read more...

adam kumpf (kumpf) wrote :

I just updated my system to the latest Hardy packages and stumbled upon this same issue. I am doing development with JOGL (Java OpenGL) and java crashes every time I try to run the program. Here's the output:

----------
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb4d16767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb4d168b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb4fec29d]
#3 /usr/share/jdk1.6.0_02/jre/lib/i386/xawt/libmawt.so [0xb09ed64e]
#4 /usr/share/jdk1.6.0_02/jre/lib/i386/xawt/libmawt.so [0xb09cbf97]
#5 /usr/share/jdk1.6.0_02/jre/lib/i386/xawt/libmawt.so [0xb09cc248]
#6 /usr/share/jdk1.6.0_02/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb09cc54f]
#7 [0xb5c9966e]
#8 [0xb5c91edd]
#9 [0xb5c91edd]
#10 [0xb5c8f243]
#11 /usr/share/jdk1.6.0_02/jre/lib/i386/client/libjvm.so [0x620bbbd]
#12 /usr/share/jdk1.6.0_02/jre/lib/i386/client/libjvm.so [0x630a6b8]
#13 /usr/share/jdk1.6.0_02/jre/lib/i386/client/libjvm.so [0x620ba50]
#14 /usr/share/jdk1.6.0_02/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x34b) [0x626190b]
#15 /usr/share/jdk1.6.0_02/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7caa96d]
#16 [0xb5c9966e]
#17 [0xb5c91d77]
#18 [0xb5c8f243]
#19 /usr/share/jdk1.6.0_02/jre/lib/i386/client/libjvm.so [0x620bbbd]
java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
----------

And here is my package version info...
---------
dpkg -l libxcb-xlib0 libx11-6 libxext6 libglib1.2ldbl libgl1-mesa-glx
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-====================-====================-========================================================
ii libgl1-mesa-glx 7.0.2-4ubuntu2 A free implementation of the OpenGL API -- GLX runtime
ii libglib1.2ldbl 1.2.10-19build1 The GLib library of C routines
ii libx11-6 2:1.1.3-1ubuntu1 X11 client-side library
ii libxcb-xlib0 1.1-1 X C Binding, Xlib/XCB interface library
ii libxext6 2:1.0.3-2build1 X11 miscellaneous extension library
------------

Timo Aaltonen (tjaalton) wrote :

adam: java is broken. Either use icedtea or the workarounds mentioned in /usr/share/doc/libx11-6/NEWS.Debian.gz.

Using icedtea ist not an option, since there is currently no javaws (webstart) binary...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers