[feisty] nvidia-glx 1.0.9xxx causes graphical glitches, artifacts and random system crashes on an integrated GeForce2 MX

Bug #85449 reported by MartinE on 2007-02-15
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.20 (Ubuntu)
Nominated for Feisty by Jeff Greene

Bug Description

Binary package hint: nvidia-glx

I tried using the nvidia-glx proprietary graphics driver on Ubuntu Feisty. However, the driver is completely unusable on my system, it messes up the entire screen with graphical noise and a lot of glitches, for example:

1) When scrolling up or down in any widget, the lines get mixed up. This applies to lists as well as textboxes and every other control that has scrollbars. I observed it in Gedit, Gnome Control Center, Synaptic, Gnome Terminal etc. pp.

2) Using the driver causes the System to crash withaut any apparent cause. I haven't been able to find any steps to reproduce these crashes, they seem to happen randomly.

3) The area that was obscured by a window or menu is not properly redrawn when the window is moved or the menu is closed. The formerly-obscured area is filled with graphical noise, every now and then mixing in what seems to be distorted pixmaps from some kind of cache (see below for the origin of these pixmaps)

4) The pixmaps that show up in these areas seem to originate from some kind of cache. For instance, on one occasion i spotted the background image from a website which i visited with firefox some minutes earlier. On another occasion, it showed what looked like a distorted screenshot of evolution, probably cached by the X server.

5) The most interesting observation is: This "screenshot" of evolution was actually from evolution running on Edgy Eft, wich is installed on another partition of the same machine. I was quite perplexed by this, but its a fact: I never configured evolution in Feisty, so there are no emails in my inbox. The "screenshot" however clearly showed emails that i had received earlier that day when running evolution on Edgy Eft. On this machine, Edgy and Feisty are installed in different partitions, but they share a swap partition. My guess is that Edgy's X server cached the pixmap of evolution, that it got stored in the swap partition, and that later, when I was running Feisty, it somehow was rendered onto the desktop instead of the background image.

This behaviour makes the proprietary nvidia driver unusable. The free nv driver works correctly, but using it means to completely sacrifice any 3D acceleration. I noticed these things in every 1.0.9xxx version of nvidia's driver that i have tried, including the driver currently included in ubuntu's repository (1.0.9631+ The 1.0.7xxx and 1.0.8xxx drivers worked flawlessly.

Painting random pixmaps from some X cache is also a serious security breach; showing a "screenshot" of evolution, with emails recently received by a different user running a different operating system installed in a different partition is clearly unacceptable.

I have added my xorg.conf, two screenshots, and a theora screencast to give you an impression of this bug. On one of the screenshots, you can spot a distorted pixmap of the Alacarte menu editor, which i opened and closed some minutes earlier. The title bar is clearly visible at the bottom of the image.

MartinE (martin-engbers-gmx) wrote :
description: updated
Jeff Greene (jeffgreene) wrote :

I am having a similar problem, but I do not know if it is the same.

Jeff Greene (jeffgreene) wrote :

In your xorg.conf file, you seem to be loading the "nv" driver, not the "nvidia" binary driver. Is this the same xorg.conf file that you have now? If it is, then this bug is mis-assigned.

MartinE (martin-engbers-gmx) wrote :

I'm sorry about that. I was *definitely* using the proprietary "nvidia" driver. The "nv" driver works fine on Feisty, "nvidia" is unusable. I guess I changed the xorg.conf entry to "nv" in order to file the bug without having to worry about system crashes, and forgot to edit it before posting here. So, below I have attached a version of the xorg.conf as I used it to get these results. The change from "nv" to "nvidia" is the only difference, however.

MartinE (martin-engbers-gmx) wrote :

I have a serious problem with using Feisty, since

1) The "nv" driver doesn't allow me to play any 3D games, use GL screensavers, or run XGL and Compiz. This is a serious regression from Edgy, and to be honest it's a showstopper for me. If it can't be fixed, I'll stay with Edgy.

2) The nvidia 1.0-96** drivers display random garbage, probably-sensitive information from other users, and are the cause of random system crashes.

3) The nvidia 1.0-8776 drivers, the latest version of nvidias driver to run properly on my hardware, does not compile on Feistys kernel. There is a patch available from nVidia for compiling 1.0-8776 on 2.6.19 kernels, but I was unable to compile it for Feisty's 2.6.20 kernels.

I understand that this is most likely an nVidia-problem, since I get the same graphics mess when I compile the driver from nvidia.com. I also understand that the driver is closed-source and Ubuntu has about no way to properly fix it.

However, may I kindly request that a working package of 1.0-8776 be made available on Feisty's repositories? I'm sure the build problems with 1.0-8776 and Feisty's kernel can be overcome if Canonical gets in touch with nVidia on the issue. We now know of at least two machines on which 1.0-96** has serious issues.

Jeff Greene (jeffgreene) wrote :

I am confirming this bug because it seems similar enough to mine and I have gotten the same results. I too have the same problems even after installing the drivers from nvidia. I would like to note that this did not occur in feisty until one patch came out, then everything stopped working. I believe it was around the time when the 2.6.20-5 kernel was out.

Changed in linux-restricted-modules-2.6.20:
status: Unconfirmed → Confirmed
Jeff Greene (jeffgreene) wrote :

I changing the status back to unconfirmed because this was caused by a hardware error (at least for me).

Changed in linux-restricted-modules-2.6.20:
status: Confirmed → Unconfirmed
paladin (paladinii) wrote :

I can third this problem - I get much screen garbage when running twinview on my nvidia 5200fx card. It can't run at native resolution (being 1600*1200), but if I downgrade the resolution to 1200*1024, it's fine albeit the aspect ratio seems off. Just thought I'd put in my two cents. FYI, until I upgraded from edgy yesterday, no problems.

Ronix (mkalus) wrote :

I also confirm a similar bug:

Until the 2.6.20-12 Kernel (older driver?), I could start X with nvidia with some minor problems (-> also applied to edgy):
- When stopping or restarting X (e.g. powering down), there was a frequent graphic corruption - I have framebuffers enabled, so there seems to be another problem.
- When not running with the nvidia-driver, the problem was gone.

With the 2.6.20-13 upgrade, I experience grevious problems:
- random system crashes (blackouts and automatic reboots): This happens after logging in. There is a short moment before the gnome loading panel is displayed, when I see a graphic corruption, then the display either gets ok or it crashes the whole system. Sometimes a system crash occurs after some while (using metacity).

I also tried this with a completely new Xorg.conf-File just replacing "nv" to "nvidia" - this caused the same effects, so it seems to be a driver problem.

I use the 2.6.20-13-generic SMP Kernel with the latest nvidia-glx-Driver on a LG M1 Pro - this means (according to lspci): nVidia Corporation G72M [GeForce Go 7400] (rev a1).

MartinE (martin-engbers-gmx) wrote :

@everyone, please note that this might be the wrong place to file this particular bug reports, since:

- nvidia-glx is a proprietary piece of software. The ubuntu developers have no access to its source code, and are thus unable to fix this this bug, unless the fault lies with the X server or the kernel, which seems unlikely.

- I filed this bug reports six weeks ago, and no ubuntu developer has ever responded to it.

- nVidia has its own Linux support forums, which are the appropriate place to complain about their nonfunctional product. Be warned: They, too, have not been, like, exceptionally helpful...however, here's the link to my bug report at the nvidia linux support forums. Be sure to read all former posts before you add a new comment.


Good Luck!

Sitsofe Wheeler (sitsofe) wrote :

For other people coming to this bug - this bug is probably tied to Martin's particular hardware. If you have a Geforce 5xxx or later then this bug almost certainly does not apply to you (because you have the option to use later drivers which NVIDIA actively release new versions of).

Unfortunately the open source nv driver has never supported 3D (even on Edgy and previous versions of Ubuntu). There is a reverse engineering effort called nouveau (http://nouveau.freedesktop.org/wiki/ ) to try and create open source drivers but who knows if they will ever succeed or have the speed of the closed ones. Without hardware specs it's going to be a tough process.

I suspect no Ubuntu developer responded to your bug because there is nothing that they can readily do about it. The amount of effort required to start investigating closed source driver issues is very high and the chance of resolving the issue in a successful fashion (or even establishing that the hardware if faulty) is very low for people without the source. You might find it helpful to read this: http://<email address hidden>/msg00657.html which talks about Ubuntu's binary driver policy.

To be honest, it looks like you did exactly the right thing and have pinned it down to a binary driver bug, filed it here and then contacted NVIDIA. Alas these problems occur and due to its binary nature only NVIDIA can help you quickly track down whether it's a hardware bug (that only manifests itself with the new drivers) or a driver issue. There is a VERY strong chance that this problem only shows up with your exact model of card (and possibly motherboard). As a last ditch effort you may want to try emailing nvidia-bugs (see http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/chapter-06.html ) with a very carefully crafted report (it is pivotal that it contains the report log and clear, highly reproducible steps that manifest the problem).

I'm not surprised that NVIDIA don't support all the different versions of their driver though - it would be a costly Q&A nightmare and for very little money in return. NVIDIA probably don't make money from supporting non-recent cards and their biggest and most profitable Linux customers probably don't use "old" card either...

Sitsofe Wheeler (sitsofe) wrote :

Just to rule something out, can you check that disabling powernowd as described in https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.20/+bug/109643/comments/9 doesn't make any difference?

Changed in linux-restricted-modules-2.6.20:
status: Unconfirmed → Needs Info
MartinE (martin-engbers-gmx) wrote :

First, thank you for your kind reply. I didn't intend to criticise the ubuntu developers for not answering this bug report. I understand very well that it's beyond their options to try and fix bugs in binary device drivers without access to source code.

I'm sorry, however, that I can no longer provide any help towards solving the problem - I sold that particular machine some days before the feisty release. I'm using a newer nVidia card now, which does not exhibit this behaviour. I'm probably going to unsubscribe from this bug.

Anyway, thanks for trying to help, I appreciate it.

Sitsofe Wheeler (sitsofe) wrote :

Setting back to unconfirmed as reporter no longer has this hardware. With the original reporter gone I would recommend closing this bug...

Changed in linux-restricted-modules-2.6.20:
status: Needs Info → Unconfirmed

I can confirm this bug but my problem is a bit different from what has been described above.
Here is my card description:

01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR] (rev b2) (prog-if 00 [VGA])
        Subsystem: ASUSTeK Computer Inc. Unknown device 4039
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 248 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at e6000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at e8000000 (32-bit, prefetchable) [size=128M]
        [virtual] Expansion ROM at e7ff0000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA- ITACoh- GART64- HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=28 ArqSz=0 Cal=0 SBA- AGP+ GART64- 64bit- FW- Rate=x4

Problem 1:
X refuses to load and shows a screen with B&W bars blinking.
Switch to another session (Crt+Alt+F1) and then switch back to the current session (F7) solves the problem but I have to do that every time X is loaded/reloaded.

Problem 2:
The 9639 driver causes artifacts on alpha channels. I can't fix this problem.

PS: Just for the record, it does matter if all extensions are disabled or enable, the problem persists.

Google Earth screenshot.

I forgot to mention that I'm using an add-on card so the description of the bug would have to change...

Update: I'm using the binary package from Nvidia's web site now and I'm getting the same errors that I described previously. The Sitsofe comments are right. This problems should be reported directly to them (Nvidia).
Thanks for your time.

I have been making some tests and it turns out that my mobo seems to be causing the issue. Set AGP to 1X fixed the problem.

Juliano Zaban (julianozaban) wrote :

Sorry to all developers, but I have to disagree that is a nvidia-glx driver bug. I explain: this driver works pretty fine on Ubuntu 6.06 (I'm using it now), but don't works only in Feisty Fawn... I've opened a new bug report a few minutes exactly about this issue. There some difference between 6.06 and 7.04 that is causing this problem with some NVidia's video cards.
I have a ASUS A7N266-VM motherboard with nForce 2 chipset (with a GeForce2 MX integrated) and I'm having the same problem: glitches, artifacts and random system crashes reported in this bug, but only in Feisty. Previous versions, I repeat, works fine.

Thanks a lot.

This is a closed source driver. Ubuntu developers have no access to the source so I'm afraid nothing could be done here.
You should try the fixes described above. If nothing works for you, head to the Nvidia's support forum. They will be able help you there.

Daniel T Chen (crimsun) on 2008-09-21
Changed in linux-restricted-modules-2.6.20:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers