fglrx 3d rendering fails after latest feisty upgrade - fallback to Mesa

Bug #76278 reported by Trond Thorbjørnsen on 2006-12-18
This bug report is a duplicate of:  Bug #76135: fglrx module unknown symbol. Edit Remove
2
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg-driver-fglrx

After upgrade this weekend, 3d rendering stopped working.

$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

Mesa is loaded, despite that the following exists in xorg.conf

Section "Extensions"
        Option "Composite" "Disable"
EndSection

An excerpt from Xorg.0.log, tells us that this probably has to do with dri... ?

(EE) AIGLX: Screen 0 is not DRI capable
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
        compiled for 7.1.1, module version = 1.0.0
        ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0

$ lspci |grep -i rade
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400

Laurent Bigonville (bigon) wrote :

Thanks for the bug report. This particular bug has already been
reported into our bug tracking system, but please feel free to report
any further bugs which you find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers