Color Balance settings have no effect on the output

Bug #34659 reported by aamukahvi on 2006-03-12
26
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-restricted-modules-2.6.20 (Ubuntu)
Low
Unassigned

Bug Description

Totem preferences --> Display tab --> Color balance

These settings do nothing. I cannot change brightness or anything. I'm using totem-xine and libxine-extracodecs.

aamukahvi (aamukahvi) wrote :

Elaboration: I can move the sliders, but to no effect. And, I'm on Dapper.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? What videocard do you have? What xorg videodriver do you use?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Ben Pregont (starnix) wrote :

I am getting the exact same behavior:

Dapper Flight 5
Nvidia Quadro NVS 280 PCI 64mb.
Nvidia Binary Drivers 1.0-8178
Default Video Output Plugin "XWindows (NoXV)" (I've tried the other options but they produce even worse results)
Default Audio Output Plugin "Alsa"

I do have xcompmgr running with composite enabled in xorg.conf. I am using the GLX extension, however I am not using the "dri" option.

I have the "RenderAccel" and "AllowGLXWithComposite" options enabled.

Here's the difference. I am using Totem 1.4.0 Using GStreamer .10.4. I have the gstreamer-ffmpeg package installed.

I do have the Win32 codecs installed. I am not sure if that matters or not.

aamukahvi (aamukahvi) wrote :

Sebastian:

I'm using Ubuntu 6.06 with the latest updates (dist-upgraded from Breezy).
Geforce 6200 256MB (non-Turbocache)
Nvidia binary drivers (1.0-8178) from repo
Video output using Xv

I'm currently running Xgl+Compiz, but it was no different with X.org.

Here's something from xorg.conf:
Section "Module"
# Load "GLcore"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "v4l"
 Load "vbe"
EndSection

Section "Device"
 Identifier "Nvidia Geforce 6200"
 Driver "nvidia"
 BusID "PCI:1:0:0"
 Option "NoLogo" "true"
 Option "NvAGP" "3"
 Option "RenderAccel" "true"
        Option "AllowGLXWithComposite" "true"
EndSection

Sebastien Bacher (seb128) wrote :

Does it happen if you don't use the composite options and the nv driver instead of nvidia?

aamukahvi (aamukahvi) wrote :

I can confirm it works now with nvidia-glx 1.0.8756. No changes made to xorg.conf. You can probably close this bug.

aamukahvi (aamukahvi) wrote :

Hold it! It still doesn't work with Xv output. The settings only work when using OpenGL output.

(Specified video.driver=opengl in ~/.gnome2/totem_config)

aamukahvi (aamukahvi) wrote :

And with the nv driver the problem persists. AllowGLXWithComposite disabled.

Sebastien Bacher (seb128) wrote :

Does it happen with totem-gstreamer and xine-ui too?

aamukahvi (aamukahvi) wrote :

It happens in totem-gstreamer. I cannot comment on xine-ui, because I couldn't change the settings at all.

I clicked on the icon with sliders (in the controls window) and up came the brightness contrast hue etc settings (+skin). When I tried to move the sliders, the whole window would move. Then again, I'm not even sure they're the settings for the picture. First time using xine-ui and that's all I could find.

Sebastien Bacher (seb128) wrote :

Do you still have the issue?

aamukahvi (aamukahvi) wrote :

Yes. I tried with totem-gst and totem-xine, only t-x works.

Changed in totem:
status: Needs Info → Unconfirmed
Lionel Dricot (ploum) wrote :

Here, with the proprietary Nvidia driver, color balance works fine with totem-gstreamer if the Video sink is set to "autodetect" in gstreamer properties.

If you manually set the sink to "No Xv", then I can confirm that color balance will have no effect.
I confirm and set this as a minor bug because not everyone wants to change the Sink to No Xv.

BTW, the reset button in the color balance has a little bug I've reported upstream ;-)
http://bugzilla.gnome.org/show_bug.cgi?id=343378

Changed in totem:
status: Unconfirmed → Confirmed
Guillaume Desmottes (cassidy) wrote :

This bug is still present in Edgy.
I tried with nv and nvidia driver and have the same problem with both drivers.

Lionel could you try again please (i suppose you're using Edgy now :) ?

kripken (kripkenstein) wrote :

I have this problem as well. Things were fine on Dapper with the nvidia binary drivers, but on Edgy (again with "nvidia" drivers) this bug occurs for me, both on Totem and gXine.

Arif Lukito (arifl) wrote :

Hi, disabling composite fixes it for me.

Hallo.
I also have this problem, none of the sliders change a thing. I have the problem with totem-xine only, with totem-gstreamer or xine-ui it works fine.

Ubuntu 6.10 Edgy Eft (Upgrade from Dapper Drake)
Nvidia Gforce 4 (using nvidia-glx)

P.s.: Tried to change video.driver to opengl (as mentioned above), doesn't help. Composite is also disabled.

RobertZenz (robert-zenz) wrote :

To that thing with that opengl.
It seems like that the file gets rewritten everytime I start totem...means he always overwrites my setting to opengl with auto.

Don't know if this has anything to do with it.

kripken (kripkenstein) wrote :

This bug is still present in Feisty (clean install).

Remus Boara (rem) wrote :

Same here on Feisty (fresh install)... with proprietary nvidia driver if set on Xv. It is working with Opengl though but the subtitles are displayed above the black border (very close to the middle of the screen).

Changed in totem:
assignee: desktop-bugs → nobody
Ramaddan (ramaddan) wrote :

I confirm this problem here as well.

I am using Ubuntu Feisty 7.04, with nVidia propriety drivers for nVidia GeForce 7600 GS.

Nothing I do makes it possible for me to change Brightness, Contrast, or any of those.

kripken (kripkenstein) wrote :

This bug is still present in Gutsy, Release Candidate.

As in Feisty and Dapper, the brightness/contrast controls in Totem work fine when using the "nv" driver, but when using the binary nvidia driver they have no effect whatsoever.

Still present in the fully updated 64-bit 8.10. Nvidia binaries here too.

Aaron Plattner (aplattner) wrote :

The Xv texture adaptor doesn't have color controls on GeForce 6 and 7 series GPUs. For GPUs that also have an overlay adaptor, that has color controls but is disabled when the Composite extension is enabled, which is by default. If there's a bug here, it's that Totem presents the color control UI elements when the underlying hardware doesn't support them. It should be querying the adaptor to see if it supports the XV_HUE, XV_BRIGHTNESS, etc. attributes. You can use xvinfo to get a list of the available adaptors and their supported attributes.

lcn_mustard (lcn-mustard) wrote :
Download full text (7.7 KiB)

Adjustments of I shine & clash no it works. I use the totem.Ajuda groan we!?! hello Acabei of installing the ubuntu 8.04 on a pcchips a15g all is OK with excessão of the totem. The controls of I shine & clash do not have a effect. Already I gave the the next commands :

sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update

sudo aptitude install ubuntu-restricted-extras nautilus-script-audio-convert totem-xine cpdvd regionset x264 gqmpeg mp3gain mjpegtools libdvdread3 mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg cdda2wav toolame libmp4v2-0 lame lame-extras libmad0 libjpeg-progs libmpcdec3 libquicktime1 flac faac faad sox toolame ffmpeg2theora libmpeg2-4 uudeview flac libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev a52dec gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-farsight gstreamer0.10-plugins-ugly gstreamer0.10-sdl gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly-multiverse rar unrar unace p7zip p7zip-full p7zip-rar arj unzoo lha mencoder libxine1-plugins libxine1-ffmpeg

sudo update-alternatives --config totem escolhi o totem xine mas parece ter ficado dividido, asteristico marcando para um e sinal de + para outro.

sudo apt-get install totem-xine
sudo apt-get remove totem totem-gstreamer
*******************************
Like doing about to use barely the totem xine & I shine & clash I'll be functioning? Does that you have relation with the xorg? thank you

*******
resposta do xvinfo:

~$ xvinfo
X-Video Extension version 2.2
screen #0
Adaptor #0: "NV17 Video Texture"
number of ports: 32
port base: 203
operations supported: PutImage
supported visuals:
depth 16, visualID 0x21
depth 16, visualID 0x23
depth 16, visualID 0x24
depth 16, visualID 0x25
depth 16, visualID 0x26
depth 16, visualID 0x27
depth 16, visualID 0x28
depth 16, visualID 0x29
depth 16, visualID 0x2a
depth 16, visualID 0x2b
depth 16, visualID 0x2c
depth 16, visualID 0x2d
depth 16, visualID 0x2e
depth 16, visualID 0x2f
depth 16, visualID 0x30
depth 16, visualID 0x31
depth 16, visualID 0x32
depth 16, visualID 0x33
depth 16, visualID 0x34
depth 16, visualID 0x35
depth 16, visualID 0x22
depth 16, visualID 0x36
depth 16, visualID 0x37
depth 16, visualID 0x38
depth 16, visualID 0x39
depth 16, visualID 0x3a
depth 16, visualID 0x3b
depth 16, visualID 0x3c
depth 16, visualID 0x3d
depth 16, visualID 0x3e
depth 16, visualID 0x3f
depth 16, visualID 0x40
depth 16, visualID 0x41
depth 16, visualID 0x42
depth 16, visualID 0x43
depth 16, visualID 0x44
depth 16, visualID 0x45
depth 16, visualID 0x46
depth 16, visualID 0x47
depth 16, visualID 0x48
number of attributes: 3
"XV_SET_DEFAULTS" (range 0 to 0)
client settable attribute
"XV_ITURBT_709" (range 0 to 1)
client settable attribute
client gettable attribute (current value is 0)
"XV_SYNC_TO_VBLANK" (range 0 to 1)
client settable attribute
client gettable attribute (current value is 1)
maximum XvImage size: 204...

Read more...

Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Feisty Fawn 7.04 has reached its end of life some months ago. As a result, we are closing the linux-restricted-modules-2.6.20 task. It would be helpful if you could test the
new Jaunty Jackalope 9.04 release and confirm if this issue remains -
http://www.ubuntu.com/getubuntu/releasenotes/904overview. If the issue still exists with the Jaunty
release, please update this report by changing the Status of the "linux (Ubuntu)". Thanks in advance!

Changed in linux-restricted-modules-2.6.20 (Ubuntu):
status: Confirmed → Won't Fix
Sergio Zanchetta (primes2h) wrote :

Sorry, there is a part missing on my last comment. The complete one is:

The 18 month support period for Feisty Fawn 7.04 has reached its end of life some months ago. As a result, we are closing the linux-restricted-modules-2.6.20 task. It would be helpful if you could test the
new Jaunty Jackalope 9.04 release and confirm if this issue remains -
http://www.ubuntu.com/getubuntu/releasenotes/904overview. If the issue still exists with the Jaunty
release, please update this report by changing the Status of the "linux (Ubuntu)"
task from "Incomplete" to "New". Thanks in advance!

Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers