New feisty 64bit install causes nvidia card failure

Bug #110361 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2007-04-26
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.20 (Ubuntu)

Bug Description

For months I have had 32-bit Feisty on one disk, decided to install 64-bit feisty on another.
Used the desktop CD, enabled nvidia in restricted modules manager thing before running the graphical installer.
Once installed, rebooted. Blank screen. Both screens report "No signal".
Machine does boot, and i have managed to login then install ssh "blind" and ssh into it.
Noted linux-restricted-modules-`uname -r` wasn't installed, so installed it and restarted X (all done via ssh).

Rebooted, still blank - blank from power up. No display at all.

Note: The machine is blank right from power up. I know this sounds like hardware failure, but this box has been fine for months, I find it too much of coincidence that *both* video cards should fail after an install of Feisty 64-bit. I know logic dictates that this stuff should not cause hardware failure, but the fact is it's blank from boot to X. I have removed one card (they were in SLI, now not, now only one card).

This is a core2duo based machine with twin NVidia 7900GTs, now only one. Two Viewsonic displays connected to one card via DVI. The only thing that I can think is that the nvidia blob put the cards into an odd state.

I am going to shut this down, leave the power disconnected and see if the card resets or some other magic. Other than that I have warranty on the cards and can get them replaced, but this shouldn't happen of course.

Under the expert guidance of the Nvidia support forums:-

I have now remove/purged nvidia-glx (9631) and installed nvidia-glx-new (9755).

Unsurprisingly I still get no output to the displays whilst the machine boots (POST) or indeed in xwindows.

Attached the xorg.0.log from the last time I booted 32-bit feisty (a little before I installed 64-bit feisty on the other disk).

This was running nvidia-glx perfectly fine.

Sitsofe Wheeler (sitsofe) wrote :

Thanks for your bug report.

This is an extremely thorough bug report - all the logs and files are already here. Utterly fantastic! Unfortunately you went on to manually installed the binary drivers so no longer makes sense to report problems to this part of launchpad I'm afraid. See for hints about better places to ask queries about manual installs. However before I vanish I do have two suggestions:

Can you file a new bug about the lack of a display when the kernel boots? That has nothing to do nvidia binary drivers so it definitely belongs here. It may also be worth temporarily removing "quiet splash" from the end of the kernel line in the grub boot menu (e edits entries, and b can be used to boot an edited entry) and seeing whether you see anything. This should turn off the splash screen and leave you card in the default BIOS resolution...

Back on the nvidia binary X thing, does adding
Option "UseDisplayDevice" "DFP"
to the Screen section of /etc/X11/xorg.conf makes any difference after X starts? It's a long shot and you are on the manual drivers now but I guess you never know...

Thanks for the kind words and prompt reply. I know how frustrating a lack of information can be (I answer support tickets in launchpad).

Just to clarify, this problem _started_ at the point I installed Ubuntu Feisty 64-bit with the NVidia driver 9631 from the Ubuntu repository.

As far as the driver goes, I can easily remove the manually installed driver and go back to nvidia-glx (9631) or nvidia-glx-new (9755) to comply with requirements to get support through launchpad, and will flick back to the manual driver to get support from NVidia if that is required. I can easily switch between the drivers - I have had quite a bit of practice over the years ;)

I get _nothing_ on the display _from_ _boot_. No BIOS splash, no memory count, no scan of USB devices - nothing at all. This is all before grub / linux loads. The flat panels indicate there is no signal. I refuse to believe that it is merely hardware failure of _both_ cards at the same time. I am more willing to suspect that the 9631 driver has done "something" to the cards, put them into a funny state.

My main gripe is that this was a plain blank install of Ubuntu, all I did is what anyone who has two displays and would like twinview to work would do, install the binary driver from the repository. That's when it all went wrong.

I will give the UseDisplayDevice option a try and report back.

Sitsofe Wheeler (sitsofe) wrote :

You can't even see grub? Well assuming it was set to appear that definitely needs a bug of its own. If you used to be able to see grub and no longer can that suggests something quite severe along the lines of hardware failure (e.g. disk corruption). How do you know your system even still boots?

Sitsofe Wheeler (sitsofe) wrote :

Hmm just reread - no BIOS splash! That's pretty bad. Nothing the nvidia binary driver can do should last over a reboot though (of course I don't know whether it is capable of flashing the video BIOS but I'd be highly surprised). I can't even begin to imagine what's happened here but I'd get in contact with NVIDIA ( ) about this ...

Have you checked the cabling on the card itself? You might want to try reseating your card and reattaching all cables just in case...

I can't see anything at all, imagine you had unplugged the screen and booted a PC. That's what I see :)

I know it boots because I waited until the disk went idle and switched to a console - blind - and logged in, installed an ssh server and can now ssh in quite happily.

The box is definately up and running or i would not have been able to post all the logs as attachments that I have.

I know it sounds like hardware failure, but the fact that it started the second I installed nvidia-glx makes me suspicious that either the cards have failed _because_ of something that driver did, _or_ the driver put the cards in some kind of odd state.

I have taklen the xorg.conf from my 32-bit install (on the other disk) and have started X with that, and with the option you suggested. I am still not hopeful. Clearly I could get a replacement card, bug if the nvidia driver _is_ to blame for this hardware malfunction, then how can I be sure it wont happen again with another nvidia card?

Right now i am sat at work and the box is at home, so I need to wait for my wife to get home before I can ask her to look at the screen and tell me if she sees anything.

The machine has two 7900GTs in SLI mode. I have removed both and reseated just one. Both 20" flat panel displays are connected to one card - the only card in the machine right now.

I have reverted back to nvidia-glx-new (9755) and have attached the xorg.log from the current reboot. I copied the xorg.conf from my 32-bit install to the 64-bit install and have attached the resulting xorg.log. This worked fine under 32-bit before I installed 64-bit Ubuntu.

Latest nvidia-bug-report.log being sent to Nvidia

Sitsofe Wheeler (sitsofe) wrote :

Not that this is going to help but how do you know its the cards and not the monitors?

I managed to get this working by changing the cables used. Here's the time line:-

32-bit feisty working with one 7900GT with two 20" DFPs connected to the two connectors on the card using DVI to DVI cables

Install 64-bit feisty, the installer works, but the second I enable the nvidia driver it goes blank

Lots of wailing and gnashing of teeth.

Remove DVI cables, replace with DVI to VGA adapters plugged into the card, and then VGA to VGA cables to the same panels.

All works under 32-bit feisty, but I have not tackled 64-bit yet.

Sitsofe Wheeler (sitsofe) wrote :

OK I've just subscribed to this bug because I want to know what happens in the next instalment of this saga. Why does the VGA cable work? Will the monitors ever work with DVI again? Does Alan have any teeth left after the gnashing incident?

Sitsofe Wheeler (sitsofe) wrote :

Setting to needsinfo pending reply from Alan.

Changed in linux-restricted-modules-2.6.20:
status: Unconfirmed → Needs Info
Launchpad Janitor (janitor) wrote :

[Expired for linux-restricted-modules-2.6.20 (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers