Ubuntu

DISABLED_MODULES="nv" doesn't stop nvidia_new.ko from loading

Reported by heckheck on 2007-04-12
10
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-restricted-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-restricted-modules-common

The /sbin/lrm-manager script is allowing the new nvidia_new.ko driver to be loaded when DISABLED_MODULES="nv" in /etc/default/linux-restricted-modules-common. The case statement for 'nv' in this script needs to have the nvidia_new name added , so that this driver will not get loaded along with the nvidia and nvidia_legacy driver.

lines 53-56 from the script
      nv)
        set -- $@ nvidia nvidia_legacy
        shift
        ;;
should be
      nv)
        set -- $@ nvidia nvidia_legacy nvidia_new
        shift
        ;;

I found this when I booted my generic 2.6.20-14-generic kernel and the driver got loaded. I have the nvidia_glx_new package installed.

This worked fine for me.
Ubuntu 7.04 feisty x386 - 2.6.20-15-generic
nvidia official driver 100.14.06

Sitsofe Wheeler (sitsofe) wrote :

p4bl0:
But do you have the nvidia-glx-new package installed? If you only have nvidia-glx installed then this problem will not occur.

Hello Sitsofe Wheeler :

No, i dont have the nvidia-glx-new package. I installed a fresh copy of ubuntu 7.04 in my machine and tried the new official beta drivers of nvidia and worked fine until reboot, when a gdm error appears saying that the api mismatch. So i tried editing the /etc/default/linux-restricted-modules-common file with DISABLED_MODULES="nv", but the error was still there. Finally editing the /sbin/lrm-manager worked fine for me.

pablo@pablo-desktop:~$ uname -a
Linux pablo-desktop 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux
pablo@pablo-desktop:~$ sudo dpkg --list | grep -i nvidia
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files
pablo@pablo-desktop:~$

Sitsofe Wheeler (sitsofe) wrote :

p4bl0:
You need a reboot after making changes to /etc/default/linux-restricted-modules-common .

Please be aware that editing /sbin/lrm-manager makes your system unsupportable by bugs.launchpad.net. Please avoid reporting any problems that you may have after such an extensive change in bugs.launchpad.net and instead use one of support methods described on http://www.ubuntu.com/support/communitysupport ...

Sitsofe Wheeler (sitsofe) wrote :

Another short term workaround for this might be to use
DISABLED_MODULES="nv nvidia_new"

Chris Halse Rogers (raof) wrote :

Still occurs in Gutsy with l-r-m-c 2.6.22.2-7.2. Since we provide the DISABLED_MODULES functionality, it seems reasonable that it should work as described in the /etc/default/linux-restricted-modules-common file.

Changed in linux-restricted-modules-2.6.20:
status: New → Confirmed
Changed in linux-restricted-modules-2.6.22:
status: New → Confirmed
Changed in linux-restricted-modules-2.6.22:
assignee: nobody → ubuntu-kernel-team
Changed in linux-restricted-modules-2.6.20:
assignee: nobody → ubuntu-kernel-team
Sitsofe Wheeler (sitsofe) wrote :

(Subscribing Alberto)

Alberto:
Any chance you can whip up a patch for this issue too?

Alberto Milone (albertomilone) wrote :

Can anyone affected by this problem post the output of this command?
ls /lib/linux-restricted-modules/.nvidia*

NOTE: it's .nvidia (with the dot) and not just nvidia

Jan Eppo Jonker (j-e-jonker) wrote :

I have been affected by this problem quite a few times.The above workaround
DISABLED_MODULES="nv nvidia_new"
always helps me.

feisty
$ uname -rm
2.6.20-16-generic x86_64
$ ls /lib/linux-restricted-modules/.nvidia*
/lib/linux-restricted-modules/.nvidia_new_installed

Timo Aaltonen (tjaalton) wrote :

linux-restricted-modules-2.6.22 (2.6.22.4-13.6) gutsy; urgency=low

  * Make 'nv' in /etc/default/linux-restricted-modules-common disable
    nvidia_new as well.

 -- Colin Watson <email address hidden> Fri, 05 Oct 2007 20:40:06 +0100

Changed in linux-restricted-modules-2.6.22:
assignee: ubuntu-kernel-team → nobody
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

I'm sure this won't be updated for feisty.

Changed in linux-restricted-modules-2.6.20:
assignee: ubuntu-kernel-team → nobody
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers