Ubuntu

With nVidia GeForce 6200 AGP, Ubuntu 6.10, nvidia-glx, Hibernate and Suspend fail

Reported by Alexandre Gatelli on 2006-11-14
8
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nvidia-glx

After the install nvidia-glx and run the utility nvidia-xconfig for setup the system for use the new video driver, the Hibernate and the Suspend don't resume video anymore. Following the tutorials for solve the problem, nothing help. This problem occur with a nVidia GeForce 6200 AGP with 256 MB of the video RAM. Setting the system for use the agpgart module or a NvAGP driver provided for nvidia-glx packge, the problem continue unsolved. The motherboard is a Asus A7N8X-XE with nVidia nForce2 chipset (compatible with NvAGP driver).

Thomas McGowan (paddy1978) wrote :

I'm having what sounds to be the same problem. With a clean (Kubuntu) Edgy install, suspend/hibernate worked OK. After installing 'nvidia-glx', they don't work - suspend/hibernate appears to take place, but on resume the screen just stays blank and the system is unresponsive.

I'm using an NVidia GeForce4 MX 4000 AGP 8x (with 64Mb ram I think), on a machine with an AMD Athlon XP 1700+ and 1Gb ram. The motherboard is an Epox EP-8RGA with nVidia nForce 2 chipset.

Peter Whittaker (pwwnow) wrote :

Thanks this bug report. To make progress, additional information is required.

Please attach (by commenting on the bug) to the bug report the output of the following commands:

uname -a

sudo lspci -vv

sudo lspci -vvn

sudo dmidecode

It would also be helpful if you could try to hibernate/suspend and after that fails, restart your system and attach /var/log/kern.log.0 as well.

Since there will be a lot of output, please do be sure to attach rather than commenting -in-line. Thanks again!

Changed in linux-restricted-modules-2.6.17:
status: Unconfirmed → Needs Info
Thomas McGowan (paddy1978) wrote :

The additional information requested is included in the attached text file.

Strangely, I couldn't get the PC to hibernate this time - so this output is following a suspend and (failed) resume. Not sure why it will no longer try to hibernate as I don't think I've changed anything, but perhaps some update has done something since the original bug report..?

If it would help, I can always try getting the same info on a clean install with/without the nvidia-glx drivers as I have a free partition.

Hope this helps - let me know if you need any more info.

Peter Whittaker (pwwnow) wrote :

Marking as confirmed based on availability of requested logs.

Changed in linux-restricted-modules-2.6.17:
status: Needs Info → Confirmed
Ketil Malde (ketil-ii) wrote :

I had the same problem. Setting SAVE_VBE_STATE and POST_VIDEO to false solved the problem - although I need to switch to a console (Shift-Ctrl-F1) and back (Ctrl-7) to get the display.

See also:

https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/34043

Ketil Malde (ketil-ii) wrote :

Alas, I spoke too soon. I'm not sure exactly when resume works and when it doesn't, but my current workaround is to switch to a text console before suspending. On resume, the display will be blank, but switching to console 7 will produce the right X display.

-k

PS: Could this be related to #149714 and #34043?

vmagnin (vincent-magnin) wrote :

I have a similar problem using :
- Asus A7N8X Deluxe motherboard (nForce 2 chipset)
- Nvidia GeForce FX 5200 (AGP)
- proprietary nvidia-glx driver
- Ubuntu 7.10 (Linux version 2.6.22-14-generic)

When I try to resume from hibernation, I obtain a black screen. Impossible to obtain a console.
When I try to suspend, I obtain a black screen, and nothing seems to be suspended in my PC (the screen is on, the motherboard is on (I hear all fans, the LED is on...)

I did not try to uninstall the nvidia-glx driver (because I am afraid to have problems rotating (90°) my screen when reinstalling it). So I do not know if the problem comes from it.

I attached my dmesg results.

Vincent

vmagnin (vincent-magnin) wrote :

I just found an option in my A7N8X BIOS to enable "suspend to ram". Now I can suspend to ram, but I can still not resume from suspend: I obtain a black screen (like with hibernation), and a lot of access to the hard drive.

vmagnin (vincent-magnin) wrote :

Same problem after upgrading to Ubuntu 8.04 with 2.6.24-16.30-generic linux kernel: black screen when resuming from hibernation.

vmagnin (vincent-magnin) wrote :

I uninstalled the nvidia-glx driver and now I can resume from hibernation.
But I need that driver to rotate my screen.

Timo Aaltonen (tjaalton) wrote :

Ubuntu 6.10 is obsolete by now, so closing the bug as WONTFIX.

there should be other bugs against 8.04, if not please file a new one.

Changed in linux-restricted-modules-2.6.17:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments