Ubuntu

Module fglrx isn't loaded

Reported by Kenneth Mokkelbost on 2006-10-04
24
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.17 (Ubuntu)
Undecided
Scott James Remnant (Canonical)

Bug Description

1. Update to version 2.6.17.5-8
2. Reboot

lsmod reports fglrx not loaded even though fglrx is used as driver in xorg.conf and needs to be loaded manually.

What do you get when you run "modprobe fglrx" by hand?

Please supply /var/log/udev and the output of "modinfo fglrx"

Assuming you have /usr on a separate partition, this is fixed by linux-restricted-modules-2.6.17_2.6.17.5-9

Changed in linux-restricted-modules-2.6.17:
assignee: nobody → keybuk
status: Unconfirmed → Fix Released
Kenneth Mokkelbost (kmokk) wrote :

I have /usr on a separate partition, but upgrading to .5-9 doesn't solve the issue. I still have to modprobe fglrx by hand.

Kenneth Mokkelbost (kmokk) wrote :
Kenneth Mokkelbost (kmokk) wrote :

"modprobe fglrx" run by hand doesn't output any information, but loads the module as expected.

Kenneth Mokkelbost (kmokk) wrote :

Sorry, but I mixed things up a little in one of my comments.

/usr is not on a separate partition (but /boot is), so the fix in .5-9 doesn't apply for my problem.

Setting status back to unconfirmed.

Changed in linux-restricted-modules-2.6.17:
status: Fix Released → Unconfirmed
Diane Cochran (dianeofthemoon) wrote :

I'm also having this issue, and from the posts I've seen on ubuntuforums, there are quite a few people running into this problem, as well.

Everything seems to install just fine, but it appears that the kernel module doesn't load when the xorg driver loads...so you have to do a modprobe and restart X to get OpenGL.

Then this has nothing to do with my change

Changed in linux-restricted-modules-2.6.17:
assignee: keybuk → nobody
Jim Paris (jim-jtan) wrote :

Yeah, I think it does:
  $ X >/tmp/foo 2>&1
  $ grep -A1 ^sh /tmp/foo
  sh: sed: not found
  sh: grep: not found
  Not loading fglrx module; not used in /etc/X11/xorg.conf
  sh: sed: not found
  sh: grep: not found
  Not loading fglrx module; not used in /etc/X11/xorg.conf
  $ which sed
  /bin/sed
  $ which grep
  /bin/grep
The modprobe action is running with PATH=/sbin at that point, so you need full paths in /etc/modprobe.d/fglrx.

Also, for some reason I don't yet understand, it still says fglrx is not used after adding full paths to grep & sed, probably some quoting issue or something. I just removed /etc/modprobe.d/fglrx and it started loading the module.

Jim Paris (jim-jtan) wrote :

BTW that seems like a bogus check anyway; you could easily be running multiple X servers with different config files.

Kenneth Mokkelbost (kmokk) wrote :

Ok, I think I've found a solution that works. At least it works on my computer.

I removed "install fglrx" from "install fglrx if cat ..." and a ^ inside the regexp of /etc/modprobe.d/fglrx. I also had to add " | grep -v "#" | " for those cases where fglrx is commented out in xorg.conf but should not be loaded.

Please review this fix.

Sean Taylor (verixx) wrote :

I'm not quite sure how well that works. When I run modprobe fglrx after modifying the modprobe.d fglrx file, I get this:

WARNING: /etc/modprobe.d/fglrx line 2: ignoring bad line starting with 'if'

So doesn't that just skip attempting to load the driver with modprobe altogether? Or am I reading this error message wrong?

Kenneth Mokkelbost (kmokk) wrote :

I think you're reading the error message right, but are you sure you don't have a typo in there somewhere? I don't get any warnings when I run my uploaded (and now downloaded) file.

Kenneth Mokkelbost (kmokk) wrote :

OK. I have the warning message, just didn't notice it before since I was rebooting from a remote location earlier. My bad.

When I put "install fglrx" in at the beginning of the line the message disappears but whatever the statement behind if is it jumps to "else", but when I drop "install fglrx" it handles the "if" correctly.

Test case:
Edit /etc/modprobe.d/fglrx to read

install fglrx if /bin/grep -i driver /etc/X11/xorg.conf; then echo "OK" > /log; else echo "Not OK" > /log; fi

reboot and check /log

What do you get?

Then do "sudo modprobe fglrx". Check /log again. What does it say now?

Sean Taylor (verixx) wrote :

Rebooting and checking /log yields: /log: No such file or directory
Modprobing fglrx and checking /log yields: OK

How strange.

Sean Taylor (verixx) wrote :

Oh! It must not have been able to find the /log file when I first rebooted. After rebooting this time, it tells me "Not OK."

mc44 (mc44) wrote :

I'm also not getting fglrx loading automatically, with the latest update 2.17.5-9

It does work when sudo modprobe fglrx is run manually. Don't have a separate /usr partition

This was working until the last couple of updates. I'm not sure why these changes were made for fglrx anyway, I thought mjg59 said it was only the nvidia drivers which casued suspend/resume problems if they were loaded.

Changed in linux-restricted-modules-2.6.17:
status: Unconfirmed → Confirmed
mc44 (mc44) wrote :

Removing fglrx in /etc/modprobe.d/ and running update-modules results in the module being loaded fine on boot, but putting this file back causes it to not be loaded again, it can still be modprobed by hand afterwards.

Is there anything else I can do to debug this?

mc44 (mc44) wrote :

Assigning back to Scott as apparently it might have to do with your change (!). Many apologies if this is the incorrect thing to do.

Changed in linux-restricted-modules-2.6.17:
assignee: nobody → keybuk

Fixed by Adam

Changed in linux-restricted-modules-2.6.17:
status: Confirmed → Fix Released
Rouben (rouben) wrote :

This bug seems to still persist... When was the fix released? Which version of restricted-modules is the fix expected?

nclm (nclm) wrote :

Same here

Rouben (rouben) wrote :

Proposed fix (not sure if this is the *proper* way to do this): add fglrx on a separate line to /etc/modules. Mine looks like this now, and seems to have solved the issue:

-- START --
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
fglrx
-- END --

My guess is this change to /etc/modules needs to be implemented through the linux-restricted-drivers package (post-install script?), assuming this is the proper way to do this (just because it works doesn't mean that it's the right way to accomplish something).

Txukie (albertodetena) wrote :

Adding fglrx to /etc/modules fixed it for me

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers