no dri cannot init AGP in 2.6.17-10 AMD64

Bug #62547 reported by tamasrs on 2006-09-27
10
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.17 (Ubuntu)
High
Ben Collins
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

Kernel Linux ubuntu 2.6.17-10-generic #2 SMP.
No DRI ( after update -- last working kernel 2.6.17-8-generic)
linux-restricted installed, also tried original ati ---install fine

EROR:

(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP

full error message:

 II) fglrx(0): Depth moves disabled by default
(==) fglrx(0): Capabilities: 0x00000000
(==) fglrx(0): CapabilitiesEx: 0x00000000
(==) fglrx(0): cpuFlags: 0x4000001f
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
(==) fglrx(0): UseFastTLS=0
(==) fglrx(0): BlockSignalsOnLock=1
(==) fglrx(0): EnablePrivateBackZ = NO
(II) fglrx(0): UMM Bus area: 0xe0954000 (size=0x076ac000)
(II) fglrx(0): UMM area: 0xe0954000 (size=0x076ac000)
(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(II) fglrx(0): detected X.org 7.1.1.0
(II) fglrx(0): doing DRIScreenInit
(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0x5000
(II) fglrx(0): [drm] mapped SAREA 0x5000 to 0x2afd9de7b000
(II) fglrx(0): [drm] framebuffer handle = 0x6000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.29.6
(II) fglrx(0): Date: Sep 19 2006
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE: 2.6.17-10-generic
(II) fglrx(0): Build-Kernel MODVERSIONS: no
(II) fglrx(0): Build-Kernel __SMP__: no
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0x00007000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x5000 at 0x2afd9de7b000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xe0000000 FBMappedSize: 0x08000000
(==) fglrx(0): Write-combining range (0xe0000000,0x8000000)
(II) fglrx(0): FBMM initialized for area (0,0)-(1600,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1600,1200) (front color buffer - assumption)
(==) fglrx(0): Backing store disabled
(==) fglrx(0): Silken mouse enabled
(**) fglrx(0): DPMS enabled
(WW) fglrx(0): Option "XaaNoOffscreenPixmaps" is not used
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used
(**) fglrx(0): Option "XaaNoOffscreenPixmaps"
(II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
(II) fglrx(0): Acceleration enabled
(II) fglrx(0): Direct rendering disabled
(==) fglrx(0): Using hardware cursor
(II) fglrx(0): Largest offscreen area available: 1600 x 6988
(**) fglrx(0): Video overlay enabled on CRTC1

TRS

Warper (warper4) wrote :

Hi.

Same here. I saw no amd64_agp module compiled in linux-image-2.6.17-10-generic.

I'm compiled kernel and ok again

Warper (warper4) wrote :

Sorry. I'm in 32bits with AMD64, but the problem is same.

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
importance: Undecided → High
status: Unconfirmed → Fix Committed
rodrigo666 (rodrigo666) wrote :

I'm using AMD 64 in Ubuntu Edgy Eft Knot 3 32 bits version here and getting sort of the same problem.

The diference is that I'm trying to use the open source drivers.

Christophe Dumez (hydr0g3n) wrote :

I'm using Ubuntu EGDY (up to date) in 32Bits and I have exactly the same problem. Hence, Graphic performance is worse than with Free ati drivers...

Ben Collins (ben-collins) wrote :

Please make sure you are running latest kernel, and attach (do no paste into comments) the output of dmesg.

Changed in linux-restricted-modules-2.6.17:
status: Fix Committed → Needs Info
tamasrs (tamasrs) wrote :

I am the original poster of this bug, for me, everything is working fine.Linux ubuntu 2.6.17-10-generic #2 SMP Wed Oct 4

TRS

Ben Collins (ben-collins) wrote :

Thanks for the report.

Changed in linux-restricted-modules-2.6.17:
status: Needs Info → Fix Released
Christophe Dumez (hydr0g3n) wrote :

Ok, here is my dmesg.

In fact, I think I have the same problem as here : #57716

I'll try to add the following to my xorg.conf as advised and see if it works:
Section "ServerFlags"
 Option "AIGLX" "off"
EndSection

Section "Extensions"
 Option "Composite" "0"
EndSection

Val (brabon) wrote :

I believe I've got the same problem.

fglrx is loaded, but there is no dri.
Turning off AIGLX works.

Affects 2.6.7-10-386

9johnny (s.j.) wrote :

I had a "customer" on irc.freenode.net #ubuntu-xgl with the same problem, he did not have any modules in /lib/modules/2.6.17-10-generic/kernel/drivers/char/agp/ on an edgy amd64 machine. I mean he had some, but not the amd64 agpgart module.

Ben Collins (ben-collins) wrote :

debian/config/amd64/config:CONFIG_AGP_AMD64=y

That's because it is compiled into the kernel.

Support should exist.

9johnny (s.j.) wrote :

Well that's fine, but as you can see, Xorg can't see the support somehow. I wonder if there is any difference if it is as a module or compiled in, there shouldn't be. Maye the agp support is broken in the kernel?

Changed in linux-source-2.6.17:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers