Comment 7 for bug 60938

It looks like depmod hasn't been run for some reason.

ls -l /lib/modules/2.6.17-10-generic/modules.dep \
  /var/lib/dpkg/info/linux-restricted-modules-2.6.17-10-generic.list \
  /var/lib/dpkg/info/linux-image-2.6.17-10-generic.list

and attach /var/lib/dpkg.log

After you've collected that information, 'sudo depmod' should correct the problem permanently.