Comment 0 for bug 60938

Binary package hint: linux-restricted-modules-2.6.17-7-generic

I have a DWL-G520 wireless PCI card, and so do many other Ubuntu users. On Dapper, the card works out of the box. In Edgy, however, the card cannot be detected in the latest kernel. If I select a 2.6.15-* kernel from GRUB, it will boot fine and wireless will still work. This bug supposedly affects some other wireless Atheros cards, but I have heard that some Atheros chipsets still work fine (?).

Here is the log when 2.6.17 is booted:
[17179593.224000] wlan: 0.8.4.2 (0.9.2)
[17179593.228000] ath_rate_sample: Unknown symbol ath_hal_computetxtime
[17179593.240000] ath_pci: Unknown symbol ath_rate_tx_complete
[17179593.240000] ath_pci: Unknown symbol _ath_hal_attach
[17179593.240000] ath_pci: Unknown symbol ath_rate_attach
[17179593.240000] ath_pci: Unknown symbol ath_rate_newassoc
[17179593.240000] ath_pci: Unknown symbol ath_hal_computetxtime
[17179593.240000] ath_pci: Unknown symbol ath_rate_dynamic_proc_register
[17179593.240000] ath_pci: Unknown symbol ath_hal_mhz2ieee
[17179593.240000] ath_pci: Unknown symbol ath_hal_detach
[17179593.240000] ath_pci: Unknown symbol ath_hal_probe
[17179593.240000] ath_pci: Unknown symbol ath_rate_node_cleanup
[17179593.240000] ath_pci: Unknown symbol ath_rate_detach
[17179593.240000] ath_pci: Unknown symbol ath_rate_node_init
[17179593.240000] ath_pci: Unknown symbol ath_rate_findrate
[17179593.240000] ath_pci: Unknown symbol ath_hal_init_channels
[17179593.240000] ath_pci: Unknown symbol ath_rate_newstate
[17179593.240000] ath_pci: Unknown symbol ath_rate_setupxtxdesc
[17179593.240000] ath_pci: Unknown symbol ath_hal_getwirelessmodes