vc4 and v3d module not loaded

Bug #1922779 reported by miskol
This bug report is a duplicate of:  Bug #1918110: overlay_map.dtb is in wrong location. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-raspi (Ubuntu)
Confirmed
Undecided
Unassigned
Hirsute
Invalid
Undecided
Unassigned

Bug Description

I am testing ubuntu 21.04 beta on raspberry pi 4
and after installation and also after restart
vc4 v3d kernel module isn't loaded
So 3d acceleration don't work

uname -a
Linux misko-desktop 5.11.0-1004-raspi #4-Ubuntu SMP PREEMPT Mon Mar 22 15:51:28 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

miskol (xlazom00)
description: updated
Revision history for this message
Juerg Haefliger (juergh) wrote :

Which image are you using, desktop or server? What's the content of /boot/firmware/config.txt?

Revision history for this message
miskol (xlazom00) wrote :

http://cdimage.ubuntu.com/releases/21.04/beta/ubuntu-21.04-beta-preinstalled-desktop-arm64+raspi.img.xz
And config.txt looks like this
[pi4]
max_framebuffers=2

[all]
kernel=vmlinuz
cmdline=cmdline.txt
initramfs initrd.img followkernel

# Enable the audio output, I2C and SPI interfaces on the GPIO header
dtparam=audio=on
dtparam=i2c_arm=on
dtparam=spi=on

# Enable the KMS ("full" KMS) graphics overlay, and allocate 128Mb to the GPU
# memory. The full KMS overlay is required for X11 application support under
# wayland
dtoverlay=vc4-kms-v3d
gpu_mem=512

# Uncomment the following to enable the Raspberry Pi camera module firmware.
# Be warned that there *may* be incompatibilities with the "full" KMS overlay
#start_x=1

# Comment out the following line if the edges of the desktop appear outside
# the edges of your display
disable_overscan=1

# If you have issues with audio, you may try uncommenting the following line
# which forces the HDMI output into HDMI mode instead of DVI (which doesn't
# support audio output)
#hdmi_drive=2

# If you have a CM4, uncomment the following line to enable the USB2 outputs
# on the IO board (assuming your CM4 is plugged into such a board)
#dtoverlay=dwc2,dr_mode=host

# Config settings specific to arm64
arm_64bit=1
dtoverlay=dwc2

Juerg Haefliger (juergh)
Changed in linux-raspi (Ubuntu Groovy):
status: New → Confirmed
Revision history for this message
miskol (xlazom00) wrote :

I don't have problem with hirsute-budgie-preinstalled-desktop-arm64+raspi.img

And this bug should be fix only for ubuntu Hirsute Hippo

Revision history for this message
miskol (xlazom00) wrote :

Older ubuntu versions don't have kernel with fixed vc4 v3d modules

Revision history for this message
Juerg Haefliger (juergh) wrote :

The problem is due to LP: #1918110. A fix for that was released today so you should update and rerun flash-kernel (if it doesn't run automatically).

I don't understand your comment #4.

Changed in linux-raspi (Ubuntu Groovy):
status: Confirmed → Fix Released
Revision history for this message
miskol (xlazom00) wrote :

Are there any daily builds for raspbery pi ?

for my comment
I saw this:
Changed in linux-raspi (Ubuntu Groovy)
But It is should ubuntu Hirsute I think

Revision history for this message
Juerg Haefliger (juergh) wrote :

Ah yes, you're right, thanks. I removed Groovy and added instead Hirsute.

Daily hirsute images:
http://cdimage.ubuntu.com/daily-preinstalled/

Changed in linux-raspi (Ubuntu Hirsute):
status: New → Fix Released
no longer affects: linux-raspi (Ubuntu Groovy)
Revision history for this message
miskol (xlazom00) wrote :

Any reason why images from http://cdimage.ubuntu.com/daily-preinstalled/20210409/
don't have it fixed aleardy ???
and still I need to call flash-kernel to fix it?

Revision history for this message
miskol (xlazom00) wrote :

I am checking 21.04 release image
and bug is still there

Changed in linux-raspi (Ubuntu Hirsute):
status: Fix Released → Confirmed
Revision history for this message
miskol (xlazom00) wrote :

I need to run sudo flash-kernel to fix it :(

Revision history for this message
Juerg Haefliger (juergh) wrote :

It seems the image build process is still broken. It's not a kernel problem and flash-kernel is fixed. Which you've confirmed by running flash-kernel manually which fixes the issue. I'm going to close this ticket, since it's not a kernel problem.

Changed in linux-raspi (Ubuntu Hirsute):
status: Confirmed → Invalid
Revision history for this message
Dave Jones (waveform) wrote :

Yes, flash-kernel was indeed fixed but there was an issue in the gadget I'd missed.

In the end it's not affecting the desktop image as initial user setup winds up implicitly running flash-kernel anyway, but it's certainly an issue for anyone installing a desktop on top of the server image (up until the first time flash-kernel is run anyway). I've added a note to the hirsute release notes, and patched the gadget accordingly (https://github.com/snapcore/pi-gadget/commit/7c06269154195c500b0f1027bc4d180c964501ed which I'll cherry-pick to the relevant branches).

Revision history for this message
miskol (xlazom00) wrote :

I did fresh install of ubuntu 21.04 desktop on pi
And I don't see drivers when I run lsmod
Only sudo flash-kernel will fix it

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers