powerpc ibm pseries 620 stopping after kernel load

Bug #196600 reported by Ulrich Enslin on 2008-02-28
6
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Undecided
Unassigned
linux-ports (Ubuntu)
Medium
Ubuntu PowerPC Architecture Team

Bug Description

Binary package hint: debian-installer

I am booting from ubuntu-7.10-alternate-powerpc.iso and ubuntu-6.06.2-server-powerpc.iso on a IBM pseries 620 (7025-6F0)

I start the install with boot parameters:
install-powerpc64 console=ttyS0

It looks like kernel loads and I can see all kinds of hardware detection etc. but the installer does not start.

I tried the debian powerpc install, and it works correctly.

Since they use the same installer, I thought that the ubuntu install should work.

Here is an extract from the boot text:
boot: install-powerpc64 console=ttyS0
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02500000, size: 5627 Kbytes
OF stdout device is: /pci@fff7f09000/isa@10/serial@i3f8
command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed quiet -- console=ttyS0
memory layout at init:
  alloc_bottom : 0000000002a7f000
  alloc_top : 0000000030000000
  alloc_top_hi : 0000000200000000
  rmo_top : 0000000030000000
  ram_top : 0000000200000000
Looking for displays
opening PHB /pci@fff7f09000... done
opening PHB /pci@fff7f0a000... done
instantiating rtas at 0x000000002ff59000 ... done
0000000000000000 : boot cpu 0000000000000000
0000000000000001 : starting cpu hw idx 0000000000000002... done
0000000000000002 : starting cpu hw idx 0000000000000004... done
0000000000000003 : starting cpu hw idx 0000000000000006... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000002d80000 -> 0x0000000002d8110d
Device tree struct 0x0000000002d82000 -> 0x0000000002d91000
Calling quiesce ...
returning from prom_init
[ 0.000000] Starting Linux PPC64 #1 SMP Sun Oct 14 22:41:26 GMT 2007
[ 0.000000] -----------------------------------------------------
[ 0.000000] ppc64_pft_size = 0x0
[ 0.000000] physicalMemorySize = 0x200000000
[ 0.000000] ppc64_caches.dcache_line_size = 0x80
[ 0.000000] ppc64_caches.icache_line_size = 0x80
[ 0.000000] htab_address = 0xc0000001f0000000
[ 0.000000] htab_hash_mask = 0xfffff
[ 0.000000] -----------------------------------------------------
[ 0.000000] Linux version 2.6.22-14-powerpc64-smp (buildd@ross) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP Sun Oct 14 22:41:26 GMT 2007 (Ubuntu 2.6.22-14.46-powerpc64-smp)
[ 0.000000] [boot]0012 Setup Arch
[ 0.000000] Segment table for CPU 1 at 0xc00000000fffb000 virtual, 0xfffb000 absolute
[ 0.000000] Segment table for CPU 2 at 0xc00000000fffa000 virtual, 0xfffa000 absolute
[ 0.000000] Segment table for CPU 3 at 0xc00000000fff9000 virtual, 0xfff9000 absolute
[ 0.000000] EEH: No capable adapters found
[ 0.000000] PPC64 nvram contains 262144 bytes
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 2097152
[ 0.000000] Normal 2097152 -> 2097152
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 2097152
[ 0.000000] [boot]0015 Setup Done
[ 0.000000] Built 1 zonelists. Total pages: 2068480
[ 0.000000] Kernel command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed quiet -- console=ttyS0
[ 2113.260402] Failed to request PCI IO region on PCI domain 0000

description: updated
Evan (ev) wrote :

Looks like a ppc64 issue. Can someone from the kernel team take a look at this?

Thanks!

Changed in debian-installer:
status: New → Invalid

Hi Ulrich,

Care to actually test the latest Hardy Alpha release. It has an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/ports/daily/current/ . If you can, please verify if this bug still exists or not and report back your results. Thanks

Changed in linux:
status: New → Incomplete

Hi Leann

I will try it today and report back.

All the best
Ulrich

Leann Ogasawara wrote:
> Hi Ulrich,
>
> Care to actually test the latest Hardy Alpha release. It has an updated
> version of the kernel. You can download and try the new Hardy Heron
> Alpha release from http://cdimage.ubuntu.com/ports/daily/current/ . If
> you can, please verify if this bug still exists or not and report back
> your results. Thanks
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
>

Download full text (12.0 KiB)

Hi Leann

I tried the install on the IBM pseries 620, but it did not work. Please
see below the text from the kernel load process, started with three
difirent options:

boot: install-powerpc64 console=ttyS0
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02600000, size: 5877 Kbytes
OF stdout device is: /pci@fff7f09000/isa@10/serial@i3f8
command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed quiet
-- console=ttyS0
memory layout at init:
  alloc_bottom : 0000000002bbe000
  alloc_top : 0000000030000000
  alloc_top_hi : 0000000200000000
  rmo_top : 0000000030000000
  ram_top : 0000000200000000
Looking for displays
opening PHB /pci@fff7f09000... done
opening PHB /pci@fff7f0a000... done
instantiating rtas at 0x000000002ff59000 ... done
0000000000000000 : boot cpu 0000000000000000
0000000000000001 : starting cpu hw idx 0000000000000002... done
0000000000000002 : starting cpu hw idx 0000000000000004... done
0000000000000003 : starting cpu hw idx 0000000000000006... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000002ebf000 -> 0x0000000002ec010d
Device tree struct 0x0000000002ec1000 -> 0x0000000002ed0000
Calling quiesce ...
returning from prom_init
[ 0.000000] Starting Linux PPC64 #1 SMP Fri Feb 22 19:32:29 UTC 2008
[ 0.000000] -----------------------------------------------------
[ 0.000000] ppc64_pft_size = 0x0
[ 0.000000] physicalMemorySize = 0x200000000
[ 0.000000] htab_address = 0xc0000001f0000000
[ 0.000000] htab_hash_mask = 0xfffff
[ 0.000000] -----------------------------------------------------
[ 0.000000] Linux version 2.6.24-10-powerpc64-smp (buildd@adare) (gcc
version 4.1.3 20071209 (prerelease) (Ubuntu 4.1.2-18ubuntu1)) #1 SMP Fri
Feb 22 19:32:29 UTC 2008 (Ubuntu 2.6.24-10.16-powerpc64-smp)
[ 0.000000] [boot]0012 Setup Arch
[ 0.000000] Segment table for CPU 1 at 0xc00000000fffb000 virtual,
0xfffb000 absolute
[ 0.000000] Segment table for CPU 2 at 0xc00000000fffa000 virtual,
0xfffa000 absolute
[ 0.000000] Segment table for CPU 3 at 0xc00000000fff9000 virtual,
0xfff9000 absolute
[ 0.000000] no ISA IO ranges or unexpected isa range,mapping 64k
[ 0.000000] EEH: No capable adapters found
[ 0.000000] PPC64 nvram contains 262144 bytes
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 2097152
[ 0.000000] Normal 2097152 -> 2097152
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 2097152
[ 0.000000] [boot]0015 Setup Done
[ 0.000000] Built 1 zonelists in Node order, mobility grouping on.
Total pages: 2068480
[ 0.000000] Policy zone: DMA
[ 0.000000] Kernel command line: ro ramdisk_size=8192
file=/cdrom/preseed/ubuntu.seed quiet -- console=ttyS0

boot: cli-powerpc64 console=ttyS0
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02600000, size: 5877 Kbytes
OF stdout device is: /pci@fff7f09000/isa@10/serial@i3f8
command line: ro ramd...

Download full text (12.0 KiB)

Hi Leann

I tried the install 'Hardy Alpha' (hardy-alternate-powerpc.iso) on the IBM
pseries 620, but it did not work. Please see below the text from the kernel
load process, started with three different options:

boot: install-powerpc64 console=ttyS0
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02600000, size: 5877 Kbytes
OF stdout device is: /pci@fff7f09000/isa@10/serial@i3f8
command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed quiet
-- console=ttyS0
memory layout at init:
  alloc_bottom : 0000000002bbe000
  alloc_top : 0000000030000000
  alloc_top_hi : 0000000200000000
  rmo_top : 0000000030000000
  ram_top : 0000000200000000
Looking for displays
opening PHB /pci@fff7f09000... done
opening PHB /pci@fff7f0a000... done
instantiating rtas at 0x000000002ff59000 ... done
0000000000000000 : boot cpu 0000000000000000
0000000000000001 : starting cpu hw idx 0000000000000002... done
0000000000000002 : starting cpu hw idx 0000000000000004... done
0000000000000003 : starting cpu hw idx 0000000000000006... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000002ebf000 -> 0x0000000002ec010d
Device tree struct 0x0000000002ec1000 -> 0x0000000002ed0000
Calling quiesce ...
returning from prom_init
[ 0.000000] Starting Linux PPC64 #1 SMP Fri Feb 22 19:32:29 UTC 2008
[ 0.000000] -----------------------------------------------------
[ 0.000000] ppc64_pft_size = 0x0
[ 0.000000] physicalMemorySize = 0x200000000
[ 0.000000] htab_address = 0xc0000001f0000000
[ 0.000000] htab_hash_mask = 0xfffff
[ 0.000000] -----------------------------------------------------
[ 0.000000] Linux version 2.6.24-10-powerpc64-smp (buildd@adare) (gcc
version 4.1.3 20071209 (prerelease) (Ubuntu 4.1.2-18ubuntu1)) #1 SMP Fri
Feb 22 19:32:29 UTC 2008 (Ubuntu 2.6.24-10.16-powerpc64-smp)
[ 0.000000] [boot]0012 Setup Arch
[ 0.000000] Segment table for CPU 1 at 0xc00000000fffb000 virtual,
0xfffb000 absolute
[ 0.000000] Segment table for CPU 2 at 0xc00000000fffa000 virtual,
0xfffa000 absolute
[ 0.000000] Segment table for CPU 3 at 0xc00000000fff9000 virtual,
0xfff9000 absolute
[ 0.000000] no ISA IO ranges or unexpected isa range,mapping 64k
[ 0.000000] EEH: No capable adapters found
[ 0.000000] PPC64 nvram contains 262144 bytes
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 2097152
[ 0.000000] Normal 2097152 -> 2097152
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 2097152
[ 0.000000] [boot]0015 Setup Done
[ 0.000000] Built 1 zonelists in Node order, mobility grouping on.
Total pages: 2068480
[ 0.000000] Policy zone: DMA
[ 0.000000] Kernel command line: ro ramdisk_size=8192
file=/cdrom/preseed/ubuntu.seed quiet -- console=ttyS0

boot: cli-powerpc64 console=ttyS0
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02600000, size: 5877 Kbytes
OF stdout device is: /pci@fff7f09000/isa@...

Changed in linux:
assignee: nobody → ubuntu-powerpc
importance: Undecided → Medium
status: Incomplete → Triaged
Jeremy Kerr (jk-ozlabs) wrote :

Hi Ulrich,

How is your console connected on this machine? Are you using a management center console or a serial cable?

Also, try adding 'debug' to the kernel command line, to override the default 'quiet' option. Let us know what output you get with that.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Manoj Iyer (manjo) on 2009-04-21
Changed in linux (Ubuntu):
status: Triaged → Invalid
Manoj Iyer (manjo) on 2009-04-21
Changed in linux (Ubuntu):
status: Invalid → Incomplete
tags: added: ct-rev
Colin Watson (cjwatson) on 2009-04-21
affects: linux (Ubuntu) → linux-ports (Ubuntu)
Luke Yelavich (themuso) wrote :

Have you tried booting the latest Jaunty alternate PowerPC CD? If you could try that for me, and let me know if it works, that would be appreciated.

Thanks.

Download full text (4.2 KiB)

Hi Luke

I am happy to try it for you.

Do you know if there is a South African server that is hosting the PPC
cd images. All the servers I looked at only hosts the i386 images.

In South African local bandwidth is cheaper than international bandwidth.

All the best
Ulrich

2009/5/13 Luke Yelavich <email address hidden>:
> Have you tried booting the latest Jaunty alternate PowerPC CD? If you
> could try that for me, and let me know if it works, that would be
> appreciated.
>
> Thanks.
>
> --
> powerpc ibm pseries 620 stopping after kernel load
> https://bugs.launchpad.net/bugs/196600
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “debian-installer” source package in Ubuntu: Invalid
> Status in “linux-ports” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: debian-installer
>
> I am booting from ubuntu-7.10-alternate-powerpc.iso and ubuntu-6.06.2-server-powerpc.iso on a IBM pseries 620 (7025-6F0)
>
> I start the install with boot parameters:
> install-powerpc64 console=ttyS0
>
> It looks like kernel loads and I can see all kinds of hardware detection etc. but the installer does not start.
>
> I tried the debian powerpc install, and it works correctly.
>
> Since they use the same installer, I thought that the ubuntu install should work.
>
> Here is an extract from the boot text:
> boot: install-powerpc64 console=ttyS0
> Please wait, loading kernel...
>   Elf64 kernel loaded...
> Loading ramdisk...
> ramdisk loaded at 02500000, size: 5627 Kbytes
> OF stdout device is: /pci@fff7f09000/isa@10/serial@i3f8
> command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed quiet -- console=ttyS0
> memory layout at init:
>  alloc_bottom : 0000000002a7f000
>  alloc_top    : 0000000030000000
>  alloc_top_hi : 0000000200000000
>  rmo_top      : 0000000030000000
>  ram_top      : 0000000200000000
> Looking for displays
> opening PHB /pci@fff7f09000... done
> opening PHB /pci@fff7f0a000... done
> instantiating rtas at 0x000000002ff59000 ... done
> 0000000000000000 : boot cpu     0000000000000000
> 0000000000000001 : starting cpu hw idx 0000000000000002... done
> 0000000000000002 : starting cpu hw idx 0000000000000004... done
> 0000000000000003 : starting cpu hw idx 0000000000000006... done
> copying OF device tree ...
> Building dt strings...
> Building dt structure...
> Device tree strings 0x0000000002d80000 -> 0x0000000002d8110d
> Device tree struct  0x0000000002d82000 -> 0x0000000002d91000
> Calling quiesce ...
> returning from prom_init
> [    0.000000] Starting Linux PPC64 #1 SMP Sun Oct 14 22:41:26 GMT 2007
> [    0.000000] -----------------------------------------------------
> [    0.000000] ppc64_pft_size                = 0x0
> [    0.000000] physicalMemorySize            = 0x200000000
> [    0.000000] ppc64_caches.dcache_line_size = 0x80
> [    0.000000] ppc64_caches.icache_line_size = 0x80
> [    0.000000] htab_address                  = 0xc0000001f0000000
> [    0.000000] htab_hash_mask                = 0xfffff
> [    0.000000] -----------------------------------------------------
> [    0.000000] Linux version 2.6.22-14-powerpc64-smp (buildd@ross) (g...

Read more...

Download full text (5.6 KiB)

Hi Luke

I tried install via latest Jaunty alternate PowerPC CD. It did not
work, see the output below. I tried Debian 5, which should be using
the same installer if I am not mistaken, and that installed
successfully.

Output:

Ubuntu PPC

To boot any other label simply type its name and press <return>.

To boot a kernel image which is not defined in the yaboot configuration
file, enter the kernel image name as [[device:][partno],]/path, where
"device:" is the OpenFirmware device path to the disk the image
resides on, and "partno" is the partition number the image resides on.
Note that the comma (,) is only required if you specify an OpenFirmware
device, if you only specify a filename you should not start it with a ","

If you omit "device:" and "partno" yaboot will use the values of
"device=" and "partition=" in yaboot.conf, right now those are set to:
device=/pci@fff7f09000/pci@b/scsi@1/sd@1,0
partition=0

boot: install64 console=tty0
Please wait, loading kernel...
install64:0,/vmlinux: Unable to open file, Invalid device
boot: install console=ttyS0
Please wait, loading kernel...
   Elf32 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02300000, size: 5772 Kbytes
OF stdout device is: /pci@fff7f09000/isa@10/serial@i2f8
command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed
quiet -- console=ttyS0
memory layout at init:
  alloc_bottom : 028a4000
  alloc_top : 00000000
  alloc_top_hi : 00000000
  rmo_top : 00000000
  ram_top : 00000000
Looking for displays
alloc_down() called with mem not initialized
EXIT called ok
0 > ok
0 > ok
0 > ok
0 > ? DEFAULT CATCH!, code=fff00300 at %SRR0: 02106a30 %SRR1: 00003000
 ok
0 > help help on is not available ok
0 >

I hope this helps

All the best
Ulrich

2009/5/13 Luke Yelavich <email address hidden>:
> Have you tried booting the latest Jaunty alternate PowerPC CD? If you
> could try that for me, and let me know if it works, that would be
> appreciated.
>
> Thanks.
>
> --
> powerpc ibm pseries 620 stopping after kernel load
> https://bugs.launchpad.net/bugs/196600
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “debian-installer” source package in Ubuntu: Invalid
> Status in “linux-ports” source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: debian-installer
>
> I am booting from ubuntu-7.10-alternate-powerpc.iso and ubuntu-6.06.2-server-powerpc.iso on a IBM pseries 620 (7025-6F0)
>
> I start the install with boot parameters:
> install-powerpc64 console=ttyS0
>
> It looks like kernel loads and I can see all kinds of hardware detection etc. but the installer does not start.
>
> I tried the debian powerpc install, and it works correctly.
>
> Since they use the same installer, I thought that the ubuntu install should work.
>
> Here is an extract from the boot text:
> boot: install-powerpc64 console=ttyS0
> Please wait, loading kernel...
>   Elf64 kernel loaded...
> Loading ramdisk...
> ramdisk loaded at 02500000, size: 5627 Kbytes
> OF stdout device is: /pci@fff7f09000/isa@10/serial@i3f8
> command line: ro ramdisk_size=8192 file=/cdrom/preseed/ubuntu.seed quiet -- console=ttyS0
> ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers