iscsi-related backports requested for Oracle-cloud

Bug #1931959 reported by Khaled El Mously
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-oracle (Ubuntu)
New
Undecided
Khaled El Mously
Focal
Fix Released
Medium
Unassigned
Groovy
Fix Released
Medium
Unassigned

Bug Description

As part of some work to enable high performance iscsi storage leveraging multipath, Oracle submitted and landed patches upstream, which were released as part of 5.10.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=2a242d59d6b908341c0d426bc6e7f8e28871cbd0
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=0610959fbbca62b534f1f276873fd297f76b164b

commit 2a242d59d6b908341c0d426bc6e7f8e28871cbd0
Author: Mike Christie <email address hidden>
Date: Thu Oct 1 10:35:53 2020 -0500

scsi: core: Add limitless cmd retry support

commit 0610959fbbca62b534f1f276873fd297f76b164b
Author: Mike Christie <email address hidden>
Date: Thu Oct 1 10:35:54 2020 -0500

scsi: sd: Allow user to configure command retries

See https://canonical.lightning.force.com/lightning/r/Case/5004K000005pykQQAQ/view for more info.

[Impact]
Optimizations/improvements in iscsi-code

[Fix]
2 patches - see above

[Test]
Build, boot, initiate an iscsi connection to a target.

[Regression Potential]
Possible impact on iscsi functionality.

Changed in linux-oracle (Ubuntu):
assignee: nobody → Khaled El Mously (kmously)
Stefan Bader (smb)
Changed in linux-oracle (Ubuntu Focal):
importance: Undecided → Medium
status: New → In Progress
Changed in linux-oracle (Ubuntu Groovy):
importance: Undecided → Medium
status: New → In Progress
Changed in linux-oracle (Ubuntu Focal):
status: In Progress → Fix Committed
Changed in linux-oracle (Ubuntu Groovy):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-groovy' to 'verification-done-groovy'. If the problem still exists, change the tag 'verification-needed-groovy' to 'verification-failed-groovy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-groovy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oracle - 5.4.0-1049.53

---------------
linux-oracle (5.4.0-1049.53) focal; urgency=medium

  * focal/linux-oracle: 5.4.0-1049.53 -proposed tracker (LP: #1933407)

  * iscsi-related backports requested for Oracle-cloud (LP: #1931959)
    - scsi: core: Add limitless cmd retry support
    - scsi: sd: Allow user to configure command retries

  * Oracle kernel has Android related config options disabled (LP: #1928686)
    - [config] oracle: Enable Android options for anbox

 -- Khalid Elmously <email address hidden> Thu, 24 Jun 2021 00:22:51 -0400

Changed in linux-oracle (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oracle - 5.8.0-1034.35

---------------
linux-oracle (5.8.0-1034.35) groovy; urgency=medium

  * groovy/linux-oracle: 5.8.0-1034.35 -proposed tracker (LP: #1933440)

  * iscsi-related backports requested for Oracle-cloud (LP: #1931959)
    - scsi: core: Add limitless cmd retry support
    - scsi: sd: Allow user to configure command retries

  * Oracle kernel has Android related config options disabled (LP: #1928686)
    - [config] oracle: Enable Android options for anbox

 -- Khalid Elmously <email address hidden> Thu, 24 Jun 2021 05:11:40 -0400

Changed in linux-oracle (Ubuntu Groovy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers