[Redpine] HCI command timeout after resume from S4

Bug #1772626 reported by Shrirang Bagul on 2018-05-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
High
Shrirang Bagul
linux-oem (Ubuntu)
Critical
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Redpine BT stops working after resume from S4.

Symptoms:
- The device list is increasing after resume.
- Error after command "hciconfig -a" which as:
Can't read local name on hci0: Connection timed out (110)

The reproduce steps:
1) Go to hibernate mode
$ sudo systemctl hibernate

2) Wakeup system by power recycle

3) Check the bluetooth list
$ hciconfig -a
hci1: Type: Primary Bus: SDIO
 BD Address: 00:23:A7:BF:34:F8 ACL MTU: 540:2 SCO MTU: 30:1
 DOWN
 RX bytes:574 acl:0 sco:0 events:30 errors:0
 TX bytes:0 acl:0 sco:0 commands:30 errors:0
 Features: 0x3f 0x02 0x04 0x4e 0xc8 0x0d 0x5b 0x87
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1
 Link policy: RSWITCH
 Link mode: SLAVE ACCEPT

hci0: Type: Primary Bus: SDIO
 BD Address: 00:23:A7:BF:34:F8 ACL MTU: 540:2 SCO MTU: 30:1
 UP RUNNING
 RX bytes:1238 acl:0 sco:0 events:75 errors:0
 TX bytes:0 acl:0 sco:0 commands:75 errors:0
 Features: 0x3f 0x02 0x04 0x4e 0xc8 0x0d 0x5b 0x87
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1
 Link policy: RSWITCH
 Link mode: SLAVE ACCEPT
Can't read local name on hci0: Connection timed out (110)

4) Go to hibernate and wake again(as step 1-2)

5) Try ifconfig command to check wifi device
Result: command no response

This bug is for tracking purposes only, please don't triage.

CVE References

Changed in linux-oem (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
tags: added: originate-from-1771268 plano
Changed in linux-oem (Ubuntu):
importance: Critical → High
importance: High → Critical
Changed in hwe-next:
status: New → Confirmed
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Shrirang Bagul (shrirang-bagul)
Timo Aaltonen (tjaalton) on 2018-05-28
Changed in linux-oem (Ubuntu Bionic):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :
Download full text (13.7 KiB)

This bug was fixed in the package linux-oem - 4.15.0-1008.11

---------------
linux-oem (4.15.0-1008.11) bionic; urgency=medium

  * linux-oem: 4.15.0-1008.11 -proposed tracker (LP: #1774764)

  * [Redpine] Wifi AP does not work (LP: #1774606)
    - Revert "UBUNTU: SAUCE: rsi: drop RX broadcast/multicast packets with invalid
      PN"
    - SAUCE: rsi: fix for 40MHZ connection issue.
    - SAUCE: rsi: add firmware support for AP+BT dual mode

linux-oem (4.15.0-1007.10) bionic; urgency=medium

  * linux-oem: 4.15.0-1007.10 -proposed tracker (LP: #1772933)

  * Intel WiFi Linux driver update for ETSI 5GHz Adaptivity Requirement
    (LP: #1769980)
    - iwlwifi: mvm: add WFA vendor specific TPC report IE to probe request
    - iwlwifi: mvm: remove set but unused variable in iwl_mvm_roc_done_wk
    - iwlwifi: mvm: rs: introduce new API for rate scaling
    - iwlwifi: mvm: rs: add ops for the new rate scaling in the FW
    - iwlwifi: mvm: rs: add basic implementation of the new RS API handlers
    - iwlwifi: mvm: rs: new rate scale API - add FW notifications
    - iwlwifi: mvm: rs: new rate scale API - add debugfs hooks
    - iwlwifi: mvm: rs: add size checks when printing to a buffer
    - iwlwifi: mvm: rs: add sanity check when sending LQ command
    - iwlwifi: mvm: support RX flags API change
    - iwlwifi: fw: fix the enums in the rate scaling API
    - iwlwifi: mvm: adjust to quota offload
    - iwlwifi: mvm: send the low latency command
    - iwlwifi: define and use if iwl_mvm_has_tlc_offload
    - cfg80211: read wmm rules from regulatory database
    - mac80211: limit wmm params to comply with ETSI requirements
    - cfg80211: Add API to allow querying regdb for wmm_rule
    - iwlwifi: mvm: query regdb for wmm rule if needed
    - iwlwifi: rename the temporary name of A000 to the official 22000
    - iwlwifi: bump FW API to 36 for 8000 and up
    - iwlwifi: bump the max API version for 9000 and 22000 devices
    - iwlwifi: api: Add geographic profile information to MCC_UPDATE_CMD

  * [Redpine] HCI command timeout after resume from S4 (LP: #1772626)
    - SAUCE: Bluetooth: btrsi: add hci detach for hibernation and poweroff
    - SAUCE: Bluetooth:btrsi: add null check in hci send and recv functions
    - SAUCE: Bluetooth:btrsi: fix bt cmd timeout issue

  * Switch Build-Depends: transfig to fig2dev (LP: #1770770)
    - [Config] update Build-Depends: transfig to fig2dev

  * Miscellaneous Ubuntu changes
    - Rebase to 4.15.0-23.25

  [ Ubuntu: 4.15.0-23.25 ]

  * linux: 4.15.0-23.25 -proposed tracker (LP: #1772927)
  * arm64 SDEI support needs trampoline code for KPTI (LP: #1768630)
    - arm64: mmu: add the entry trampolines start/end section markers into
      sections.h
    - arm64: sdei: Add trampoline code for remapping the kernel
  * Some PCIe errors not surfaced through rasdaemon (LP: #1769730)
    - ACPI: APEI: handle PCIe AER errors in separate function
    - ACPI: APEI: call into AER handling regardless of severity
  * qla2xxx: Fix page fault at kmem_cache_alloc_node() (LP: #1770003)
    - scsi: qla2xxx: Fix session cleanup for N2N
    - scsi: qla2xxx: Remove unused argument from qlt_schedule_sess_for_deletion()
    - scsi: qla2xx...

Changed in linux-oem (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in linux-oem (Ubuntu):
status: Confirmed → Fix Released
Changed in hwe-next:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers