Activity log for bug #1763271

Date Who What changed Old value New value Message
2018-04-12 06:41:39 AceLan Kao bug added bug
2018-04-12 06:49:37 AceLan Kao description [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700 drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below fbe0967 drm/i915/edp: Do not do link training fallback or prune modes on EDP This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP. b25b806 drm/i915/edp: Allow alternate fixed mode for eDP if available. Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. bf389c7 drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp 6199c65 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below fbe0967 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. b25b806 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. bf389c7 drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp 6199c65 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp Above 2 commits do function name renaming only.
2018-04-12 06:50:35 AceLan Kao description [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below fbe0967 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. b25b806 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. bf389c7 drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp 6199c65 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp Above 2 commits do function name renaming only. [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below 9bdbd39 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. 4f4db42 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. eed02c3 drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp be39bc2 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp    Above 2 commits do function name renaming only.
2018-04-12 06:53:45 AceLan Kao description [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below 9bdbd39 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. 4f4db42 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. eed02c3 drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp be39bc2 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp    Above 2 commits do function name renaming only. [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below a306343 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. dc911f5 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. 1853a9d drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp 7b91bf7 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp    Above 2 commits do function name renaming only.
2018-04-12 07:06:02 AceLan Kao description [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below a306343 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. dc911f5 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display. 1853a9d drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp 7b91bf7 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp    Above 2 commits do function name renaming only. [Impact] The display becomes black after S3 with the following error messages. dmesg: [ 60.546305] [drm:intel_dp_start_link_train [i915]] Link Training failed at link rate = 540000, lane count = 4 Xorg.0.log: [ 60.748] (EE) modeset(0): failed to set mode: Invalid argument [ 60.748] (WW) modeset(0): hotplug event: connector 48's link-state is BAD, tried resetting the current mode. You may be left with a black screen if this fails... [Fix] Looks like link training fallback fails sometimes with eDP, we need this commit to fix the issue. commit a306343bcd7df89d9d45a601929e26866e7b7a81 (refs/bisect/bad) Author: Manasi Navare <manasi.d.navare@intel.com> Date: Thu Oct 12 12:13:38 2017 -0700     drm/i915/edp: Do not do link training fallback or prune modes on EDP [Regression Potential] Should be low. To avoid conflicts, we introduce 4 commits, I'll try explaining them below a306343 drm/i915/edp: Do not do link training fallback or prune modes on EDP    This is the fix commit and the behavior only changes when DP is eDP, it does nothing if DP is eDP. Should be fine to not do link training fallback and not emit Hotplug Uevent to userspace to start modeset, since its eDP, the display is fixed. 1853a9d drm/i915/dp: make is_edp non-static and rename to intel_dp_is_edp 7b91bf7 drm/i915/dp: rename intel_dp_is_edp to intel_dp_is_port_edp    Above 2 commits do function name renaming only. dc911f5 drm/i915/edp: Allow alternate fixed mode for eDP if available.    Change the prototype of function "intel_panel_init()" and adding one extra argument, should have small impact on the display.
2018-04-12 07:53:35 AceLan Kao bug added subscriber Canonical Hardware Enablement Team
2018-04-12 07:53:38 AceLan Kao tags originate-from-1758823 somerville
2018-04-12 08:04:09 Timo Aaltonen nominated for series Ubuntu Xenial
2018-04-12 08:04:09 Timo Aaltonen bug task added linux-oem (Ubuntu Xenial)
2018-04-12 08:04:18 Timo Aaltonen linux-oem (Ubuntu Xenial): status New Fix Committed
2018-04-12 08:04:24 Timo Aaltonen linux-oem (Ubuntu): status In Progress Invalid
2018-04-12 08:04:30 Timo Aaltonen linux-oem (Ubuntu): status Invalid In Progress
2018-04-13 13:07:06 Seth Forshee bug task added linux (Ubuntu)
2018-04-13 13:30:05 Ubuntu Kernel Bot linux (Ubuntu): status New Incomplete
2018-04-13 13:30:08 Ubuntu Kernel Bot linux (Ubuntu Xenial): status New Incomplete
2018-04-18 07:34:54 Kleber Sacilotto de Souza linux (Ubuntu Xenial): status Incomplete In Progress
2018-04-18 07:35:26 Kleber Sacilotto de Souza nominated for series Ubuntu Artful
2018-04-18 07:35:26 Kleber Sacilotto de Souza bug task added linux (Ubuntu Artful)
2018-04-18 07:35:26 Kleber Sacilotto de Souza bug task added linux-oem (Ubuntu Artful)
2018-04-18 07:35:34 Kleber Sacilotto de Souza linux (Ubuntu Artful): status New In Progress
2018-04-18 07:35:39 Kleber Sacilotto de Souza linux (Ubuntu Xenial): status In Progress Invalid
2018-04-18 07:35:43 Kleber Sacilotto de Souza linux-oem (Ubuntu Artful): status New Invalid
2018-04-18 07:36:05 Kleber Sacilotto de Souza linux (Ubuntu): status Incomplete Invalid
2018-04-20 11:54:16 Stefan Bader linux (Ubuntu Artful): status In Progress Fix Committed
2018-04-23 12:52:04 Launchpad Janitor linux-oem (Ubuntu Xenial): status Fix Committed Fix Released
2018-04-23 12:52:04 Launchpad Janitor cve linked 2017-5715
2018-04-23 12:52:04 Launchpad Janitor cve linked 2017-5754
2018-04-23 12:52:04 Launchpad Janitor cve linked 2018-8043
2018-04-25 01:56:04 AceLan Kao linux-oem (Ubuntu): status In Progress Fix Released
2018-04-27 19:02:51 Brad Figg tags originate-from-1758823 somerville originate-from-1758823 somerville verification-needed-artful
2018-05-03 03:01:07 AceLan Kao tags originate-from-1758823 somerville verification-needed-artful originate-from-1758823 somerville verification-done-artful
2018-05-15 08:34:48 Kleber Sacilotto de Souza nominated for series Ubuntu Bionic
2018-05-15 08:34:48 Kleber Sacilotto de Souza bug task added linux (Ubuntu Bionic)
2018-05-15 08:34:48 Kleber Sacilotto de Souza bug task added linux-oem (Ubuntu Bionic)
2018-05-15 08:35:20 Kleber Sacilotto de Souza linux (Ubuntu Bionic): status New Fix Committed
2018-05-15 08:35:32 Kleber Sacilotto de Souza linux-oem (Ubuntu Bionic): status New Invalid
2018-05-22 00:04:32 Launchpad Janitor linux (Ubuntu Artful): status Fix Committed Fix Released
2018-05-22 00:04:32 Launchpad Janitor cve linked 2017-17449
2018-05-22 00:04:32 Launchpad Janitor cve linked 2017-17975
2018-05-22 00:04:32 Launchpad Janitor cve linked 2017-18203
2018-05-22 00:04:32 Launchpad Janitor cve linked 2017-18208
2018-05-22 00:04:32 Launchpad Janitor cve linked 2018-3639
2018-05-22 00:04:32 Launchpad Janitor cve linked 2018-8822
2018-05-24 18:05:23 Brad Figg tags originate-from-1758823 somerville verification-done-artful originate-from-1758823 somerville verification-done-artful verification-needed-bionic
2018-05-25 06:00:00 AceLan Kao tags originate-from-1758823 somerville verification-done-artful verification-needed-bionic originate-from-1758823 somerville verification-done-artful verification-done-bionic
2018-06-11 15:08:06 Launchpad Janitor linux (Ubuntu Bionic): status Fix Committed Fix Released
2018-06-11 15:08:06 Launchpad Janitor cve linked 2018-1092
2018-06-11 15:08:06 Launchpad Janitor cve linked 2018-8087
2018-06-13 09:30:49 Launchpad Janitor linux-oem (Ubuntu Bionic): status Invalid Fix Released
2018-06-14 12:16:29 Launchpad Janitor linux (Ubuntu): status Invalid Fix Released
2018-08-29 17:26:00 Anthony Wong hwe-next: status New Fix Released