ath9k can't connect to wifi AP

Bug #1727228 reported by AceLan Kao on 2017-10-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux-oem (Ubuntu)
Undecided
AceLan Kao
Xenial
Undecided
Unassigned
Bionic
Undecided
AceLan Kao

Bug Description

[Impact]
iwlist scan can search the available wifi APs, but can't get connected.

On new Intel platforms like ApolloLake, legacy interrupt mechanism
(INTx) is not supported, so WLAN modules are not working because
interrupts are missing.

The affected and listed platforms are
Dell Inspiron 24-3460
Dell Inspiron 14-3473
Dell Inspiron 3472
Dell Inspiron 3576
Dell Vostro 3262
Dell Vostro 15-3572
Dell Vostro 3578

[Fix]
Qualcomm provided a MSI patch for ath9k, and it fixes the issue.

[Test Case]
Tested on the machines mentioned above, and they all work well.

[Regression Potential]
There shouldn't be any regression potential. These are newly enabled machines and quirks are applied based on DMI_PRODUCT_NAME to only use MSI on such machines.

AceLan Kao (acelankao) on 2017-10-25
description: updated
description: updated
tags: added: originate-from-1717179 somerville
description: updated
AceLan Kao (acelankao) wrote :
AceLan Kao (acelankao) wrote :

The patches are in
git://git.kernel.org/pub/scm/linux/kernel/git/kvalo/ath.git pending

tags: added: patch
AceLan Kao (acelankao) on 2018-01-16
description: updated
Timo Aaltonen (tjaalton) on 2018-01-23
affects: linux (Ubuntu) → linux-oem (Ubuntu)
Changed in linux-oem (Ubuntu):
status: In Progress → Invalid
Timo Aaltonen (tjaalton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Timo Aaltonen (tjaalton) on 2018-02-02
Changed in linux-oem (Ubuntu Xenial):
status: New → Fix Committed
AceLan Kao (acelankao) on 2018-02-07
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem - 4.13.0-1020.21

---------------
linux-oem (4.13.0-1020.21) xenial; urgency=low

  * linux-oem: 4.13.0-1020.21 -proposed tracker (LP: #1746017)

  [ Stefan Bader ]
  * Firmware upgrade interface for CAC Reader BCM58102 (LP: #1744041)
    - SAUCE: Support fw upgrade for CAC Reader BCM58102

  * the wifi driver is always hard blocked on a lenovo laptop (LP: #1743672)
    - ACPI: EC: Fix possible issues related to EC initialization order

  * ath9k can't connect to wifi AP (LP: #1727228)
    - ath9k: add MSI support
    - ath9k: add a quirk to set use_msi automatically

  * boot failure on AMD Raven + WesternXT (LP: #1742759)
    - SAUCE: drm/amdgpu: add atpx quirk handling (v2)

  * x86: CFL missing from early quirks (LP: #1742755)
    - drm/i915: add GT number to intel_device_info
    - drm/i915/kbl: Change a KBL pci id to GT2 from GT1.5
    - SAUCE: x86/gpu: add CFL to early quirks

  * [0cf3:e010] QCA6174A XR failed to pair with bt 4.0 device (LP: #1741166)
    - Bluetooth: btusb: Add support for 0cf3:e010

  * QCA Rome bluetooth failed to work after applying reset-resume quirk
    (LP: #1741206)
    - Revert "Bluetooth: btusb: fix QCA Rome suspend/resume"
    - usb: quirks: Add reset-resume quirk for Dell DW1820 QCA Rome Bluetooth

  * [800 G3 SFF] [800 G3 DM]External microphone of headset(3-ring) is working,
    2-ring mic not working, both not shown in sound settings (LP: #1740974)
    - ALSA: hda - Add MIC_NO_PRESENCE fixup for 2 HP machines

  * Two front mics can't work on a lenovo machine (LP: #1740973)
    - ALSA: hda - change the location for one mic on a Lenovo machine

  * No external microphone be detected via headset jack on a dell machine
    (LP: #1740972)
    - ALSA: hda - fix headset mic detection issue on a Dell machine

  * Can't detect external headset via line-out jack on some Dell machines
    (LP: #1740971)
    - ALSA: hda/realtek - Fix Dell AIO LineOut issue

 -- Timo Aaltonen <email address hidden> Mon, 29 Jan 2018 16:51:18 +0200

Changed in linux-oem (Ubuntu Xenial):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Fix Released
Changed in linux-oem (Ubuntu Bionic):
status: Invalid → Fix Committed
Timo Aaltonen (tjaalton) on 2018-04-26
Changed in linux-oem (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers