Intel Killer(R) Wi-Fi 6 AX1650i/AX1650s 160MHz Wireless Network Adapter (201NGW) [8086:34f0] subsystem [1a56:1651] not supported

Bug #1841736 reported by You-Sheng Yang on 2019-08-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned
linux-oem-osp1 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[SRU Justification]

[Impact]
These cards are currently not recognized correctly and trying to load
non-existent firmware blob iwlwifi-QuQnj-b0-hr-b0-<rev>.ucode, so the
device probing process fails and WiFi is therefore not functional.

[Fix]
Three new patches are required to bring up this device, and one of them,
"handle switching killer Qu B0 NICs to C0", is still under review in
iwlwifi-fixes tree.

One previously SRU'ed patch, "add support for qu c-step devices", was
replaced with the one in the mainline kernel tree due to a mandatory
preprocessor symbol definition introduced in the differences.

[Test Case]
Tested on AX1650s/AX1650i, as well as 9462/9560.

[Regression Risk]
Low. These patches are mostly around adding support to new devices.

========== original description =============

iwlwifi cannot initialize this device and leave following error messages in dmesg:

  iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuQnj-b0-hr-b0-50.ucode failed with error -2
  ...
  iwlwifi 0000:00:14.3: no suitable firmware found!
  iwlwifi 0000:00:14.3: minimum version required: iwlwifi-QuQnj-b0-hr-b0-39
  iwlwifi 0000:00:14.3: maximum version supported: iwlwifi-QuQnj-b0-hr-b0-50

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-oem-osp1 5.0.0.1017.18
ProcVersionSignature: Ubuntu 5.0.0-1017.19-oem-osp1 5.0.18
Uname: Linux 5.0.0-1017-oem-osp1 x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Aug 28 15:53:18 2019
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-bionic-amd64-20190418-59+beaver-osp1-melisa+X16
InstallationDate: Installed on 2019-08-14 (14 days ago)
InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 20190418-12:10
SourcePackage: linux-meta-oem-osp1
UpgradeStatus: No upgrade log present (probably fresh install)

You-Sheng Yang (vicamo) wrote :
You-Sheng Yang (vicamo) wrote :
tags: added: oem-priority originate-from-1839240 somerville
You-Sheng Yang (vicamo) wrote :
no longer affects: linux-meta-oem-osp1 (Ubuntu)
summary: - Intel Killer 1650s [8086:34f0] subsystem [1a56:1651] not supported
+ Intel Killer(R) Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW)
+ [8086:34f0] subsystem [1a56:1651] not supported

This would take backport-iwlwifi version 8039[1] or newer, or iwlwifi-fixes/pending[2] to have full support.

When enabled, it will take "iwlwifi-Qu-c0-hr-b0-*.ucode" instead of currently requested "iwlwifi-QuQnj-b0-hr-b0-*.ucode" as firmware.

[1]: https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git/commit/?id=895fe853f8ad30d8ac8460c02cf2d2943360fda4
[2]: https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/iwlwifi-fixes.git/log/?h=pending

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Bionic):
status: New → Confirmed
Changed in linux (Ubuntu Disco):
status: New → Confirmed
Changed in hwe-next:
status: New → Triaged
You-Sheng Yang (vicamo) on 2019-09-06
summary: - Intel Killer(R) Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW)
- [8086:34f0] subsystem [1a56:1651] not supported
+ Intel Killer(R) Wi-Fi 6 AX1650i/AX1650s 160MHz Wireless Network Adapter
+ (201NGW) [8086:34f0] subsystem [1a56:1651] not supported
You-Sheng Yang (vicamo) on 2019-09-06
description: updated
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: New → In Progress
Changed in linux (Ubuntu Bionic):
status: Confirmed → Won't Fix
You-Sheng Yang (vicamo) wrote :

We don't have iwlwifi patches backported for Bionic 4.15 generic/oem kernels. Instead, dkms package backport-iwlwifi is recommended.

Timo Aaltonen (tjaalton) on 2019-09-09
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
You-Sheng Yang (vicamo) on 2019-09-26
tags: added: verification-done-bionic
removed: verification-needed-bionic
You-Sheng Yang (vicamo) wrote :

Mark linux/Disco as WONTFIX. Should use either backport-iwlwifi-dkms from bug 1835858 or oem-osp1 kernel in Disco.

Changed in linux (Ubuntu Disco):
status: Confirmed → Won't Fix
Changed in linux (Ubuntu Eoan):
status: Confirmed → Invalid
You-Sheng Yang (vicamo) wrote :

Mark linux/Eoan as INVALID for Eoan generic kernel has had included all the upstream changes since 5.3.0-11.12.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-osp1 - 5.0.0-1024.27

---------------
linux-oem-osp1 (5.0.0-1024.27) bionic; urgency=medium

  * bionic/linux-oem-osp1: <version to be filled> -proposed tracker
    (LP: #1846023)

  * alsa/sof: fix the hang issue on Dell Nebula MP platforms (LP: #1845904)
    - ALSA: hda: clear output link mappinp
    - ALSA: SOF: disable L1SEN for capture stream
    - ALSA: sof: refine stop-start sequence for driver and FW
    - ALSA: sof: disable debug message for production release

  [ Ubuntu: 5.0.0-31.33 ]

  * disco/linux: 5.0.0-31.33 -proposed tracker (LP: #1846026)
  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
  * /proc/self/maps paths missing on live session (was vlc won't start; eoan
    19.10 & bionic 18.04 ubuntu/lubuntu/kubuntu/xubuntu/ubuntu-mate dailies)
    (LP: #1842382)
    - SAUCE: Revert "UBUNTU: SAUCE: shiftfs: enable overlayfs on shiftfs"

 -- Timo Aaltonen <email address hidden> Fri, 04 Oct 2019 11:24:05 +0300

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in linux-oem-osp1 (Ubuntu Disco):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers