soc/amd/renoir: detect dmic from acpi table

Bug #1887734 reported by Hui Wang
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Hui Wang
Focal
Undecided
Unassigned
Groovy
Undecided
Hui Wang
linux-oem-5.6 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

Groovy kernel already merged the patchset

[Impact]
On the amd renoir machines, there is possibility that they have no dmic
from the hardware desgin, but the driver register a dmic unconditionally,
to avoid it, add the dmic detection code in the driver.

[Fix]
Backport 3 patches from upstream.

[Test Case]
On the 3 Lenovo ADM renoir machines, boot the kernel with this patchset,
all dmic could be detected and registered as before. Disable the dmic
in the BIOS, the driver can't detect the dmic and the dmic is not
registered in the driver.

[Regression Risk]
Low, this SRU are only specific to soc/amd/renoir, and we already
tested on 3 lenovo machines, they worked as expected.

Hui Wang (hui.wang)
no longer affects: linux-oem-5.6 (Ubuntu Groovy)
Hui Wang (hui.wang)
summary: - soc/amd/renoir: improve the amd renoir audio driver to prepare work with
- ucm3
+ soc/amd/renoir: improve the amd renoir audio driver to prepare to work
+ with ucm3
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1887734

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Focal):
status: New → Incomplete
Hui Wang (hui.wang)
tags: added: oem-priority originate-from-1867844 sutton
Hui Wang (hui.wang)
description: updated
Hui Wang (hui.wang)
summary: - soc/amd/renoir: improve the amd renoir audio driver to prepare to work
- with ucm3
+ soc/amd/renoir: detect dmic from acpi table
Changed in linux (Ubuntu Groovy):
status: Incomplete → Fix Committed
Hui Wang (hui.wang)
description: updated
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.6 (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Hui Wang (hui.wang) wrote :

Tested on an AMD renoir machine,the dmic was detected from ACPI table.

tags: added: verification-done-focal
removed: verification-needed-focal
Changed in linux (Ubuntu Focal):
status: Incomplete → Fix Committed
AceLan Kao (acelankao)
Changed in linux-oem-5.6 (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.6 - 5.6.0-1021.21

---------------
linux-oem-5.6 (5.6.0-1021.21) focal; urgency=medium

  * focal/linux-oem-5.6: 5.6.0-1021.21 -proposed tracker (LP: #1889371)

  * Fix right speaker of HP laptop (LP: #1889375)
    - SAUCE: hda/realtek: Fix right speaker of HP laptop

  * blk_update_request error when mount nvme partition (LP: #1872383)
    - SAUCE: nvme-pci: prevent SK hynix PC400 from using Write Zeroes command

  * cgroup refcount is bogus when cgroup_sk_alloc is disabled (LP: #1886860)
    - cgroup: fix cgroup_sk_alloc() for sk_clone_lock()
    - cgroup: Fix sock_cgroup_data on big-endian.

  * Add support for Atlantic NIC firmware v4 (LP: #1886908)
    - net: atlantic: simplify hw_get_fw_version() usage
    - net: atlantic: align return value of ver_match function with function name
    - net: atlantic: add support for FW 4.x

  * Restart the machine successfully after suspend (LP: #1888375)
    - SAUCE: iommu/vt-d: Skip TE disabling on quirky gfx dedicated iommu
    - iommu/vt-d: Don't apply gfx quirks to untrusted devices

  * Wakeup the system by touching the touchpad (LP: #1888331)
    - gpio: gpiolib: Allow GPIO IRQs to lazy disable
    - HID: i2c-hid: Enable wakeup capability from Suspend-to-Idle

  * soc/amd/renoir: detect dmic from acpi table (LP: #1887734)
    - ASoC: amd: add logic to check dmic hardware runtime
    - ASoC: amd: add ACPI dependency check
    - ASoC: amd: fixed kernel warnings

  * [SRU][PATCH 0/1][oem-5.6] fix amd RENOIR screen backlight issue.
    (LP: #1886785)
    - Revert "drm/amd/display: disable dcn20 abm feature for bring up"

  * Enable Quectel EG95 LTE modem [2c7c:0195] (LP: #1886744)
    - net: usb: qmi_wwan: add support for Quectel EG95 LTE modem
    - USB: serial: option: add Quectel EG95 LTE modem

  * soc/amd/renoir: change the module name to make it work with ucm3
    (LP: #1888166)
    - AsoC: amd: add missing snd- module prefix to the acp3x-rn driver kernel
      module
    - remove a kernel module since its name is changed

  * System stops responding while entering S3 with SD card installed
    (LP: #1880519)
    - xhci: Return if xHCI doesn't support LPM
    - xhci: Poll for U0 after disabling USB2 LPM

  * [SRU][F/OEM-5.6] add a new OLED panel support for brightness control
    (LP: #1887909)
    - drm/dp: Lenovo X13 Yoga OLED panel brightness fix

 -- Timo Aaltonen <email address hidden> Wed, 29 Jul 2020 21:08:56 +0300

Changed in linux-oem-5.6 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.8.0-16.17

---------------
linux (5.8.0-16.17) groovy; urgency=medium

  * groovy/linux: 5.8.0-16.17 -proposed tracker (LP: #1891233)

  * Miscellaneous Ubuntu changes
    - hio -- Update to use bio_{start,end}_io_acct with 5.8+
    - Enable hio driver
    - [Packaging] Temporarily disable building doc package contents

linux (5.8.0-15.16) groovy; urgency=medium

  * groovy/linux: 5.8.0-15.16 -proposed tracker (LP: #1891177)

  * Miscellaneous Ubuntu changes
    - SAUCE: Documentation: import error c_funcptr_sig_re, c_sig_re (sphinx-
      doc/sphinx@0f49e30c)

linux (5.8.0-14.15) groovy; urgency=medium

  * groovy/linux: 5.8.0-14.15 -proposed tracker (LP: #1891085)

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts

  * msg_zerocopy.sh in net from ubuntu_kernel_selftests failed (LP: #1812620)
    - selftests/net: relax cpu affinity requirement in msg_zerocopy test

  * Fix missing HDMI/DP Audio on an HP Desktop (LP: #1890441)
    - ALSA: hda/hdmi: Add quirk to force connectivity

  * Add initial audio support for Lenovo ThinkStation P620 (LP: #1890317)
    - ALSA: usb-audio: Add support for Lenovo ThinkStation P620

  * Fix IOMMU error on AMD Radeon Pro W5700 (LP: #1890306)
    - PCI: Mark AMD Navi10 GPU rev 0x00 ATS as broken

  * Enlarge hisi_sec2 capability (LP: #1890222)
    - crypto: hisilicon - update SEC driver module parameter

  * Miscellaneous Ubuntu changes
    - [Config] Re-enable signing for ppc64el

 -- Seth Forshee <email address hidden> Tue, 11 Aug 2020 15:32:58 -0500

Changed in linux (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package linux-oem-5.6 - 5.6.0-1021.21+20.10.2

---------------
linux-oem-5.6 (5.6.0-1021.21+20.10.2) groovy; urgency=medium

  * dkms artifacts may expire from the pool (LP: #1850958)
    - [Packaging] autoreconstruct -- manage executable debian files

linux-oem-5.6 (5.6.0-1021.21+20.10.1) groovy; urgency=medium

  * dkms artifacts may expire from the pool (LP: #1850958)
    - [packaging] handle downloads from the librarian better

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
    - [Packaging] update update.conf
    - update dkms package versions

  * Introduce the new NVIDIA 450-server and the 450 UDA series (LP: #1887674)
    - [Packaging] NVIDIA -- Add signed modules for 450

  * Miscellaneous upstream changes
    - usbip: tools: fix build error for multiple definition
    - libtraceevent: Fix build with binutils 2.35
    - perf cs-etm: Move definition of 'traceid_list' global variable from header
      file

linux-oem-5.6 (5.6.0-1021.21) groovy; urgency=medium

  * Emtpy entry.

linux-oem-5.6 (5.6.0-1021.21) focal; urgency=medium

  * focal/linux-oem-5.6: 5.6.0-1021.21 -proposed tracker (LP: #1889371)

  * Fix right speaker of HP laptop (LP: #1889375)
    - SAUCE: hda/realtek: Fix right speaker of HP laptop

  * blk_update_request error when mount nvme partition (LP: #1872383)
    - SAUCE: nvme-pci: prevent SK hynix PC400 from using Write Zeroes command

  * cgroup refcount is bogus when cgroup_sk_alloc is disabled (LP: #1886860)
    - cgroup: fix cgroup_sk_alloc() for sk_clone_lock()
    - cgroup: Fix sock_cgroup_data on big-endian.

  * Add support for Atlantic NIC firmware v4 (LP: #1886908)
    - net: atlantic: simplify hw_get_fw_version() usage
    - net: atlantic: align return value of ver_match function with function name
    - net: atlantic: add support for FW 4.x

  * Restart the machine successfully after suspend (LP: #1888375)
    - SAUCE: iommu/vt-d: Skip TE disabling on quirky gfx dedicated iommu
    - iommu/vt-d: Don't apply gfx quirks to untrusted devices

  * Wakeup the system by touching the touchpad (LP: #1888331)
    - gpio: gpiolib: Allow GPIO IRQs to lazy disable
    - HID: i2c-hid: Enable wakeup capability from Suspend-to-Idle

  * soc/amd/renoir: detect dmic from acpi table (LP: #1887734)
    - ASoC: amd: add logic to check dmic hardware runtime
    - ASoC: amd: add ACPI dependency check
    - ASoC: amd: fixed kernel warnings

  * [SRU][PATCH 0/1][oem-5.6] fix amd RENOIR screen backlight issue.
    (LP: #1886785)
    - Revert "drm/amd/display: disable dcn20 abm feature for bring up"

  * Enable Quectel EG95 LTE modem [2c7c:0195] (LP: #1886744)
    - net: usb: qmi_wwan: add support for Quectel EG95 LTE modem
    - USB: serial: option: add Quectel EG95 LTE modem

  * soc/amd/renoir: change the module name to make it work with ucm3
    (LP: #1888166)
    - AsoC: amd: add missing snd- module prefix to the acp3x-rn driver kernel
      module
    - remove a kernel module since its name is changed

  * System stops responding while entering S3 with SD card installed
    (LP: #1880519)
    - xhci: Return if xHCI doesn't support LPM
    - xhci: Poll for U0 after disabl...

Read more...

Changed in linux-oem-5.6 (Ubuntu):
status: Invalid → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (97.9 KiB)

This bug was fixed in the package linux - 5.4.0-45.49

---------------
linux (5.4.0-45.49) focal; urgency=medium

  * focal/linux: 5.4.0-45.49 -proposed tracker (LP: #1893050)

  * [Potential Regression] dscr_inherit_exec_test from powerpc in
    ubuntu_kernel_selftests failed on B/E/F (LP: #1888332)
    - powerpc/64s: Don't init FSCR_DSCR in __init_FSCR()

linux (5.4.0-44.48) focal; urgency=medium

  * focal/linux: 5.4.0-44.48 -proposed tracker (LP: #1891049)

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts

  * ipsec: policy priority management is broken (LP: #1890796)
    - xfrm: policy: match with both mark and mask on user interfaces

linux (5.4.0-43.47) focal; urgency=medium

  * focal/linux: 5.4.0-43.47 -proposed tracker (LP: #1890746)

  * Packaging resync (LP: #1786013)
    - update dkms package versions

  * Devlink - add RoCE disable kernel support (LP: #1877270)
    - devlink: Add new "enable_roce" generic device param
    - net/mlx5: Document flow_steering_mode devlink param
    - net/mlx5: Handle "enable_roce" devlink param
    - IB/mlx5: Rename profile and init methods
    - IB/mlx5: Load profile according to RoCE enablement state
    - net/mlx5: Remove unneeded variable in mlx5_unload_one
    - net/mlx5: Add devlink reload
    - IB/mlx5: Do reverse sequence during device removal

  * msg_zerocopy.sh in net from ubuntu_kernel_selftests failed (LP: #1812620)
    - selftests/net: relax cpu affinity requirement in msg_zerocopy test

  * Enlarge hisi_sec2 capability (LP: #1890222)
    - Revert "UBUNTU: [Config] Disable hisi_sec2 temporarily"
    - crypto: hisilicon - update SEC driver module parameter

  * Fix missing HDMI/DP Audio on an HP Desktop (LP: #1890441)
    - ALSA: hda/hdmi: Add quirk to force connectivity

  * Fix IOMMU error on AMD Radeon Pro W5700 (LP: #1890306)
    - PCI: Mark AMD Navi10 GPU rev 0x00 ATS as broken

  * ASoC:amd:renoir: the dmic can't record sound after suspend and resume
    (LP: #1890220)
    - SAUCE: ASoC: amd: renoir: restore two more registers during resume

  * No sound, Dummy output on Acer Swift 3 SF314-57G with Ice Lake core-i7 CPU
    (LP: #1877757)
    - ASoC: SOF: Intel: hda: fix generic hda codec support

  * Fix right speaker of HP laptop (LP: #1889375)
    - SAUCE: hda/realtek: Fix right speaker of HP laptop

  * blk_update_request error when mount nvme partition (LP: #1872383)
    - SAUCE: nvme-pci: prevent SK hynix PC400 from using Write Zeroes command

  * soc/amd/renoir: detect dmic from acpi table (LP: #1887734)
    - ASoC: amd: add logic to check dmic hardware runtime
    - ASoC: amd: add ACPI dependency check
    - ASoC: amd: fixed kernel warnings

  * soc/amd/renoir: change the module name to make it work with ucm3
    (LP: #1888166)
    - AsoC: amd: add missing snd- module prefix to the acp3x-rn driver kernel
      module
    - SAUCE: remove a kernel module since its name is changed

  * Focal update: v5.4.55 upstream stable release (LP: #1890343)
    - AX.25: Fix out-of-bounds read in ax25_connect()
    - AX.25: Prevent out-of-bounds read in ax25_sendmsg()
    - dev: Defer free of skbs in flush_backlog
    - drivers/net/wan/x25_asy: Fix to make i...

Changed in linux (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers