Can only reach PC3 when ethernet is plugged r8169

Bug #1946433 reported by AceLan Kao
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Fix Released
Undecided
Unassigned
linux (Ubuntu)
Confirmed
Undecided
AceLan Kao
Focal
Invalid
Undecided
Unassigned
Impish
Won't Fix
Undecided
AceLan Kao
Jammy
Fix Released
Undecided
Unassigned
Kinetic
Confirmed
Undecided
AceLan Kao
linux-oem-5.13 (Ubuntu)
Invalid
Undecided
Unassigned
Focal
Fix Released
Undecided
AceLan Kao
Impish
Invalid
Undecided
Unassigned
Jammy
Invalid
Undecided
Unassigned
Kinetic
Invalid
Undecided
Unassigned
linux-oem-5.14 (Ubuntu)
Invalid
Undecided
Unassigned
Focal
Fix Released
Undecided
AceLan Kao
Impish
Invalid
Undecided
Unassigned
Jammy
Invalid
Undecided
Unassigned
Kinetic
Invalid
Undecided
Unassigned
linux-oem-5.17 (Ubuntu)
Invalid
Undecided
Unassigned
Jammy
Fix Released
Undecided
koba
Kinetic
Invalid
Undecided
Unassigned
linux-oem-6.0 (Ubuntu)
Invalid
Undecided
Unassigned
Jammy
Fix Released
Undecided
koba
Kinetic
Invalid
Undecided
Unassigned

Bug Description

[Impact]
System only can reach PC3, and it affects power consumption alot.

[Fix]
Kaiheng implemented a dynamic ASPM for r8169, it not only fixes the PC state issue, but also fixes network speed issue.
V7:
https://patchwork.kernel.org<email address hidden>/
V6:
https://patchwork.ozlabs.org<email address hidden>/

[Test]
Verified on 2 different systems which has PC state issue and has network speed issue, these patches fix both issues.

[Where problems could occur]
It toggles ASPM on and off depends on the network traffic during runtime, I don't think it'll lead to any regressions. Some potential issues have been addressed during the patch submitting. It's v6 now and accepted by upstream.

AceLan Kao (acelankao)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: New → In Progress
assignee: nobody → AceLan Kao (acelankao)
AceLan Kao (acelankao)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → In Progress
assignee: nobody → AceLan Kao (acelankao)
Changed in linux-oem-5.13 (Ubuntu):
status: New → Incomplete
Changed in linux-oem-5.14 (Ubuntu):
status: New → Incomplete
Changed in linux-oem-5.13 (Ubuntu):
status: Incomplete → Invalid
Changed in linux-oem-5.14 (Ubuntu):
status: Incomplete → Invalid
AceLan Kao (acelankao)
description: updated
no longer affects: linux-unstable (Ubuntu)
Changed in linux (Ubuntu Focal):
status: New → Invalid
no longer affects: linux-unstable (Ubuntu Focal)
no longer affects: linux-unstable (Ubuntu Impish)
Changed in linux (Ubuntu Impish):
status: New → In Progress
assignee: nobody → AceLan Kao (acelankao)
AceLan Kao (acelankao)
tags: added: oem-priority originate-from-1944504 somerville
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Changed in linux-oem-5.14 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-5.14/5.14.0-1006.6 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
David Chen (david.chen) wrote :

Is this landed in 5.13-OEM update?

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1019.23

---------------
linux-oem-5.13 (5.13.0-1019.23) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1019.23 -proposed tracker (LP: #1949076)

  * Fail to detect audio output from external monitor (LP: #1948767)
    - ALSA: hda: intel: Allow repeatedly probing on codec configuration errors

  * Intel I225-IT ethernet controller: igc: probe of 0000:02:00.0 failed with
    error -1 (LP: #1945576)
    - igc: Remove _I_PHY_ID checking
    - igc: Remove phy->type checking

  * Fix Screen freeze after resume from suspend with iGPU [1002:6987]
    (LP: #1949050)
    - drm/amdgpu: reenable BACO support for 699F:C7 polaris12 SKU
    - drm/amdgpu: add missing cleanups for Polaris12 UVD/VCE on suspend
    - drm/amdgpu: Fix crash on device remove/driver unload

  * Need support of Qualcomm WCN6856 (LP: #1939528)
    - Revert "UBUNTU: SAUCE: Bluetooth: btusb: Add support using different nvm for
      variant WCN6855 controller"
    - Revert "UBUNTU: SAUCE: cfg80211: save power spectral density(psd) of
      regulatory rule"
    - Revert "UBUNTU: SAUCE: cfg80211: add definition for 6 GHz power spectral
      density(psd)"
    - Revert "UBUNTU: SAUCE: ath11k: set correct NL80211_FEATURE_DYNAMIC_SMPS for
      WCN6855"
    - Revert "mac80211: save transmit power envelope element and power constraint"
    - Revert "mac80211: add parse regulatory info in 6 GHz operation information"
    - Revert "ieee80211: add power type definition for 6 GHz"
    - Revert "mac80211: use ieee802_11_parse_elems() in ieee80211_prep_channel()"
    - Revert "mac80211: always allocate struct ieee802_11_elems"
    - Revert "mac80211: mlme: find auth challenge directly"
    - Revert "mac80211: move CRC into struct ieee802_11_elems"
    - Revert "mac80211: mesh: clean up rx_bcn_presp API"
    - Revert "ath11k: support SMPS configuration for 6 GHz"
    - Revert "ath11k: add 6 GHz params in peer assoc command"
    - Revert "ieee80211: Add new A-MPDU factor macro for HE 6 GHz peer caps"
    - Revert "ath11k: copy cap info of 6G band under WMI_HOST_WLAN_5G_CAP for
      WCN6855"
    - Revert "ath11k: enable 6G channels for WCN6855"
    - Revert "ath11k: re-enable ht_cap/vht_cap for 5G band for WCN6855"
    - Revert "ath11k: fix survey dump collection in 6 GHz"
    - Revert "ath11k: fix packet drops due to incorrect 6 GHz freq value in rx
      status"
    - Revert "ath11k: add channel 2 into 6 GHz channel list"
    - Revert "ath11k: qmi: avoid error messages when dma allocation fails"
    - Revert "mac80211: parse transmit power envelope element"
    - Revert "ieee80211: add definition for transmit power envelope element"
    - Revert "ieee80211: add definition of regulatory info in 6 GHz operation
      information"
    - Revert "mac80211: notify driver on mgd TX completion"
    - Revert "ath11k: don't call ath11k_pci_set_l1ss for WCN6855"
    - Revert "ath11k: add support for WCN6855"
    - Revert "ath11k: add support to get peer id for WCN6855"
    - Revert "ath11k: setup WBM_IDLE_LINK ring once again"
    - Revert "ath11k: setup REO for WCN6855"
    - Revert "ath11k: add dp support for WCN6855"
    - Revert "ath11k:...

Read more...

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.14 - 5.14.0-1007.7

---------------
linux-oem-5.14 (5.14.0-1007.7) focal; urgency=medium

  * focal/linux-oem-5.14: 5.14.0-1007.7 -proposed tracker (LP: #1949349)

  * Intel I225-IT ethernet controller: igc: probe of 0000:02:00.0 failed with
    error -1 (LP: #1945576)
    - igc: Remove _I_PHY_ID checking
    - igc: Remove phy->type checking

  * Fix Screen freeze after resume from suspend with iGPU [1002:6987]
    (LP: #1949050)
    - drm/amdgpu: reenable BACO support for 699F:C7 polaris12 SKU
    - drm/amdgpu: add missing cleanups for Polaris12 UVD/VCE on suspend
    - drm/amdgpu: Fix crash on device remove/driver unload

  * Fail to detect audio output from external monitor (LP: #1948767)
    - ALSA: hda: intel: Allow repeatedly probing on codec configuration errors

  * Fix System hangs on black screen when reboot (LP: #1949321)
    - SAUCE: drm/i915: Don't request GMBUS to generate irqs when called while irqs
      are off
    - SAUCE: drm/i915/hdmi: Turn DP++ TMDS output buffers back on in
      encoder->shutdown()

 -- Timo Aaltonen <email address hidden> Mon, 01 Nov 2021 12:38:15 +0200

Changed in linux-oem-5.14 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.15.0-17.17

---------------
linux (5.15.0-17.17) jammy; urgency=medium

  * jammy/linux: 5.15.0-17.17 -proposed tracker (LP: #1957809)

 -- Andrea Righi <email address hidden> Thu, 13 Jan 2022 17:11:21 +0100

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Timo Aaltonen (tjaalton)
Changed in linux (Ubuntu Impish):
status: In Progress → Won't Fix
Timo Aaltonen (tjaalton)
Changed in hwe-next:
status: New → Fix Released
koba (kobako)
Changed in linux-oem-5.17 (Ubuntu Jammy):
assignee: nobody → koba (kobako)
status: New → In Progress
Changed in linux-oem-6.0 (Ubuntu Jammy):
assignee: nobody → koba (kobako)
status: New → In Progress
koba (kobako)
description: updated
tags: added: originate-from-1990805
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.17 (Ubuntu Kinetic):
status: New → Invalid
Changed in linux-oem-6.0 (Ubuntu Kinetic):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu Jammy):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Jammy):
status: New → Invalid
Changed in linux (Ubuntu Jammy):
status: New → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

not fixed in kinetic and up

Changed in linux (Ubuntu Kinetic):
status: Fix Released → Confirmed
Changed in linux-oem-5.17 (Ubuntu Jammy):
status: In Progress → Fix Committed
Changed in linux-oem-6.0 (Ubuntu Jammy):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-6.0/6.0.0-1007.7 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-jammy' to 'verification-done-jammy'. If the problem still exists, change the tag 'verification-needed-jammy' to 'verification-failed-jammy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-5.17/5.17.0-1021.22 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-jammy' to 'verification-done-jammy'. If the problem still exists, change the tag 'verification-needed-jammy' to 'verification-failed-jammy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.17 - 5.17.0-1021.22

---------------
linux-oem-5.17 (5.17.0-1021.22) jammy; urgency=medium

  * jammy/linux-oem-5.17: 5.17.0-1021.22 -proposed tracker (LP: #1992020)

  * Add some ACPI device IDs for Intel HID device (LP: #1995453)
    - SAUCE: platform/x86/intel: hid: add some ACPI device IDs

  * RaptorLake: Fix the Screen is shaking by onboard HDMI port in mirror mode
    (LP: #1993561)
    - SAUCE: drm/i915/display: Drop check for doublescan mode in modevalid
    - SAUCE: drm/i915/display: Prune Interlace modes for Display >=12

  * Can only reach PC3 when ethernet is plugged r8169 (LP: #1946433)
    - SAUCE: r8169: Enable chip-specific ASPM regardless of PCIe ASPM status
    - SAUCE: r8169: Use mutex to guard config register locking
    - SAUCE: r8169: Implement dynamic ASPM mechanism

  * Fix Turbostat is not working for fam: 6 model: 191: stepping: 2 CPU
    (LP: #1991365)
    - SAUCE: tools/power turbostat: add support for RPL-S

  * Miscellaneous Ubuntu changes
    - [Config] Update config after rebase

  [ Ubuntu: 5.17.0-11.12~22.04.8 ]

  * jammy/linux-hwe-5.17: 5.17.0-11.12~22.04.8 -proposed tracker (LP: #1992022)
  * Packaging resync (LP: #1786013)
    - [Packaging] update variants

 -- Timo Aaltonen <email address hidden> Wed, 02 Nov 2022 12:30:17 +0100

Changed in linux-oem-5.17 (Ubuntu Jammy):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton)
tags: added: verification-needed-jammy
AceLan Kao (acelankao)
tags: added: verification-done-focal verification-done-jammy
removed: verification-needed-focal verification-needed-jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (58.3 KiB)

This bug was fixed in the package linux-oem-6.0 - 6.0.0-1007.7

---------------
linux-oem-6.0 (6.0.0-1007.7) jammy; urgency=medium

  * jammy/linux-oem-6.0: 6.0.0-1007.7 -proposed tracker (LP: #1992023)

  * Packaging resync (LP: #1786013)
    - debian/dkms-versions -- update from kernel-versions (main/2022.10.10)

  * AMD Cezanne takes 5 minutes to wake up from suspend (LP: #1993715)
    - SAUCE: platform/x86/amd: pmc: Read SMU version during suspend on Cezanne
      systems

  * Add iommu passthrough quirk for Intel IPU6 on RaptorLake (LP: #1989041)
    - SAUCE: iommu: intel-ipu: use IOMMU passthrough mode for Intel IPUs on Raptor
      Lake

  * RaptorLake: Fix the Screen is shaking by onboard HDMI port in mirror mode
    (LP: #1993561)
    - SAUCE: drm/i915/display: Drop check for doublescan mode in modevalid
    - SAUCE: drm/i915/display: Prune Interlace modes for Display >=12

  * [SRU] SoF for RPL platform support (LP: #1992714)
    - ASoC: Intel: common: add ACPI matching tables for Raptor Lake
    - ASoC: SOF: Intel: pci-tgl: use RPL specific firmware definitions

  * Can only reach PC3 when ethernet is plugged r8169 (LP: #1946433)
    - SAUCE: r8169: Enable chip-specific ASPM regardless of PCIe ASPM status
    - SAUCE: r8169: Use mutex to guard config register locking
    - SAUCE: r8169: Implement dynamic ASPM mechanism

  * [SRU][J/OEM-5.17][PATCH 0/1] Fix oled brightness set above frame-average
    luminance (LP: #1978986)
    - drm: New function to get luminance range based on static hdr metadata
    - drm/amdgpu_dm: Rely on split out luminance calculation function
    - drm/i915: Use luminance range calculated during edid parsing

  * Add support for AMD PMF Cool and Quiet Framework (CnQF) (LP: #1991609)
    - platform/x86/amd/pmf: Add support for CnQF
    - platform/x86/amd/pmf: Add sysfs to toggle CnQF
    - Documentation/ABI/testing/sysfs-amd-pmf: Add ABI doc for AMD PMF

  * TEE Support for CCP driver (LP: #1991608)
    - SAUCE: crypto: ccp: Add support for TEE for PCI ID 0x14CA

  * Jammy update: v6.0.3 upstream stable release (LP: #1994038)
    - ALSA: oss: Fix potential deadlock at unregistration
    - ALSA: rawmidi: Drop register_mutex in snd_rawmidi_free()
    - ALSA: usb-audio: Fix potential memory leaks
    - ALSA: usb-audio: Fix NULL dererence at error path
    - ALSA: hda/realtek: remove ALC289_FIXUP_DUAL_SPK for Dell 5530
    - ALSA: hda/realtek: Correct pin configs for ASUS G533Z
    - ALSA: hda/realtek: Add quirk for ASUS GV601R laptop
    - ALSA: hda/realtek: Add Intel Reference SSID to support headset keys
    - mtd: rawnand: atmel: Unmap streaming DMA mappings
    - io_uring: add custom opcode hooks on fail
    - io_uring/rw: don't lose partial IO result on fail
    - io_uring/net: don't lose partial send/recv on fail
    - io_uring/rw: fix unexpected link breakage
    - io_uring/rw: don't lose short results on io_setup_async_rw()
    - io_uring/net: fix fast_iov assignment in io_setup_async_msg()
    - io_uring/net: don't update msg_name if not provided
    - io_uring: limit registration w/ SINGLE_ISSUER
    - io_uring/net: handle -EINPROGRESS correct for IORING_OP_CONNECT
    - io_uring: correct pinned_vm ac...

Changed in linux-oem-6.0 (Ubuntu Jammy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers