[SRU][I/OEM-5.13/OEM-5.14] Fix USB3.1 hotplug after S3 on AMD renoir

Bug #1952817 reported by AaronMa
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
AaronMa
linux (Ubuntu)
Undecided
Unassigned
Impish
Medium
Unassigned
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
linux-oem-5.14 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]
On new amdgpu renoir firmware, the USB-type-C port is useless when uplug the USB-type-C <-> DP/HDMI/VGA Dongle after the system resumed from S3.

[Fix]
Restore the old amdgpu fw, this issue is gone.
For new fw, AMD make kernel fix be ready, after backport, the issue is not reproduced on new fw.
Cherry-picked from stable kernel release to fix it.

[Test]
After S3 on renoir's platforms, hotplug USB, the USB3.1 devices works good.

[Where problems could occur]
AMD renoir platform may have issues when suspend.

Jammy already got this commit via stable updates v5.15.3

AaronMa (mapengyu)
tags: added: oem-priority originate-from-1949722 sutton
no longer affects: linux (Ubuntu Focal)
no longer affects: linux-oem-5.13 (Ubuntu Impish)
no longer affects: linux-oem-5.13 (Ubuntu Jammy)
no longer affects: linux-oem-5.14 (Ubuntu Impish)
no longer affects: linux-oem-5.14 (Ubuntu Jammy)
Changed in hwe-next:
assignee: nobody → AaronMa (mapengyu)
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1952817

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
AaronMa (mapengyu)
no longer affects: linux (Ubuntu Jammy)
description: updated
summary: - [SRU][I/J/OEM-5.13/OEM-5.14] Fix USB3.1 hotplug after S3 on AMD renoir
+ [SRU][I/OEM-5.13/OEM-5.14] Fix USB3.1 hotplug after S3 on AMD renoir
AaronMa (mapengyu)
description: updated
AaronMa (mapengyu)
Changed in linux (Ubuntu):
status: Incomplete → In Progress
AaronMa (mapengyu)
tags: added: originate-from-1945395
removed: originate-from-1949722
Stefan Bader (smb)
Changed in linux (Ubuntu Impish):
importance: Undecided → Medium
status: New → In Progress
Changed in linux-oem-5.13 (Ubuntu):
status: New → Invalid
Changed in linux-oem-5.14 (Ubuntu):
status: New → Invalid
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → Fix Committed
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-5.13/5.13.0-1021.25 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
AaronMa (mapengyu) wrote :

Verified on Ubuntu-oem-5.14-5.14.0-1009.9.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1021.25

---------------
linux-oem-5.13 (5.13.0-1021.25) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1021.25 -proposed tracker (LP: #1953028)

  * [SRU][I/OEM-5.13/OEM-5.14] Fix USB3.1 hotplug after S3 on AMD renoir
    (LP: #1952817)
    - drm/amd/display: Look at firmware version to determine using dmub on dcn21

  * Fix non-working e1000e device after resume (LP: #1951861)
    - SAUCE: Revert "e1000e: Additional PHY power saving in S0ix"
    - SAUCE: Revert "e1000e: Add polling mechanism to indicate CSME DPG exit"
    - SAUCE: Revert "e1000e: Add handshake with the CSME to support S0ix"

  * [SRU][I/J/OEM-5.13/OEM-5.14] Add MAC passthrough support for more Lenovo
    docks (LP: #1951767)
    - net: usb: r8152: Add MAC passthrough support for more Lenovo Docks

  * Fix missing external headset after resume problem for Cirrus CS8409 sound
    driver (LP: #1952385)
    - SAUCE: ALSA: hda/cs8409: Schedule delayed work for jack detect on resume

 -- Timo Aaltonen <email address hidden> Thu, 02 Dec 2021 19:29:38 +0200

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.14 - 5.14.0-1010.10

---------------
linux-oem-5.14 (5.14.0-1010.10) focal; urgency=medium

  * focal/linux-oem-5.14: 5.14.0-1010.10 -proposed tracker (LP: #1953346)

  * alsa/sdw: add sdw audio machine driver for several ADL machines
    (LP: #1951563)
    - ASoC: Intel: sof_sdw: Add support for SKU 0AF3 product
    - ASoC: Intel: soc-acpi: add SKU 0AF3 SoundWire configuration
    - ASoC: Intel: sof_sdw: Add support for SKU 0B00 and 0B01 products
    - ASoC: Intel: sof_sdw: Add support for SKU 0B11 product
    - ASoC: Intel: sof_sdw: Add support for SKU 0B13 product
    - ASoC: Intel: soc-acpi: add SKU 0B13 SoundWire configuration
    - ASoC: Intel: sof_sdw: Add support for SKU 0B29 product
    - ASoC: Intel: soc-acpi: add SKU 0B29 SoundWire configuration
    - ASoC: Intel: sof_sdw: Add support for SKU 0B12 product
    - ASoC: intel: sof_sdw: return the original error number
    - ASoC: intel: sof_sdw: rename be_index/link_id to link_index
    - ASoC: intel: sof_sdw: Use a fixed DAI link id for AMP
    - ASoC: intel: sof_sdw: move DMIC link id overwrite to create_sdw_dailink
    - ASoC: intel: sof_sdw: remove SOF_RT715_DAI_ID_FIX quirk
    - ASoC: intel: sof_sdw: remove get_next_be_id
    - ASoC: intel: sof_sdw: add link adr order check
    - soundwire: bus: update Slave status in sdw_clear_slave_status

 -- Chia-Lin Kao (AceLan) <email address hidden> Mon, 06 Dec 2021 22:12:32 +0800

Changed in linux-oem-5.14 (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Impish):
status: In Progress → Fix Committed
AaronMa (mapengyu)
Changed in hwe-next:
status: New → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux/5.13.0-24.24 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-impish' to 'verification-done-impish'. If the problem still exists, change the tag 'verification-needed-impish' to 'verification-failed-impish'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-impish
AaronMa (mapengyu)
tags: added: verification-done-impish
removed: verification-needed-impish
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Included in Impish Ubuntu-5.13.0-26.27

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu Impish):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers