PCIE LnkCtl ASPM not enabled under VMD mode for Alder Lake platforms

Bug #1942160 reported by You-Sheng Yang
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
OEM Priority Project
Critical
Unassigned
linux (Ubuntu)
High
You-Sheng Yang
Focal
Undecided
Unassigned
Hirsute
High
You-Sheng Yang
Impish
High
You-Sheng Yang
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.14 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang
Hirsute
Undecided
Unassigned
Impish
Undecided
Unassigned

Bug Description

[SRU Justification]

[Impact]

VMD PCI-E bridges on ADL-M/P/S use new device IDs and therefore not
covered by previous LTR reset fix in bug 1896598.

[Fix]

Additional entires to vmd_bridge_tbl in drivers/pci/quirks.c is
requierd:
* ADL-M: [8086:464d]
* ADL-P: [8086:51b0]
* ADL-S: [8086:7ab4]

[Test Case]

$ sudo lspci -vvn | grep -E '^(1|\s+LnkCtl:)'
...
10000:e0:1d.4 0604: 8086:7ab4 (rev 10) (prog-if 00 [Normal decode])
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes Disabled- CommClk+
10000:e1:00.0 0108: 8086:0975 (rev 03) (prog-if 02 [NVM Express])
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes Disabled- CommClk+

[Where problems could occur]

This will reset zeroed PCI_LTR_MAX_SNOOP_LAT and PCI_LTR_MAX_NOSNOOP_LAT
values to a fixed 3145728ns that is used on Windows. Devices might want
to set itself to a smaller value, but while this is not yet correctly
supported by VMD controller driver, so the device power consumption
might be little worse than ideal.

[Other Info]

VMD ASPM was first supported for Tiger Lake cpus, so all kernel versions
newer than 5.6 should have already the supporting function. This patch
targets Alder Lake cpus that are supported since 5.10-oem and on.

========== original bug report ==========

* ADL-M:

$ sudo lspci -vvn | grep -E '^(1|\s+LnkCtl:)'
10000:e0:06.0 PCI bridge [0604]: Intel Corporation Device [8086:464d] (rev 05)
        Kernel driver in use: pcieport
10000:e1:00.0 Non-Volatile memory controller [0108]: Intel Corporation Device [8086:f1aa] (rev 03)
        Subsystem: Intel Corporation Device [8086:390f]
        Kernel driver in use: nvme
        Kernel modules: nvme

* ADL-P:

$ sudo lspci -vvn | grep -E '^(1|\s+LnkCtl:)'
10000:e0:1d.0 0604: 8086:51b0 (prog-if 00 [Normal decode])
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
10000:e1:00.0 0108: 8086:f1a8 (rev 03) (prog-if 02 [NVM Express])
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+

* ADL-S:

$ sudo lspci -vvn | grep -E '^(1|\s+LnkCtl:)'
10000:e0:1d.4 0604: 8086:7ab4 (rev 10) (prog-if 00 [Normal decode])
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
10000:e1:00.0 0108: 8086:0975 (rev 03) (prog-if 02 [NVM Express])
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+

See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1889384, https://bugs.launchpad.net/bugs/1896598.
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gdm 1100 F.... pulseaudio
CasperMD5CheckResult: skip
Dependencies:

DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2021-04-06 (146 days ago)
InstallationMedia: Ubuntu 20.04.2 LTS "Focal Fossa" - Release amd64 (20210204)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0032 Intel Corp.
 Bus 001 Device 002: ID 062a:4c01 MosArt Semiconductor Corp. 2.4G INPUT DEVICE
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Intel Corporation Alder Lake Client Platform
Package: linux-firmware 1.187.16+staging.11 [origin: unknown]
PackageArchitecture: all
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.13.0-9010-oem root=UUID=e38f9e97-de55-4524-ba5b-a0ae4d5ea8a7 ro i915.force_probe=4680 quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.13.0-9010.11+staging.9-oem 5.13.1
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-5.13.0-9010-oem N/A
 linux-backports-modules-5.13.0-9010-oem N/A
 linux-firmware 1.187.16+staging.11
Tags: focal third-party-packages
Uname: Linux 5.13.0-9010-oem x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: N/A
_MarkForUpload: True
dmi.bios.date: 04/26/2021
dmi.bios.vendor: Intel Corporation
dmi.bios.version: ADLSFWI1.R00.2181.A00.2104261003
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: AlderLake-S ADP-S DDR5 UDIMM CRB
dmi.board.vendor: Intel Corporation
dmi.board.version: 2
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 3
dmi.chassis.vendor: Intel Corporation
dmi.chassis.version: 0.1
dmi.ec.firmware.release: 1.36
dmi.modalias: dmi:bvnIntelCorporation:bvrADLSFWI1.R00.2181.A00.2104261003:bd04/26/2021:efr1.36:svnIntelCorporation:pnAlderLakeClientPlatform:pvr0.1:sku00001004002B0100:rvnIntelCorporation:rnAlderLake-SADP-SDDR5UDIMMCRB:rvr2:cvnIntelCorporation:ct3:cvr0.1:
dmi.product.family: Alder Lake Client System
dmi.product.name: Alder Lake Client Platform
dmi.product.sku: 00001004002B0100
dmi.product.version: 0.1
dmi.sys.vendor: Intel Corporation

Revision history for this message
You-Sheng Yang (vicamo) wrote : AlsaInfo.txt

apport information

Changed in linux (Ubuntu Focal):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu Impish):
status: New → Invalid
tags: added: oem-priority originate-from-1942030 somerville
tags: added: apport-collected focal third-party-packages
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote : CRDA.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : CurrentDmesg.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : IwConfig.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lspci.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lspci-vt.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb-t.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb-v.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcEnviron.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcInterrupts.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcModules.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : RfKill.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : UdevDb.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : WifiSyslog.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : acpidump.txt

apport information

Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
You-Sheng Yang (vicamo) wrote :

PPA: https://launchpad.net/~vicamo/+archive/ubuntu/linux-staging version 5.13.0-9011.14+staging.15 and 5.14.0-9001.1+staging.15

You-Sheng Yang (vicamo)
Changed in linux (Ubuntu Hirsute):
status: New → In Progress
Changed in linux (Ubuntu Impish):
status: Confirmed → In Progress
importance: Undecided → High
Changed in linux (Ubuntu Hirsute):
importance: Undecided → High
assignee: nobody → You-Sheng Yang (vicamo)
Changed in linux (Ubuntu Impish):
assignee: nobody → You-Sheng Yang (vicamo)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → In Progress
importance: Undecided → High
assignee: nobody → You-Sheng Yang (vicamo)
Changed in linux-oem-5.13 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Focal):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
status: New → In Progress
Changed in linux-oem-5.10 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Impish):
status: New → Invalid
You-Sheng Yang (vicamo)
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote :
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Missing [8086:7ac8]:

$ sudo lspci -vvn | grep -E '^(1|\s+LnkCtl:)'
10000:e0:1a.0 PCI bridge [0604]: Intel Corporation Device [8086:7ac8] (rev 11)
        Kernel driver in use: pcieport
10000:e1:00.0 Non-Volatile memory controller [0108]: KIOXIA Corporation Device [1e0f:0001]
        Subsystem: KIOXIA Corporation Device [1e0f:0001]
        Kernel driver in use: nvme
        Kernel modules: nvme

Alex Tu (alextu)
Changed in oem-priority:
importance: Undecided → Critical
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Update by review comments.

Changed in linux (Ubuntu Hirsute):
status: In Progress → Won't Fix
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

oem-5.10 doesn't need this, ADL is enabled with 5.13 (S) and 5.14 (M/P)

Changed in linux-oem-5.10 (Ubuntu Focal):
status: In Progress → Invalid
Revision history for this message
You-Sheng Yang (vicamo) wrote :
Timo Aaltonen (tjaalton)
affects: linux-oem-5.10 (Ubuntu Focal) → linux-oem-5.14 (Ubuntu Focal)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: Invalid → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-hwe-5.13/5.13.0-17.17~20.04.1 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-19.19

---------------
linux (5.13.0-19.19) impish; urgency=medium

  * impish/linux: 5.13.0-19.19 -proposed tracker (LP: #1946337)

  * impish:linux-aws 5.13 panic during systemd autotest (LP: #1946001)
    - [Config] disable KFENCE

 -- Andrea Righi <email address hidden> Thu, 07 Oct 2021 11:09:51 +0200

Changed in linux (Ubuntu Impish):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1017.21

---------------
linux-oem-5.13 (5.13.0-1017.21) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1017.21 -proposed tracker (LP: #1946722)

  * Intel AX201 8086:7af0 subsys 8086:4070 hardware reset periodically: FW error
    in SYNC CMD UNKNOWN (LP: #1941665)
    - iwlwifi: mvm: support BIOS enable/disable for 11ax in Russia
    - iwlwifi: mvm: Read acpi dsm to get unii4 enable/disable bitmap.

 -- Timo Aaltonen <email address hidden> Tue, 12 Oct 2021 11:54:40 +0300

Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Released
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.14 (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Fix Released
tags: added: verification-done-focal
removed: verification-needed-focal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers