[ADL-S] Broken PMU hardware detected, using software events only.

Bug #1933617 reported by You-Sheng Yang
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
High
You-Sheng Yang
Focal
Undecided
Unassigned
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang

Bug Description

[Summary]
Broken PMU hardware detected, using software events on

log
04 16:04:26 u-Inspiron kernel: Broken PMU hardware detected, using software events only.
04 16:04:26 u-Inspiron kernel: Failed to access perfctr msr (MSR 18e is ffffffffffffffff)
04 16:04:26 u-Inspiron kernel: rcu: Hierarchical SRCU implementation.
04 16:04:26 u-Inspiron kernel: NMI watchdog: Perf NMI watchdog permanently disabled
04 16:04:26 u-Inspiron kernel: smp: Bringing up secondary CPUs ...
04 16:04:26 u-Inspiron kernel: x86: Booting SMP configuration:

[Reproduce Steps]
1. Boot to Ubuntu with 5.13 kernel
2. Intel PMU driver report Broken HW detected
3. journalctl -k

[Results]
Expected: PMU hardware works normally
Actual: PMU borken hardware detected

--
Upstream bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=213443

Revision history for this message
You-Sheng Yang (vicamo) wrote :
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Proposed fix: https://lore<email address hidden>/

tags: added: oem-priority originate-from-1930885 somerville
Revision history for this message
You-Sheng Yang (vicamo) wrote :

PPA: https://launchpad.net/~vicamo/+archive/ubuntu/ppa-1933617

Version 5.13.0-2004.4+lp1933617.1.adl.pmu verify failed. Still have this issue.

Revision history for this message
You-Sheng Yang (vicamo) wrote (last edit ):

attach dmesg capture from ADL-S running 5.13.0-1005-oem kernel with korg tip/tip.git branch perf/core (HEAD commit 012669c740e6 "perf: Fix task context PMU for Hetero"). Still reproducible.

You-Sheng Yang (vicamo)
tags: added: originate-from-1931993
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Confirmed this is a known issue in early staging engineering samples of big-core only CPUs with stepping < 0x03. Will close this as WONTFIX then.

Changed in linux-oem-5.13 (Ubuntu):
status: New → Won't Fix
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → Won't Fix
You-Sheng Yang (vicamo)
Changed in hwe-next:
status: New → Won't Fix
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Second thought. While there are still a few fixes for this issue not yet applied to linux-5.13 stable, nor on 5.13-oem/generic, so I think it's necessary to get this fixed first before new production grade hw becoming available.

Changed in hwe-next:
status: Won't Fix → In Progress
Changed in linux-oem-5.13 (Ubuntu):
status: Won't Fix → In Progress
Changed in linux-oem-5.13 (Ubuntu Focal):
status: Won't Fix → In Progress
Changed in linux-oem-5.13 (Ubuntu):
status: In Progress → Invalid
Changed in linux-oem-5.13 (Ubuntu Focal):
importance: Undecided → High
assignee: nobody → You-Sheng Yang (vicamo)
Changed in linux-oem-5.13 (Ubuntu):
assignee: You-Sheng Yang (vicamo) → nobody
Changed in linux (Ubuntu Focal):
status: New → Won't Fix
Changed in linux (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → You-Sheng Yang (vicamo)
Revision history for this message
You-Sheng Yang (vicamo) wrote :
AceLan Kao (acelankao)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
katragaddamastan (katragaddamastan) wrote :

Hi vicamo can please give little info who has given conclusion about stepping ?

Confirmed this is a known issue in early staging engineering samples of big-core only CPUs with stepping < 0x03.

Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
You-Sheng Yang (vicamo) wrote :

verified linux-oem-5.13 version 5.13.0-1010.11 from focal-proposed.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.6 KiB)

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1010.11

---------------
linux-oem-5.13 (5.13.0-1010.11) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1010.11 -proposed tracker (LP: #1937217)

  * Packaging resync (LP: #1786013)
    - [Packaging] update update.conf, follow impish

  * [SRU][OEM-5.13/U] Fix firmware reload failure of MT7921 (LP: #1936790)
    - mt76: mt7921: continue to probe driver when fw already downloaded

  * Backport support for AMD SMU statistics (LP: #1934809)
    - platform/x86: amd-pmc: Fix command completion code
    - platform/x86: amd-pmc: Fix SMU firmware reporting mechanism
    - platform/x86: amd-pmc: call dump registers only once
    - platform/x86: amd-pmc: Add support for logging SMU metrics
    - platform/x86: amd-pmc: Add support for logging s0ix counters
    - platform/x86: amd-pmc: Add support for ACPI ID AMDI0006
    - platform/x86: amd-pmc: Add new acpi id for future PMC controllers
    - platform/x86: amd-pmc: Use return code on suspend
    - platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd()
    - platform/x86: amd-pmc: Fix undefined reference to __udivdi3

  * Skip rtcpie test in kselftests/timers if the default RTC device does not
    exist (LP: #1937991)
    - selftests: timers: rtcpie: skip test if default RTC device does not exist

  * Support AMD W6600 [1002:73E3] (LP: #1938145)
    - drm/amdgpu: add new dimgrey cavefish DID

  * Add additional Mediatek MT7921 WiFi/BT device IDs (LP: #1937004)
    - Bluetooth: btusb: Fixed too many in-token issue for Mediatek Chip.
    - Bluetooth: btusb: Add support for Lite-On Mediatek Chip
    - Bluetooth: btusb: fix memory leak
    - SAUCE: Bluetooth: btusb: Add Mediatek MT7921 support for Foxconn
    - SAUCE: Bluetooth: btusb: Add Mediatek MT7921 support for IMC Network
    - SAUCE: Bluetooth: btusb: Add support for Foxconn Mediatek Chip

  * Add new PCI MMIO based thermal driver [8086:461d] for Intel Alder Lake
    (LP: #1934741)
    - thermal/drivers/int340x/processor_thermal: Split enumeration and processing
      part
    - thermal/drivers/int340x/processor_thermal: Add PCI MMIO based thermal driver

  * On TGL platforms screen shows garbage when browsing website by scrolling
    mouse (LP: #1926579)
    - drm/i915/display: Disable PSR2 if TGL Display stepping is B1 from A0

  * Fix kernel panic caused by legacy devices on AMD platforms (LP: #1936682)
    - SAUCE: iommu/amd: Keep swiotlb enabled to ensure devices with 32bit DMA
      still work

  * Fix display output on HP hybrid GFX laptops (LP: #1936296)
    - drm/i915: Invoke another _DSM to enable MUX on HP Workstation laptops

  * Add support for AMD BCL DID (LP: #1936785)
    - SAUCE: drm/amdgpu: add another Renior DID

  * e1000e blocks the boot process when it tried to write checksum to its NVM
    (LP: #1936998)
    - SAUCE: e1000e: Do not take care about recovery NVM checksum

  * Mute/mic LEDs no function on some HP platfroms (LP: #1934878)
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 450 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 445 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 630 G8

  * ...

Read more...

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers