The front mic can't be detected on a lenovo thinkstation machine

Bug #1937144 reported by Hui Wang
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux-oem-5.10 (Ubuntu)
High
Unassigned
Focal
High
Hui Wang
linux-oem-5.13 (Ubuntu)
Medium
Unassigned
Focal
Medium
Unassigned

Bug Description

The patch is sent to oem-5.10 first, and other ubuntu kernels will
merge this patch with stable update since this patch was already
CCed to stable.

[Impact]
Users plug a headset or microphone to the front mic jack, but the
system can't detect the plug and will not set the mic to be the
active input device.

[Fix]
Backport a upstream patch, this will change the front mic jack's
name from Front Mic to Mic, then the pulseaudio could handle the
plug/unplug.

[Test]
Plug a headset to the front mic jack, open the gnome-sound-setting,
the front mic is the active input device, use this device to record
sound, it could record the sound successfully.

[Where problems could occur]
It could make the other mic can't be detected, but this possibility is
very low and I alreaed tested all audio jacks on that machine, all worked
well as before.

Hui Wang (hui.wang)
affects: linux (Ubuntu) → linux-oem-5.10 (Ubuntu)
Changed in linux-oem-5.10 (Ubuntu):
status: New → In Progress
Changed in linux-oem-5.10 (Ubuntu Focal):
status: New → In Progress
tags: added: oem-priority originate-from-1934844 sutton
Hui Wang (hui.wang)
description: updated
Changed in linux-oem-5.10 (Ubuntu):
importance: Undecided → High
Changed in linux-oem-5.10 (Ubuntu Focal):
importance: Undecided → High
AceLan Kao (acelankao)
Changed in linux-oem-5.10 (Ubuntu Focal):
status: In Progress → Fix Committed
assignee: nobody → Hui Wang (hui.wang)
Changed in linux-oem-5.10 (Ubuntu):
status: In Progress → Invalid
assignee: Hui Wang (hui.wang) → nobody
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Hui Wang (hui.wang) wrote :

Installed the proposed kernel on the machine, reboot, and plug a headest to the front mic audio jack, the mic could be detected and could record sound via it.

Verified done.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Bin Li (binli) wrote :

Installed the 21.04, I could reproduced this issue too.

kernel: 5.11.0-25-generic

Revision history for this message
Bin Li (binli) wrote :

Tested 5.10-1043-oem kernel in proposed, this issue is fixed.

And please help merge the fix into 5.13 oem kernel, on 5.13.0-1009-oem kernel I could reproduce this issue. Thanks!

Revision history for this message
Hui Wang (hui.wang) wrote :

the patch will be merged to all 5.13-generic and 5.13-oem kernels with stable update. Do we put 5.10-oem kernel in the image?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.10 - 5.10.0-1044.46

---------------
linux-oem-5.10 (5.10.0-1044.46) focal; urgency=medium

  * focal/linux-oem-5.10: 5.10.0-1044.46 -proposed tracker (LP: #1939533)

  * mute/micmute LEDs no function on HP ProBook 650 G8 (LP: #1939473)
    - SAUCE: ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 650 G8
      Notebook PC

 -- Chia-Lin Kao (AceLan) <email address hidden> Wed, 11 Aug 2021 17:35:07 +0800

Changed in linux-oem-5.10 (Ubuntu Focal):
status: Fix Committed → Fix Released
Hui Wang (hui.wang)
Changed in linux-oem-5.13 (Ubuntu):
status: New → In Progress
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → In Progress
importance: Undecided → Medium
Changed in linux-oem-5.13 (Ubuntu):
importance: Undecided → Medium
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Changed in linux-oem-5.13 (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers