Backport support for AMD SMU statistics

Bug #1934809 reported by Mario Limonciello
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Impish
Undecided
Unassigned
linux-oem-5.10 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Kai-Heng Feng
Impish
Undecided
Unassigned
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Kai-Heng Feng
Impish
Undecided
Unassigned

Bug Description

[Impact]
AMD RN and CZN SOC can collect extra debugging data for s0i3. This information is useful for finding problems with IP blocks not going into correct states.

[Fix]
The following patch series adds support for these stats and will be included in 5.14.
https://patchwork.kernel.org/project/platform<email address hidden>/

[Test]
Check for extra debugfs files on amd platform. Verify that s0i3 shows successful enter (counter increases to non-zero).

[Where problems could occur]
The code is only used on amd platforms in s2idle. It would be specific to those platforms and cases (where it is adding support for debugging).

Changed in linux-oem-5.10 (Ubuntu):
status: New → Invalid
Changed in linux-oem-5.13 (Ubuntu):
status: New → Invalid
tags: added: originate-from-1928846
Changed in linux-oem-5.13 (Ubuntu Focal):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
Changed in linux-oem-5.10 (Ubuntu Focal):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Mario, can we skip OEM-5.10? The backport will block OEM-5.10 kernel to suspend, so I'd like to just target OEM-5.13.

Revision history for this message
Mario Limonciello (superm1) wrote :

KH, That's surprising to me.... but OEM-5.13 is OK with it?

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Yes, it works correctly on OEM-5.13. If there's no compelling reason, I think we should skip OEM-5.10 as it should transit to OEM-5.13 soon.

Revision history for this message
Mario Limonciello (superm1) wrote :

Sounds good, thanks.

Changed in linux-oem-5.10 (Ubuntu Focal):
status: New → Won't Fix
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
tags: added: verification-done-focal
removed: verification-needed-focal
Changed in linux (Ubuntu Focal):
status: New → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.6 KiB)

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1010.11

---------------
linux-oem-5.13 (5.13.0-1010.11) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1010.11 -proposed tracker (LP: #1937217)

  * Packaging resync (LP: #1786013)
    - [Packaging] update update.conf, follow impish

  * [SRU][OEM-5.13/U] Fix firmware reload failure of MT7921 (LP: #1936790)
    - mt76: mt7921: continue to probe driver when fw already downloaded

  * Backport support for AMD SMU statistics (LP: #1934809)
    - platform/x86: amd-pmc: Fix command completion code
    - platform/x86: amd-pmc: Fix SMU firmware reporting mechanism
    - platform/x86: amd-pmc: call dump registers only once
    - platform/x86: amd-pmc: Add support for logging SMU metrics
    - platform/x86: amd-pmc: Add support for logging s0ix counters
    - platform/x86: amd-pmc: Add support for ACPI ID AMDI0006
    - platform/x86: amd-pmc: Add new acpi id for future PMC controllers
    - platform/x86: amd-pmc: Use return code on suspend
    - platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd()
    - platform/x86: amd-pmc: Fix undefined reference to __udivdi3

  * Skip rtcpie test in kselftests/timers if the default RTC device does not
    exist (LP: #1937991)
    - selftests: timers: rtcpie: skip test if default RTC device does not exist

  * Support AMD W6600 [1002:73E3] (LP: #1938145)
    - drm/amdgpu: add new dimgrey cavefish DID

  * Add additional Mediatek MT7921 WiFi/BT device IDs (LP: #1937004)
    - Bluetooth: btusb: Fixed too many in-token issue for Mediatek Chip.
    - Bluetooth: btusb: Add support for Lite-On Mediatek Chip
    - Bluetooth: btusb: fix memory leak
    - SAUCE: Bluetooth: btusb: Add Mediatek MT7921 support for Foxconn
    - SAUCE: Bluetooth: btusb: Add Mediatek MT7921 support for IMC Network
    - SAUCE: Bluetooth: btusb: Add support for Foxconn Mediatek Chip

  * Add new PCI MMIO based thermal driver [8086:461d] for Intel Alder Lake
    (LP: #1934741)
    - thermal/drivers/int340x/processor_thermal: Split enumeration and processing
      part
    - thermal/drivers/int340x/processor_thermal: Add PCI MMIO based thermal driver

  * On TGL platforms screen shows garbage when browsing website by scrolling
    mouse (LP: #1926579)
    - drm/i915/display: Disable PSR2 if TGL Display stepping is B1 from A0

  * Fix kernel panic caused by legacy devices on AMD platforms (LP: #1936682)
    - SAUCE: iommu/amd: Keep swiotlb enabled to ensure devices with 32bit DMA
      still work

  * Fix display output on HP hybrid GFX laptops (LP: #1936296)
    - drm/i915: Invoke another _DSM to enable MUX on HP Workstation laptops

  * Add support for AMD BCL DID (LP: #1936785)
    - SAUCE: drm/amdgpu: add another Renior DID

  * e1000e blocks the boot process when it tried to write checksum to its NVM
    (LP: #1936998)
    - SAUCE: e1000e: Do not take care about recovery NVM checksum

  * Mute/mic LEDs no function on some HP platfroms (LP: #1934878)
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 450 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 445 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 630 G8

  * ...

Read more...

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1934809

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Impish):
status: Incomplete → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-16.16

---------------
linux (5.13.0-16.16) impish; urgency=medium

  * impish/linux: 5.13.0-16.16 -proposed tracker (LP: #1942611)

  * Miscellaneous Ubuntu changes
    - [Config] update toolchain in configs

  * Miscellaneous upstream changes
    - Revert "UBUNTU: [Config] Enable CONFIG_UBSAN_BOUNDS"

 -- Andrea Righi <email address hidden> Fri, 03 Sep 2021 16:21:14 +0200

Changed in linux (Ubuntu Impish):
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers