Intel IPU6 camera: Microsoft Teams can not access the webcam for few minutes when it starts

Bug #1929157 reported by You-Sheng Yang
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux-oem-5.10 (Ubuntu)
Undecided
Unassigned
Focal
High
You-Sheng Yang

Bug Description

[SRU Justification]

[Impact]

Intel IPU6 camera driver includes a test pattern generator for early
stage development before hardware ready. This driver exposes additional
device nodes up to 24 of them as video devices. While Microsoft Teams,
and maybe other video/camera apps as well, tries to locate a suitable
device one by one, this may take up to minutes before returning to a
usable state.

[Fix]

Intel resolved this by removing TPG in their kernel driver release
Release_20210520
(https://github.com/intel/ipu6-drivers/commit/362375c928d184fb0b4187df7da1ffd506bbd07f).

[Test Case]

Before this patch, there are 25 video devices on the testing platform.
One additional is created by v4l2loopback. By removing TPG as this
change does, the remaining video devices should be two exactly:

  $ ls -al /dev/video*
  crw-rw----+ 1 root video 81, 0 May 25 02:08 /dev/video0
  crw-rw---- 1 root video 81, 1 May 25 02:08 /dev/video1

[Where problems could occur]

On this platform TPG is never used after hardware being enabled. So it's
probably pretty safe to remove them.

[Other Info]

While Intel IPU6 driver is currently for oem-5.10 only and there is plan
for newer kernels at the moment, only oem-5.10 is nominated.

========== original bug description ==========

Both of snap and deb of Microsoft Teams apps take minutes to probe all video device nodes before starting up on Intel IPU6 camera platforms. It's rooted in the extra video devices created for IPU6 TPG (test pattern generator), and Intel resolved this by removing TPG in their kernel driver release Release_20210520 (https://github.com/intel/ipu6-drivers/commit/362375c928d184fb0b4187df7da1ffd506bbd07f).
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.17
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: u 2219 F.... pulseaudio
CasperMD5CheckResult: skip
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-focal-amd64-20200502-85+fossa-mewtwo+X82
DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2021-05-21 (4 days ago)
InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 20200502-05:58
MachineType: Dell Inc. Latitude 9420
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.10.0-2026-oem root=UUID=597af0c1-07a4-45f8-9de9-77ca8ed3661d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.10.0-2026.27+lp1926275.1.fix.ov01a1s.iq-oem 5.10.31
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-5.10.0-2026-oem N/A
 linux-backports-modules-5.10.0-2026-oem N/A
 linux-firmware 1.187.12
Tags: focal
Uname: Linux 5.10.0-2026-oem x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: N/A
_MarkForUpload: True
dmi.bios.date: 02/27/2021
dmi.bios.release: 1.1
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.1.1
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.1.1:bd02/27/2021:br1.1:svnDellInc.:pnLatitude9420:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
dmi.product.family: Latitude
dmi.product.name: Latitude 9420
dmi.product.sku: 0A32
dmi.sys.vendor: Dell Inc.

You-Sheng Yang (vicamo)
tags: added: oem-priority originate-from-1924720 somerville
Changed in linux-oem-5.10 (Ubuntu):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Focal):
status: New → In Progress
importance: Undecided → High
assignee: nobody → You-Sheng Yang (vicamo)
Revision history for this message
You-Sheng Yang (vicamo) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected focal
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote : CRDA.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : CurrentDmesg.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : IwConfig.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lspci.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lspci-vt.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb-t.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb-v.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcInterrupts.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcModules.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : RfKill.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : UdevDb.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : WifiSyslog.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : acpidump.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote :
description: updated
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.10 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Verified linux-oem-5.10 version 5.10.0-1030.31 from focal-proposed.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.10 - 5.10.0-1032.33

---------------
linux-oem-5.10 (5.10.0-1032.33) focal; urgency=medium

  * focal/linux-oem-5.10: 5.10.0-1032.33 -proposed tracker (LP: #1932138)

  * Mute/Mic mute LEDs and right speaker are not work on HP platforms
    (LP: #1932055)
    - ALSA: hda/realtek: fix mute/micmute LEDs and speaker for HP Elite Dragonfly
      G2
    - ALSA: hda/realtek: fix mute/micmute LEDs and speaker for HP EliteBook x360
      1040 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP EliteBook 840 Aero G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ZBook Power G8

 -- Timo Aaltonen <email address hidden> Wed, 16 Jun 2021 15:27:58 +0300

Changed in linux-oem-5.10 (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers