Update - Fix no screen show on display after S3 on CML-R

Bug #1922768 reported by koba on 2021-04-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Status tracked in Hirsute
Focal
Undecided
Unassigned
Hirsute
Undecided
koba
linux-oem-5.10 (Ubuntu)
Status tracked in Hirsute
Focal
Undecided
koba
Hirsute
Undecided
Unassigned

Bug Description

[Impact]
On CML-R, after S3, No screen show on all three connector(3*DP).

[Fix]
Here's v4 patch and has been landed on drm-tip,
https://patchwork<email address hidden>,
so revert the old and resend the v4 patch.
For Legacy S3 suspend/resume GEN9 BC needs to enable and setup TGP PCH.

[Test Case]
1. Connected the monitor on one of 3*DP on CML-R.
2. Suspend&resume the machine.
3. Check the monitor can output something.

[Where problems could occur]
Just Enable the hpd detection in IRQ installer and during suspend&resume.

koba (kobako) on 2021-04-06
Changed in linux-oem-5.10 (Ubuntu Focal):
status: New → In Progress
Changed in linux (Ubuntu Hirsute):
status: New → In Progress
assignee: nobody → koba (kobako)
Changed in linux-oem-5.10 (Ubuntu Focal):
assignee: nobody → koba (kobako)
koba (kobako) on 2021-04-06
description: updated
koba (kobako) on 2021-04-06
description: updated
koba (kobako) on 2021-04-07
tags: added: oem-priority originate-from-1911190 somerville
tags: added: originate-from-1912745
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers