ntfsresize detected bad sectors but chkdsk does not.

Bug #763155 reported by Steve Romanow
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-ntfs (Ubuntu)
New
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

to reproduce, assume this:

2 primary partitions, sda1 and sda3. and sda5 is in an extended partition. win7 is on sda1. sda3 is 20g, sda5 is 120g.

boot to live media
choose Install 11.04

**** key to the problem, I think *****
This did not occur on first install, only on reinstall attempts.
Choose "Something Else" to launch PartMan
choose your partitions (sda3 == /, sda5 == /home, format both. Install grub to MBR
Press Install Now
Formatting starts, dialog proceeeds to "Where Are You". Choose city (Detroit for me)
Keyboard Setup, i chose USA, Next

"ubi-usersetup failed with error code 10"

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.6.5
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sat Apr 16 18:17:16 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Steve Romanow (slestak989) wrote :
Revision history for this message
Steve Romanow (slestak989) wrote :

In Syslog, time Apr 16 14:34:54 I think is where the problem was occuring

Revision history for this message
Steve Romanow (slestak989) wrote :

I can duplicate this for a dev if needed.

Revision history for this message
Evan (ev) wrote :

Your disk has bad sectors. Please replace your hard drive and then the installation should work fine.

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Invalid
Revision history for this message
Steve Romanow (slestak989) wrote : Re: [Bug 763155] Re: ubi-usersetup failed with error code 10

I do not believe that is the case.

I am able to install other versions of ubuntu and debian. Granted,
the sectors is a problem, but I don't think it is "the" problem.

On Wed, Apr 20, 2011 at 12:24 PM, Evan Dandrea
<email address hidden> wrote:
> Your disk has bad sectors.  Please replace your hard drive and then the
> installation should work fine.
>
> Thanks!
>
> ** Changed in: ubiquity (Ubuntu)
>       Status: New => Invalid
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/763155
>
> Title:
>  ubi-usersetup failed with error code 10
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/763155/+subscribe
>

Revision history for this message
Steve Romanow (slestak989) wrote : Re: ubi-usersetup failed with error code 10

I would like to reopen this please. I downloaded OpenSUSE livecd and installed it in the same fashion (same partitions) with no drama. Opensuse auto detected the partitions, assigned them the way I did manually, and installed first time.

I also booted win7 (from sda2) and setup a chkdisk and it found no bad sectors.

I do think this is a problem with the 11.04 installer and have invested enough time in this.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

from the logs the error is caused by:

Apr 16 14:32:46 ubuntu ntfsresize: ntfsresize v2.0.0 (libntfs 10:0:0)
Apr 16 14:32:46 ubuntu ntfsresize: Device name : /dev/sda2
Apr 16 14:32:46 ubuntu ntfsresize: NTFS volume version: 3.1
Apr 16 14:32:46 ubuntu ntfsresize: Cluster size : 4096 bytes
Apr 16 14:32:46 ubuntu ntfsresize: Current volume size: 268464878080 bytes (268465 MB)
Apr 16 14:32:46 ubuntu ntfsresize: Current device size: 268464881664 bytes (268465 MB)
Apr 16 14:32:46 ubuntu ntfsresize: ERROR: This software has detected that the disk has at least 2 bad sectors.
Apr 16 14:32:46 ubuntu ntfsresize: ****************************************************************************
Apr 16 14:32:46 ubuntu ntfsresize: * WARNING: The disk has bad sector. This means physical damage on the disk *
Apr 16 14:32:46 ubuntu ntfsresize: * surface caused by deterioration, manufacturing faults or other reason. *
Apr 16 14:32:46 ubuntu ntfsresize: * The reliability of the disk may stay stable or degrade fast. We suggest *
Apr 16 14:32:46 ubuntu ntfsresize: * making a full backup urgently by running 'ntfsclone --rescue ...' then *
Apr 16 14:32:46 ubuntu ntfsresize: * run 'chkdsk /f /r' on Windows and rebooot it TWICE! Then you can resize *
Apr 16 14:32:46 ubuntu ntfsresize: * NTFS safely by additionally using the --bad-sectors option of ntfsresize.*
Apr 16 14:32:46 ubuntu ntfsresize: ****************************************************************************
Apr 16 14:32:46 ubuntu partman: Error running 'ntfsresize --info'

I'm assigning to linux-ntfsprogs if you think ntfsresize wrongly identified bad sectors.

affects: ubiquity (Ubuntu) → linux-ntfs (Ubuntu)
summary: - ubi-usersetup failed with error code 10
+ ntfsresize detected bad sectors but chkdsk does not.
Changed in linux-ntfs (Ubuntu):
status: Invalid → New
Revision history for this message
Steve Romanow (slestak989) wrote : Re: [Bug 763155] Re: ubi-usersetup failed with error code 10

Thanks for looking at this Jean Baptiste.

The install I was running was not using sda2. I was formatting and
installing to sda3 and sda5. There was no resize called for.

Revision history for this message
Steve Romanow (slestak989) wrote :

And if the install failed because of this error, shouldn't the error
dialog come from ubiquity.partman instead of ubi-usersetup?

On Fri, Apr 22, 2011 at 9:11 AM, Steve Romanow <email address hidden> wrote:
> Thanks for looking at this Jean Baptiste.
>
> The install I was running was not using sda2.  I was formatting and
> installing to sda3 and sda5.  There was no resize called for.
>

Revision history for this message
Steve Romanow (slestak989) wrote :

I have the machine at work with me today. I have beta1 live media (I
think) and I will do some disk error checkign using the ubuntu live
environment and see what I can find out.

Thanks Again.

On Fri, Apr 22, 2011 at 9:13 AM, Steve Romanow <email address hidden> wrote:
> And if the install failed because of this error, shouldn't the error
> dialog come from ubiquity.partman instead of ubi-usersetup?
>
>
>
> On Fri, Apr 22, 2011 at 9:11 AM, Steve Romanow <email address hidden> wrote:
>> Thanks for looking at this Jean Baptiste.
>>
>> The install I was running was not using sda2.  I was formatting and
>> installing to sda3 and sda5.  There was no resize called for.
>>
>

Revision history for this message
Steve Romanow (slestak989) wrote :

The reinstall with the natty beta1 media has the "Who Are You" dialog
after the timezone and keyboard selection. This is the dialog that
was not appearing for me on the natty beta2 media.

On Fri, Apr 22, 2011 at 9:26 AM, Steve Romanow <email address hidden> wrote:
> I have the machine at work with me today.  I have beta1 live media (I
> think) and I will do some disk error checkign using the ubuntu live
> environment and see what I can find out.
>
> Thanks Again.
>
> On Fri, Apr 22, 2011 at 9:13 AM, Steve Romanow <email address hidden> wrote:
>> And if the install failed because of this error, shouldn't the error
>> dialog come from ubiquity.partman instead of ubi-usersetup?
>>
>>
>>
>> On Fri, Apr 22, 2011 at 9:11 AM, Steve Romanow <email address hidden> wrote:
>>> Thanks for looking at this Jean Baptiste.
>>>
>>> The install I was running was not using sda2.  I was formatting and
>>> installing to sda3 and sda5.  There was no resize called for.
>>>
>>
>

Revision history for this message
Steve Romanow (slestak989) wrote :

BETA1 does not exhibit this problem. The first install went well
(which was not where the problem surfaced) and the reinstall did show
me the "Who Are You" dialog.

BETA2 did not show me the "Who Are You" dialog. This is repeatable.

On Fri, Apr 22, 2011 at 9:44 AM, Steve Romanow <email address hidden> wrote:
> The reinstall with the natty beta1 media has the "Who Are You" dialog
> after the timezone and keyboard selection.  This is the dialog that
> was not appearing for me on the natty beta2 media.
>
> On Fri, Apr 22, 2011 at 9:26 AM, Steve Romanow <email address hidden> wrote:
>> I have the machine at work with me today.  I have beta1 live media (I
>> think) and I will do some disk error checkign using the ubuntu live
>> environment and see what I can find out.
>>
>> Thanks Again.
>>
>> On Fri, Apr 22, 2011 at 9:13 AM, Steve Romanow <email address hidden> wrote:
>>> And if the install failed because of this error, shouldn't the error
>>> dialog come from ubiquity.partman instead of ubi-usersetup?
>>>
>>>
>>>
>>> On Fri, Apr 22, 2011 at 9:11 AM, Steve Romanow <email address hidden> wrote:
>>>> Thanks for looking at this Jean Baptiste.
>>>>
>>>> The install I was running was not using sda2.  I was formatting and
>>>> installing to sda3 and sda5.  There was no resize called for.
>>>>
>>>
>>
>

Revision history for this message
Steve Romanow (slestak989) wrote :

Here is the syslog from the beta1 install. No error 10 and no ntfs error.

beta1 has ntfsresize 2.0.0, same as beta2.

It seems there is some parallelism, while you answer the dialogs in ubiquity, some copying and partman actions are occurring on another thread.

Where to now?

Revision history for this message
David Young (dove-young) wrote :

I met this issue either. I have been blocked by this bug 747579 Ubiquity gets stuck at restoring previous packages Then I rebooted system after hours waiting. I tried the installation reported in 74579 again, then the ubi-usersetup occurred.
Then I tried to format my disk and try a fresh install. The ubi-usersetup still there. And in the end, the installation crashed.

My partition is

/boot ext4
/ Reiserfs
swap is seperate

The screen shot is in attachment

Revision history for this message
David Young (dove-young) wrote :
  • syslog Edit (72.3 KiB, application/octet-stream)

And this is the syslog

Revision history for this message
David Young (dove-young) wrote :

Finally, when I reboot and select 'install ubuntu to a hard disk', I mean do not run live system, then installation complete successfully.

There are some differences in my last installation

1. Filesystem

/boot ext4
/ ext4

2. Language: English, Region: New York.
In previous installs, language: English, Region: Beijing Shi, China

Revision history for this message
Steve Romanow (slestak989) wrote : Re: [Bug 763155] Re: ntfsresize detected bad sectors but chkdsk does not.

I personally think the problem lies in some cached data on the usb
install media. That is the only common thing between reinstalls that
include formattign the hd.

Revision history for this message
Steve Romanow (slestak989) wrote : Invitation to connect on LinkedIn

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Steve

Steve Romanow
Application Developer
Greater Grand Rapids, Michigan Area

Confirm that you know Steve Romanow:
https://www.linkedin.com/e/-epi24d-hbfa3jau-1t/isd/10241136845/FsZ60YNO/?hs=false&tok=19JotCYeAT7BA1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/-epi24d-hbfa3jau-1t/TGJminqCc8NgHwoE70xwJy8CFm5l40HMezvxZaO/goo/763155%40bugs%2Elaunchpad%2Enet/20061/I3406802080_1/?hs=false&tok=0T09n0i_IT7BA1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers