Ubuntu

Gutsy can't resize Vista NTFS

Reported by Martin Olsson on 2007-08-12
10
Affects Status Importance Assigned to Milestone
linux-ntfs (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by Martin Olsson

Bug Description

I booted Gutsy Tribe 4 live CD on a machine which normally runs Vista (at least Vista was on it when I bought it and now I'm looking for a way to install Ubuntu instead). Anyway, I launched the partition editor gparted from "Applications :: System Tools :: Partition Editor". I notice a warning icon next to my Vista partition. I right-click the Vista NTFS partition and a message is displayed saying that some checksum is wrong and that I should boot into Windows and run "chkdsk /f".

I open up Wikipedia article about "ntfsresize" and it says Vista partitions are fully supported since version 1.13.1.1 however, gutsy currently ships with ntfsresize 1.13.1 and I believe this is the problem. The bottom line is:

If you upgrade from 1.13.1 to 1.13.1.1 Gutsy will get full Vista NTFS resize support. This is a small amount of job for a big amount of win.

See the three areas circled in read on the attached screenshot.

Martin Olsson (mnemo) wrote :
Brian Murray (brian-murray) wrote :

ntfsprogs is version 1.13.1.1 in debian so a sync should resolve the issue

Brian Murray (brian-murray) wrote :

Actually Debian doesn't have 1.13.1.1 as far as I can tell.

Martin Olsson (mnemo) wrote :

If Debian doesn't have it, is there some other way to include it into Ubuntu? I really feel this would be a killer feature for Gutsy given that almost all laptops come with Vista and many people might not be ready to delete the Vista partition before they know Ubuntu works and it right for them.

Henrik Nilsen Omma (henrik) wrote :

I agree that it would be good to support this in Gutsy, esp. if a solution exists upstream.

Phillip, can you have a look?

Changed in linux-ntfs:
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

I was able to successfully resize a Windows Vista NTFS partition using gparted version 0.3.3-2ubuntu3 and ntfsprogs version 1.13.1-6 on Gutsy Gibbon.

Martin Olsson (mnemo) wrote :

Brian, is that the same version that I used when I got the error in the screenshot? If I do "ntfsresize -V" I still get 1.13.1, how did you get that other version number?

Shirish Agarwal (shirishag75) wrote :

meemo,
       new to the discussion & just did an aptitude show :-

shirish@Mugglewille:~$ aptitude show ntfsprogs
Package: ntfsprogs
State: not installed
Version: 1.13.1-6
Priority: optional
Section: otherosfs
Maintainer: Ubuntu Core Developers <email address hidden>
Uncompressed Size: 717k
Depends: libc6 (>= 2.5-0ubuntu1), libfuse2 (>= 2.6), libntfs9 (>= 1.13.1), fuse-utils (> 2.5.0)
Description: tools for doing neat things in NTFS partitions from Linux
 The Linux-NTFS project (http://www.linux-ntfs.org/) aims to bring full support for the NTFS filesystem to the
 Linux operating system.

 This is a set of tools targeted for people interested in working with the NTFS support in the Linux kernel and
 using it. The following utilities are included:

 ntfsfix - Fix common filesystem errors and force Windows to check NTFS.

 mkntfs - Format a partition with an NTFS filesystem, optionally bootable.

 ntfsinfo - Show some information about an NTFS partition or one of the files or directories within it.

 ntfslabel - Show, or set, an NTFS partition's volume label.

 ntfsresize - Resize an NTFS partition without losing data.

 ntfsundelete - Recover deleted files from an NTFS partition.

 ntfscluster - Locate the owner of any given sector or cluster on an NTFS partition.

 ntfscat - Concatenate files and print them on the standard output (without mounting the partition).

 ntfsls - List directory contents on an NTFS filesystem (without mounting).

 ntfscp - Overwrite files on an NTFS partition.

 ntfsclone - Efficiently clone an NTFS filesystem or a part of it.

 ntfsmount - Mount an NTFS partition from user-space using libntfs and FUSE.

 ntfsdecrypt - Decrypt NTFS encrypted files.

 ntfscmp - Compare two NTFS volumes and tell the differences.

This tells me its the 1.13.1-6 , another way is https://launchpad.net/ubuntu/+source/linux-ntfs & you'll see
when the updates happened on the web itself.

Shirish Agarwal (shirishag75) wrote :

That said, I'm gonna subscribe to the bug & see what new happens here. This is pretty good news if Brian was able to do what he said he was able to do :)

Timo Jyrinki (timo-jyrinki) wrote :

1.13.1-5 included the Vista patch, so in theory it should work as well as 1.13.1.1.

Martin Olsson (mnemo) wrote :

I tried the chkdsk /f thing again now and that seemed to have worked. I no longer see the nasty error message in the screenshot. I suppose this bug could be closed if the NTFS patch is already in Ubuntu.

Colin Watson (cjwatson) wrote :

As far as I can tell, and as mentioned earlier, the ntfsresize fix mentioned in the Wikipedia article is that which is included in 1.13.1-5. (I can't actually find the 1.13.1.1 release anywhere, and the site hosting the ntfsresize FAQ itself isn't responding, so it's hard to be certain.)

I think the correct action was indeed for you simply to follow the instructions given in the error message, and there doesn't seem to be a real bug here. Thanks for your feedback.

Changed in linux-ntfs:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers