Unable to handle kernel NULL pointer dereference at virtual address 00000002

Bug #530404 reported by Paul Larson
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
High
Eric Miao
Lucid
High
Eric Miao

Bug Description

Can be easily reproduced by just running mplayer on dove

ProblemType: KernelOops
Annotation: Your system might become unstable now and might need to be restarted.
Architecture: armel
Date: Mon Mar 1 18:05:59 2010
DistroRelease: Ubuntu 10.04
Failure: oops
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha armel+dove (20100224.1)
Package: linux-image-2.6.32-201-dove 2.6.32-201.11
ProcVersionSignature: Ubuntu 2.6.32-201.11-hostname
SourcePackage: linux-mvl-dove
Title: Unable to handle kernel NULL pointer dereference at virtual address 00000002
Uname: Linux 2.6.32-201-dove armv7l

Revision history for this message
Paul Larson (pwlars) wrote :
Revision history for this message
Paul Larson (pwlars) wrote :

When I run it, I lose all input devices and the system seems hung, but the led counter keeps rolling

Changed in linux-mvl-dove (Ubuntu):
assignee: nobody → Eric Miao (eric.y.miao)
importance: Undecided → High
Changed in linux-mvl-dove (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
Tobin Davis (gruemaster)
Changed in linux-mvl-dove (Ubuntu Lucid):
status: New → Confirmed
Revision history for this message
Tobin Davis (gruemaster) wrote :

Here is more output from the kernel oops.

Revision history for this message
Tobin Davis (gruemaster) wrote :

Here is the strace output from mplayer. Command was: strace mplayer 2>&1

Revision history for this message
Saeed Bishara (saeed-marvell) wrote :

The bug is a double call to dma_free_writecombine to dma_desc_array buffer. the happens when soc_pcm_open fails on asoc: AC97 <-> pxa2xx-lfe-ac97 No matching rates.
the dma buffer above get freed first time in the same function at
codec_dai_err:
        if (platform->pcm_ops->close)
              platform->pcm_ops->close(substream);
The second time is when snd_pcm_open_substream fails and calls snd_pcm_release_substream.

Revision history for this message
Saeed Bishara (saeed-marvell) wrote :

any idea why playback devices (pxa2xx-surround-ac97) and pxa2xx-lfe-ac97 are open as capture devices?

Revision history for this message
Saeed Bishara (saeed-marvell) wrote :

This patch for the dove kernel can fix this bug.

Paul Larson (pwlars)
tags: added: patch
Revision history for this message
Eric Miao (eric.y.miao) wrote :

I've put a test kernel in http://people.canonical.com/~ycmiao/lp530404/,
seems to be OK. Please test.

Revision history for this message
Tobin Davis (gruemaster) wrote :

Well, this fixes the mplayer system crash issue. Doesn't resolve the audio issues on dove, but at least it no longer hangs.

Tobin Davis (gruemaster)
Changed in linux-mvl-dove (Ubuntu Lucid):
status: Confirmed → Fix Released
Revision history for this message
Tobin Davis (gruemaster) wrote :

Oops. Thought the fix would have been released before beta 1. Unfortunately, the problem still exists, indicating that it hasn't been released yet.

Changed in linux-mvl-dove (Ubuntu Lucid):
status: Fix Released → Confirmed
tags: added: iso-testing
Revision history for this message
Steve Langasek (vorlon) wrote :

Moving the milestone to beta-2. What's the ETA for having this uploaded to the archive?

Changed in linux-mvl-dove (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Revision history for this message
Eric Miao (eric.y.miao) wrote :

Unfortunately, this missed the beta-1. The fix, however, has been pushed, and will be uploaded once the kernel freeze is over.

Revision history for this message
Andy Whitcroft (apw) wrote :

Applied to lucid mvl-dove.

Changed in linux-mvl-dove (Ubuntu Lucid):
status: Confirmed → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

When is the next linux-mvl-dove upload scheduled?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-mvl-dove - 2.6.32-202.14

---------------
linux-mvl-dove (2.6.32-202.14) lucid; urgency=low

  [ Andy Whitcroft ]

  * rules -- allow architecture configurations to be missing

  [ Eric Miao ]

  * [Config]: Make UIO_DOVE_VMETA driver builtin
    - LP: #541921

  [ Upstream Kernel Changes ]

  * sound: skip error handling inside soc_pcm_open
    - LP: #530404
  * DVS: Fixed a potential conflict of defining dvs_enable as global for
    two diffrent baords
    - LP: #537311
  * rt5611_ts: swap touchscreen Y axis
    - LP: #537311
  * dove: fix section mismatch error
    - LP: #537311
 -- Stefan Bader <email address hidden> Fri, 26 Mar 2010 22:53:03 +0100

Changed in linux-mvl-dove (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers