Some python scripts trigger system hang

Bug #505772 reported by Eric Miao on 2010-01-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
Critical
Eric Miao
Lucid
Critical
Eric Miao

Bug Description

System freezes after X is up for a while. Mouse and keyboard are no longer responding. The debug HEX LED stops counting. Keeping activity of the mouse and keyboard seems to postpone the freeze. And this doesn't happen in single user mode. This doesn't happen in Karmic and lucid alpha-1 either.

Eric Miao (eric.y.miao) on 2010-01-11
Changed in linux-mvl-dove (Ubuntu):
assignee: nobody → Eric Miao (eric.y.miao)
importance: Undecided → Critical
milestone: none → lucid-alpha-2
Alexander Sack (asac) on 2010-01-12
Changed in linux-mvl-dove (Ubuntu Lucid):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

changing milestone on request of release team since thats unlikely to be fixed in time for A2

Changed in linux-mvl-dove (Ubuntu Lucid):
milestone: lucid-alpha-2 → lucid-alpha-3
Brad Figg (brad-figg) on 2010-01-13
tags: added: armel
tags: added: iso-testing
Paul Larson (pwlars) wrote :

I stopped gdm from starting, however the system still hung. I was eventually able to narrow it down to bootchart that seems to be triggering the hang.

summary: - system freezes sometimes after X is up for a while
+ bootchart triggers system hang

I tried some more things with this today. I was able to get basic X up and running with just fvwm, xterm, etc. No problems. In a later trial, I preventing python from running anything and was able to get the normal desktop up and running. Looks like some python scripts are triggering this (including pybootchartgui). I tried some simple python scripts to see if I could narrow it down to a simple testcase that would also trigger the problem, but so far I have been unsuccessful. importing 'uno' seems to be another easy example of how to trigger it though.

summary: - bootchart triggers system hang
+ Some python scripts trigger system hang

Hi,

You can rerun pybootchartgui to see if it is simply the pybootchartgui that is eating all your cpu.

/usr/bin/pybootchartgui /var/log/bootchart/$your_most_recent.tgz

Best
Anders

Paul Larson (pwlars) wrote :

Retried with the latest python build from today (2.6.4-0ubuntu3) and it still hangs for me.

Paul Larson (pwlars) wrote :

I also see the hang when running with python2.5

This is likely caused by the VFP+Thumb2 issues we're having on dove versus a specific bug in Python. I'm not going to mark this as a dupe however since we may be able to work around this specific crash to go from unusable boards to at least boot-able boards

Andy Whitcroft (apw) wrote :

It is rumoured that the latest 2.6.32-200 kernel update may fix this. Once that is in the archive perhaps you could test and confirm/deny.

On 22.01.2010 21:02, Paul Larson wrote:
> Retried with the latest python build from today (2.6.4-0ubuntu3) and it
> still hangs for me.

the latest python2.6 at this time was 2.6.4-4ubuntu1. you did use an out-of-date
mirror.

Paul Larson (pwlars) wrote :

Forgot to update. With the latest python and removing the .pyc files, I was able to run pybootchartgui without seeing the hang. importing uno still causes the hang, but this could be related to other known issues with openoffice. Closing this since it seems to have been resolved with the updated python.

Changed in linux-mvl-dove (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers