CONFIG_HIBERNATION needs to be set for dove kernels

Bug #502983 reported by Michael Casadevall on 2010-01-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
Undecided
Eric Miao

Bug Description

The dove kernel needs CONFIG_HIBERNATION to enable hibernation for this SoC.

Can this please enabled with the next kernel upload?

Alexander Sack (asac) wrote :

assigning to eric. are there reasons this is not enabled? otherwise, please consider this.

tags: added: armel
Changed in linux-mvl-dove (Ubuntu):
assignee: nobody → Eric Miao (eric.y.miao)
status: New → Confirmed
Paul Larson (pwlars) wrote :

There was actually some recent discussion about this on IRC, I don't recall with whom, that this might be intentional. Speculation was that if suspend produces such a low power state (especially on arm), then full hibernation would be moot. If it *is* intentionally not supported on ARM though, I would like to see that clarified.

On Dove it should be supported.

 -----Original Message-----
 From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
 Paul Larson
 Sent: Tuesday, January 05, 2010 1:32 AM
 To: Maen Suleiman
 Subject: [Bug 502983] Re: CONFIG_HIBERNATION needs to be set for dove
 kernels

 There was actually some recent discussion about this on IRC, I don't
 recall with whom, that this might be intentional. Speculation was that
 if suspend produces such a low power state (especially on arm), then
 full hibernation would be moot. If it *is* intentionally not supported
 on ARM though, I would like to see that clarified.

 --
 CONFIG_HIBERNATION needs to be set for dove kernels
 https://bugs.launchpad.net/bugs/502983
 You received this bug notification because you are subscribed to linux-
 mvl-dove in ubuntu.

 Status in "linux-mvl-dove" package in Ubuntu: Confirmed

 Bug description:
 The dove kernel needs CONFIG_HIBERNATION to enable hibernation for this
 SoC.

 Can this please enabled with the next kernel upload?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-mvl-dove - 2.6.32-200.7

---------------
linux-mvl-dove (2.6.32-200.7) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] fix SECURITY and LSM configuration -- mvl-dove
  * (buildenv) Add a distclean target to remove temporary files -- mvl-dove
  * update remaining references from karmic to lucid -- mvl-dove
  * undo slamming architecture to armel -- mvl-dove
  * restore linux-image prefix -- mvl-dove
  * include modules.builtin in the binary debs -- mvl-dove
  * resync kernelconfig with lucid -- mvl-dove
  * config-check -- add a configuration enforcer -- mvl-dove
  * config-check -- add a unit-test suite to the checker -- mvl-dove
  * config-check -- ensure the checks get run at build time -- mvl-dove
  * config-check -- check the processed config during updateconfigs --
    mvl-dove
  * enforcer -- resync configuration with master -- mvl-dove
  * clean up whitespace differences -- mvl-dove
  * copy over minor modification -- mvl-dove
  * make doc package completely optional -- mvl-dove
  * install the full changelog with the binary package -- mvl-dove
  * make source package completely optional -- mvl-dove
  * make linux-libc-dev completly optional -- mvl-dove
  * convert package disable to a deps list -- mvl-dove
  * move back to common headers in arch mode -- mvl-dove
  * convert binary package disable to a deps list -- mvl-dove
  * disable linux-libc-dev -- mvl-dove
  * add configuration option for a full source build tree -- mvl-dove
  * getabis -- cleanup and parameterise repository list -- mvl-dove
  * kernelconfig -- fix minor whitespace damage -- mvl-dove
  * getabis -- move configuration to etc/getabis -- mvl-dove
  * kernelconfig -- move configuration to etc -- mvl-dove
  * set the current branch name -- mvl-dove
  * remove common files -- mvl-dove
  * remove generated files
  * insert-changes -- correctly link to debian/rules in DROOT

  [ Bryan Wu ]

  * Add 3 missing files to prerm remove file list -- mvl-dove
    - LP: #345623, #415832

  [ Eric Miao ]

  * [Config]: Enable devtmpfs for mvl-dove kernel
    - LP: #512321
  * SAUCE: Enable CPUFREQ by default
    - LP: #513254
  * [Config]: Turn on CONFIG_HIBERNATE
    - LP: #502983
  * [Config]: Turn on CONFIG_ARM_THUMBEE
  * [Config]: Disable V6 debugger mode and use V7

  [ Tim Gardner ]

  * [Config] DH_COMPAT=5 -- mvl-dove

  [ Upstream Kernel Changes ]

  * ARM VFP supprot code bug: If any of the status flags are set, update
    the FPSCR
  * Marvell Dove VFP errata
 -- Andy Whitcroft <email address hidden> Thu, 04 Feb 2010 20:49:42 +0000

Changed in linux-mvl-dove (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers