Lots of errors during install on dove

Bug #451553 reported by Paul Larson on 2009-10-14
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
Low
Eric Miao
Karmic
Low
Brad Figg
Lucid
Low
Eric Miao

Bug Description

I got lots of these errors during installation of the daily image from 10/14/2009, and confirmed with some others on irc that they had seen similar things during install. I haven't had a chance to pick through them all yet, but wanted to go ahead and capture the debug info before rebooting. The install did seem to complete ok, but took a long while.

ProblemType: Bug
Architecture: armel
Date: Wed Oct 14 14:07:14 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha armel+dove (20091014)
Package: linux-image-2.6.31-206-dove 2.6.31-206.14
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-206.14-dove
SourcePackage: linux-mvl-dove
Uname: Linux 2.6.31-206-dove armv7l

Paul Larson (pwlars) wrote :

Architecture: armel
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha armel+dove (20091014)
Package: kernel (not installed)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-206.14-dove
Uname: Linux 2.6.31-206-dove armv7l
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected
Paul Larson (pwlars) wrote :

Linux version 2.6.31-206-dove (buildd@jackfruit) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu6) ) #14-Ubuntu Tue Oct 6 20:45:45 UTC 2009 (Ubuntu 2.6.31-206.14-dove)

Loïc Minier (lool) wrote :

Anyone reproducing this issue?

Is this happening on all installs?

Loïc Minier (lool) wrote :

@Paul: could you please provide some dd/hdparm/bonnie++ benchmarks of USB and SATA on dove? Thanks!

Paul Larson (pwlars) wrote :

USB
Version 1.03c ------Sequential Output------ --Sequential Input- --Random-
                    -Per Chr- --Block-- -Rewrite- -Per Chr- --Block-- --Seeks--
Machine Size K/sec %CP K/sec %CP K/sec %CP K/sec %CP K/sec %CP /sec %CP
dove 1G 2809 54 5246 2 2879 2 3630 71 18376 8 1827 10
                    ------Sequential Create------ --------Random Create--------
                    -Create-- --Read--- -Delete-- -Create-- --Read--- -Delete--
              files /sec %CP /sec %CP /sec %CP /sec %CP /sec %CP /sec %CP
                 16 9962 100 +++++ +++ 17556 100 10120 99 +++++ +++ 7265 43
dove,1G,2809,54,5246,2,2879,2,3630,71,18376,8,1827.4,10,16,9962,100,+++++,+++,17556,100,10120,99,+++++,+++,7265,43

SATA
Version 1.03c ------Sequential Output------ --Sequential Input- --Random-
                    -Per Chr- --Block-- -Rewrite- -Per Chr- --Block-- --Seeks--
Machine Size K/sec %CP K/sec %CP K/sec %CP K/sec %CP K/sec %CP /sec %CP
dove 1G 5079 98 98070 61 36575 40 5021 99 130236 67 588.2 3
                    ------Sequential Create------ --------Random Create--------
                    -Create-- --Read--- -Delete-- -Create-- --Read--- -Delete--
              files /sec %CP /sec %CP /sec %CP /sec %CP /sec %CP /sec %CP
                 16 8930 94 +++++ +++ 17283 100 10401 99 +++++ +++ 15991 93
dove,1G,5079,98,98070,61,36575,40,5021,99,130236,67,588.2,3,16,8930,94,+++++,+++,17283,100,10401,99,+++++,+++,15991,93

In both cases, I passed -s1024 -r512 to bonnie++ to limit the ram to 512M and the size to 1024M (due to constraints with the size of the usb stick I used, and wanting to keep consistent)

Li Li (lli5) wrote :

Just FYI.

Well, I happened to install karmic armel dove beta image successfully (from SanDisk 4GB SD card based u-disk to 80GB SATA), though this install process failed for several times (mainly during partition and ext4 formatting process).

But I haven't try the installed rootfs yet because I failed to boot Y1 board with Canonical uboot (https://bugs.launchpad.net/adana/+bug/452697) and didn't know how to launch Canonical kernel (vmlinuz) from Marvell uboot.

I tar/gzip the rootfs from SATA to my host PC as NFS rootfs, and boot Canonical kernel (uImage) from this NFS rootfs. It successfully boot to init process but did not launch any desktop (no gdm process exists).

PS:
USB disk is tricky. I tried many u-disk but all of them failed to pass checksum or failed to be recogized correctly by u-boot. Finally I use USB SD card reader. So I suggest you double check the contents in u-disk before installation.

Li Li (lli5) wrote :

[quick update]

Tried to boot Canonical vmlinuz (mkimage to uImage) from Marvell uboot and installed Karmic Beta in SATA, the whole Ubuntu desktop works.

But marvell components (x driver, ipp codec, gstreamer, etc.) seems not integrated yet. Please let me know if there's any problem integrating them.

Thanks,
Lea

Loïc Minier (lool) wrote :

Lea, the X driver and opengl drivers etc. are pending licensing fixes; can you please look into them?

Loïc Minier (lool) wrote :

Confirmed by Maen in another bug.

Changed in linux-mvl-dove (Ubuntu):
importance: Undecided → Medium
milestone: none → karmic-updates
status: New → Confirmed
Paul Larson (pwlars) wrote :

separating this into separate bugs, one for the cpu_idle bug mentioned in bug #458533 and also seen in the kern.log here, and this one which includes the double bit errors and page allocation errors that I'm only seeing when booting from USB and installing.

Loïc Minier (lool) on 2009-10-29
Changed in linux-mvl-dove (Ubuntu Karmic):
assignee: nobody → Brad Figg (brad-figg)
tags: added: iso-testing
Paul Larson (pwlars) wrote :

most of these errors do not appear to be present in lucid anymore, however, the double-bit errors remain

Changed in linux-mvl-dove (Ubuntu Lucid):
assignee: Brad Figg (brad-figg) → Eric Miao (eric.y.miao)
Alexander Sack (asac) wrote :

untargetting lucid ... lets track this as normal bug.

Changed in linux-mvl-dove (Ubuntu Lucid):
status: Confirmed → Invalid
status: Invalid → Won't Fix
Changed in linux-mvl-dove (Ubuntu):
status: Invalid → Confirmed
milestone: karmic-updates → none
Paul Larson (pwlars) wrote :

update: I'm still seeing the double bit errors on the Lucid Alpha 3 candidate image with X0

tags: added: karmic
Paul Larson (pwlars) wrote :

It was brought up in a meeting on IRC that this is likely related to nand contents, and reinitializing the nand may clear this up. The double-bit errors seem to be more of a warning rather than something that has any impact.

Changed in linux-mvl-dove (Ubuntu):
importance: Medium → Low
Changed in linux-mvl-dove (Ubuntu Karmic):
importance: Medium → Low
Changed in linux-mvl-dove (Ubuntu Lucid):
importance: Medium → Low
Paul Larson (pwlars) wrote :

Ok, clearing the nand resolves this. Marking invalid

Changed in linux-mvl-dove (Ubuntu Karmic):
status: Confirmed → Invalid
milestone: karmic-updates → none
Changed in linux-mvl-dove (Ubuntu Lucid):
milestone: karmic-updates → none
Changed in linux-mvl-dove (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers