Video output with dove broken with 2.6.31-203

Bug #423675 reported by Michael Casadevall on 2009-09-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-mvl-dove (Ubuntu)
Critical
Brad Figg
Karmic
Critical
Brad Figg

Bug Description

The dove kernel's video output has broken with the most recent kernel uploads, causing my monitor to go into "Unable to display video mode" when using a newer kernel. This change seems to be related to "DOVEFB_DISPLAY_MODE=y" - which has not been set with previous Dove kernels which did have working video output.

The following command line has been used for video output: console=ttyS0,115200 console=tty0 mem=512M video=dovefb:lcd0:1280x768-24@60,lcd1:1024x768-16@60 clcd.lcd0_enable=0 clcd.lcd1_enable=1

Changed in linux-mvl-dove (Ubuntu):
importance: Undecided → Critical
milestone: none → karmic-alpha-6
Oliver Grawert (ogra) wrote :

confirming, i use the board as shipped with no changes (original uboot, pulling uImage via tftp, no changes to uboot options) my monitor goes into a way to hig video mode with this kernel ... the monitor is an about 3 years old LCD which can do up to 1280x1024 and should also properly report EDID data.

it used to work properly with all former kernel builds

Changed in linux-mvl-dove (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

oh, i see this bug is against 203.7, i actually use 203.8 atm

ogra: the change that seems to have broken video out was 203.7; I'm currently building a test kernel to see if that's the case.

summary: - Video output with dove broken with 2.6.31-203.7
+ Video output with dove broken with 2.6.31-203
Brad Figg (brad-figg) on 2009-09-04
Changed in linux-mvl-dove (Ubuntu Karmic):
assignee: nobody → Brad Figg (brad-figg)
status: Confirmed → In Progress
Brad Figg (brad-figg) on 2009-09-04
Changed in linux-mvl-dove (Ubuntu Karmic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-mvl-dove - 2.6.31-203.9

---------------
linux-mvl-dove (2.6.31-203.9) karmic; urgency=low

  [ Brad Figg ]

  * [Config] Dove Configuration: set lcd external clock to a fixed speed,
    1000MHz.
    - LP: #423675

 -- Tim Gardner <email address hidden> Mon, 07 Sep 2009 23:39:31 +0000

Changed in linux-mvl-dove (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: iso-testing

Please try to set on/off of DOVEFB_SINGLE_DISPLAY_ACCURATE_PCLK in kernel configuration to see if it helps. Thanks.

Best regards,
Peter Liao (Wen-Liang Liao)
Marvell Taiwan Ltd. Hsin-Chu Office, OS/Driver Team of Compiler Development Department
Tel: 886-3-516-5098 ext.6195337
Fax: 886-3-573-9907

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ubuntu QA Website
Sent: Wednesday, November 18, 2009 3:40 AM
To: Peter Liao
Subject: [Bug 423675] Re: Video output with dove broken with 2.6.31-203

** Tags added: iso-testing

--
Video output with dove broken with 2.6.31-203
https://bugs.launchpad.net/bugs/423675
You received this bug notification because you are subscribed to linux-
mvl-dove in ubuntu.

Status in "linux-mvl-dove" package in Ubuntu: Fix Released
Status in "linux-mvl-dove" source package in Karmic: Fix Released

Bug description:
The dove kernel's video output has broken with the most recent kernel uploads, causing my monitor to go into "Unable to display video mode" when using a newer kernel. This change seems to be related to "DOVEFB_DISPLAY_MODE=y" - which has not been set with previous Dove kernels which did have working video output.

The following command line has been used for video output: console=ttyS0,115200 console=tty0 mem=512M video=dovefb:lcd0:1280x768-24@60,lcd1:1024x768-16@60 clcd.lcd0_enable=0 clcd.lcd1_enable=1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers