PMU counters for Cortex-A78 not working correctly

Bug #2060063 reported by Umair Hashim
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-mtk (Ubuntu)

Bug Description

I am seeing an issue with the Cortex-A78 PMU counters on the Genio1200-evk.

Linux perf reports <not counted> for Cortex-A78 PMUs when I run the following commands:

taskset -c 7 perf stat -e cycles sleep 5
taskset -c 7 perf stat -r r11 sleep 5

Infact none of the standard PMU events on the Cortex-A78 work when using the raw PMU event register values such as:

-e r08
-e r11
-e r13
...... etc.

I also see this behaviour when an application using libpfm4 OR perf_event_open() API is pinned to one of the 4xCortex-A78 on the board.

When I run the above perf commands and applications pinned to the Cortex-A55 cores the PMU events get reported correctly.

Please let me know if you need more details.

Kind regards,

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.