hdaps no longer reports accelerometer values

Bug #95494 reported by lcampagn on 2007-03-24
16
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by James Ward

Bug Description

Binary package hint: linux-image-generic

After upgrading to feisty from edgy, hdaps no longer reports accelerometer values. Inserting the module looks ok:
[ 24.068000] hdaps: inverting axis readings.
[ 24.076000] hdaps: LENOVO ThinkPad X60 detected.
[ 24.088000] input: hdaps as /class/input/input3
[ 24.108000] hdaps: driver successfully loaded.

However the accelerometer values are stuck at (0,-3):
$ cat /sys/devices/platform/hdaps/position
(0,-3)

ProblemType: Bug
Architecture: i386
Date: Sat Mar 24 10:37:25 2007
DistroRelease: Ubuntu 7.04
Uname: Linux underwood 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

professordes (d-a-johnston) wrote :

hdaps is reporting nothing back on 2.6.20-13 with an IBM X40 either.

hdaps-pivot gives:

(x,y) position: (0,0)
keyboard=0 mouse=0

whatever the orientation. Similarly,

cat /sys/devices/platform/hdaps/position

always returns

(128,1)

and no movement either in hdaps-gl :(

The laptop was upgraded from edgy where hdaps was working.

James Ward (jamesward) wrote :

hdaps is not working for me either on feisty. The module loads fine, but I do not see any movement being tracked.

Håvard H. Garnes (hhgarnes) wrote :

I have the same problem on my T60p. Is anyone looking into this?

Linux tp 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

professordes (d-a-johnston) wrote :

Still not a peep from hdaps with the release Feisty kernel on my X40 :(

There is a bug report open at
http://sourceforge.net/tracker/?atid=740637&group_id=138242&func=browse, but
no response to it so far.

On 4/24/07, professordes <email address hidden> wrote:
>
> Still not a peep from hdaps with the release Feisty kernel on my X40 :(
>

Håvard H. Garnes (hhgarnes) wrote :

install tp_smapi with the HDAPS=1 parameter, shown here.

http://www.thinkwiki.org/wiki/Tp_smapi

It works for me. I'd rather see it included in ubuntu, though, because it has to be recompiled for every kernel upgrade.

professordes (d-a-johnston) wrote :

Hi Havard - thanks for that, it does indeed work.

On Wed, 30 May 2007, Håvard H. Garnes wrote:

> install tp_smapi with the HDAPS=1 parameter, shown here.
>
> http://www.thinkwiki.org/wiki/Tp_smapi
>
> It works for me. I'd rather see it included in ubuntu, though, because
> it has to be recompiled for every kernel upgrade.
>
> --
> hdaps no longer reports accelerometer values
> https://bugs.launchpad.net/bugs/95494
> You received this bug notification because you are a direct subscriber
> of the bug.
>

==================================================================
Prof. Des Johnston Phone (+44) (131) 451 3255
Department of Mathematics Fax. (+44) (131) 451 3249
School of Mathematical and
Computer Sciences
Colin Maclaurin Building Email: <email address hidden>
Heriot-Watt University
Riccarton, Edinburgh EH14 4AS Office: CM/S04
United Kingdom
==================================================================

lcampagn (luke-campagnola) wrote :

Installing tp_smapi worked for me, thanks.

On 5/30/07, Håvard H. Garnes <email address hidden> wrote:
>
> install tp_smapi with the HDAPS=1 parameter, shown here.
>
> http://www.thinkwiki.org/wiki/Tp_smapi
>
> It works for me. I'd rather see it included in ubuntu, though, because
> it has to be recompiled for every kernel upgrade.
>
> --
> hdaps no longer reports accelerometer values
> https://bugs.launchpad.net/bugs/95494
> You received this bug notification because you are a direct subscriber
> of the bug.
>

lcampagn (luke-campagnola) wrote :

Can we get this bug changed to a wishlist item to have tp_smapi included in ubuntu? If not, we should just close the bug.

Chris Jones (cmsj) wrote :

I see this on an X40

Changed in linux-meta:
status: New → Confirmed
Igor (igor47) wrote :

Ok, what is the deal? I don't really want to be polluting my Ubuntu install with self-compiled packages, but there haven't even been any comments, much less action, from any developers/maintainers on this bug for 5 months. This is a bug which could potentially lead to data loss!

Why doesn't hdaps module report accelerometer values even though it detects the hardware?

Do the thinkpad-base and thinkpad-source packages provide tp_smapi? If so, is it possible to get install instructions for those packages that make sense?

gagarine (gagarine) wrote :

The kernel module NOT loaded by default so:
sudo echo "hdaps" >> /etc/modules

After that the kernel module is loaded properly:
gagarine@area42:~$ dmesg | grep hdaps
[ 30.226769] hdaps: inverting axis readings.
[ 30.226775] hdaps: LENOVO ThinkPad T60 detected.
[ 30.226887] hdaps: initial latch check good (0x01).
[ 30.881008] hdaps: device successfully initialized.
[ 30.881535] input: hdaps as /class/input/input3
[ 30.881599] hdaps: driver successfully loaded.
gagarine@area42:~$

I do 2-3 restarts before hdaps-gl work (i work but the "computer" don't move)... I don't know why

Shem Multinymous (multinymous) wrote :

The hdaps driver in mainline kernel doesn't follow the correct protocol when initializing and reading the accelerometer interface of the embedded controller hardware. It sometimes happen to work when the port probing timing is lucky, but this is very unreliable (especially on recent ThinkPad models). The modified hdaps in tp_smapi fixes this.

Václav Šmilauer (eudoxos) wrote :

Accelerometer values are reported if you load the hdaps_ec module instead of hdaps (on hardy), as said on the thinkwiki page.

Changed in linux-meta:
status: Confirmed → Fix Released
Václav Šmilauer (eudoxos) wrote :

(See a patch for hdaps-gl that suggest the alternative module to the user: https://lists.ubuntu.com/archives/ubuntu-motu/2008-June/004056.html)

Chris Jones (cmsj) wrote :

This being the case, what is the point of shipping hdaps.ko?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers