package linux-tools-common (not installed) failed to install/upgrade: trying to overwrite '/usr/bin/perf', which is also in package linux-base 3.3

Bug #931353 reported by Shahar Or on 2012-02-13
170
This bug affects 24 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Precise
Undecided
Unassigned
Quantal
High
Andy Whitcroft
linux-base (Ubuntu)
High
Tim Gardner
Precise
Undecided
Tim Gardner
Quantal
High
Tim Gardner
linux-meta (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Dear Ones,

Seems like straightforward same file existing in two different packages conflict. But I haven't read the APT policy.

Thanks and Blessings,
Shahar

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: linux-tools-common (not installed)
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
AptOrdering:
 linux-tools-common: Install
 linux-tools-common: Configure
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: shahar 2366 F.... pulseaudio
 /dev/snd/controlC0: shahar 2366 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe024000 irq 16'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,1458a102,00100004'
   Controls : 38
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfdefc000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card2.Amixer.info:
 Card hw:2 'Camera'/'Vimicro Corp. Venus USB2.0 Camera at usb-0000:00:12.2-5, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0ac8:3420'
   Controls : 2
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 48
   Mono: Capture 47 [98%] [20.00dB] [on]
Date: Mon Feb 13 12:15:18 2012
DpkgTerminalLog:
 Unpacking linux-tools-common (from .../linux-tools-common_3.0.0-16.28_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/linux-tools-common_3.0.0-16.28_all.deb (--unpack):
  trying to overwrite '/usr/bin/perf', which is also in package linux-base 3.3
DuplicateSignature:
 Unpacking linux-tools-common (from .../linux-tools-common_3.0.0-16.28_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/linux-tools-common_3.0.0-16.28_all.deb (--unpack):
  trying to overwrite '/usr/bin/perf', which is also in package linux-base 3.3
ErrorMessage: trying to overwrite '/usr/bin/perf', which is also in package linux-base 3.3
HibernationDevice: RESUME=UUID=f2bd5594-8447-422c-a345-492ede4de1d9
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
IwConfig:
 lo no wireless extensions.

 eth4 no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. GA-880GMA-USB3
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-15-generic root=UUID=57641e34-8b71-4e2e-9324-ff40ca1bc82a ro quiet splash vt.handoff=7
PulseSinks: Error: command ['pacmd', 'list-sinks'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
PulseSources: Error: command ['pacmd', 'list-sources'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 1.99-12ubuntu5
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Title: package linux-tools-common (not installed) failed to install/upgrade: trying to overwrite '/usr/bin/perf', which is also in package linux-base 3.3
UpgradeStatus: Upgraded to oneiric on 2011-10-16 (120 days ago)
WifiSyslog:

dmi.bios.date: 10/20/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F3
dmi.board.name: GA-880GMA-USB3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF3:bd10/20/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-880GMA-USB3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-880GMA-USB3:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-880GMA-USB3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Related branches

Shahar Or (mightyiam) wrote :
tags: removed: need-duplicate-check
Brad Figg (brad-figg) on 2012-02-13
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

You may need to run the following:

sudo apt-get install -f
sudo apt-get clean
sudo apt-get update

Then re-install the package.

If that does not resolve your issue, please mark the bug as "Confirmed"

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

Confirmed on Precise with the following versions:
$ apt-cache policy linux-base linux-tools-common
linux-base:
  Installed: 3.4
  Candidate: 3.4
  Version table:
 *** 3.4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status
linux-tools-common:
  Installed: (none)
  Candidate: 3.2.0-15.24
  Version table:
     3.2.0-15.24 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

Changed in linux (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
Changed in linux-base (Ubuntu):
status: New → Triaged
importance: Undecided → High
Andy Whitcroft (apw) wrote :

Ok linux-base is debian sourced package which is designed to mesh with their kernel packages. Currently this conflicts with the Ubuntu kernel package. It makes no sense to have linux-base installed with the current ubuntu kernel packages as they contain the same functionality.

Will have a look at avoiding this collission in future.

Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Andy Whitcroft (apw)

On 13 March 2012 15:17, Andy Whitcroft <email address hidden> wrote:
> Ok linux-base is debian sourced package which is designed to mesh with
> their kernel packages.  Currently this conflicts with the Ubuntu kernel
> package.  It makes no sense to have linux-base installed with the
> current ubuntu kernel packages as they contain the same functionality.
>
> Will have a look at avoiding this collission in future.

Great! Thank you, Andy!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-meta (Ubuntu):
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact - linux-base conflicts with Ubuntu kernel tools packages
Patch Description: delete the reference to /usr/bin/perf

Remove /usr/bin/perf from this package as it conflicts with the Ubuntu kernel tools package linux-tools-common (which provides the real /usr/bin/perf). I can think of no reason why this should cause a problem. /usr/bin/perf is kernel ABI version specific, therefore it can only be provided by the correct version of linux-tools-$version-$abi.

Changed in linux-base (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Changed in linux (Ubuntu):
status: In Progress → Won't Fix
Changed in linux-meta (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Precise):
status: New → Won't Fix
Changed in linux-base (Ubuntu Precise):
status: New → In Progress
Changed in linux-meta (Ubuntu Precise):
status: New → Invalid
Changed in linux-base (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
Changed in linux-base (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-1

Hello Shahar, or anyone else affected,

Accepted linux-base into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-base (Ubuntu Precise):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) on 2012-05-23
Changed in linux-base (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-base - 3.5ubuntu1

---------------
linux-base (3.5ubuntu1) quantal; urgency=low

  * Added quilt patch support
  * Remove /usr/bin/perf from this package as it conflicts with
    the Ubuntu kernel tools package linux-tools-common (which
    provides the real /usr/bin/perf). I can think of no reason why
    this should cause a problem. /usr/bin/perf is kernel ABI version
    specific, therefore it can only be provided by the correct
    version of linux-tools-$version-$abi.
    debian/patches/0001-remove-bin-perf.patch
    -LP: #931353
 -- Tim Gardner <email address hidden> Wed, 23 May 2012 13:35:38 -0600

Changed in linux-base (Ubuntu Quantal):
status: Fix Committed → Fix Released
Stéphane Graber (stgraber) wrote :

Confirmed that the two debs are now co-installable.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-base - 3.4ubuntu2

---------------
linux-base (3.4ubuntu2) precise-proposed; urgency=low

  * Forgot version diff in the 3.4ubuntu1 upload.

linux-base (3.4ubuntu1) precise-proposed; urgency=low

  * Remove /usr/bin/perf from this package as it conflicts with
    the Ubuntu kernel tools package linux-tools-common (which
    provides the real /usr/bin/perf). I can think of no reason why
    this should cause a problem. /usr/bin/perf is kernel ABI version
    specific, therefore it can only be provided by the correct
    version of linux-tools-$version-$abi.
    -LP: #931353
 -- Tim Gardner <email address hidden> Fri, 04 May 2012 07:08:15 -0600

Changed in linux-base (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.