Kernel 3.0 (11.10 default kernel) won't boot unless acpi=off, worked fine with the default kernels of the 3 previous releases

Bug #883438 reported by Alexander Winizki on 2011-10-29
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Recently I upgraded from 11.04 to 11.10. Now the computer boots only with the default kernel and acpi=off or with the 2.6.28 kernel left from 11.04 with default options. If I try to boot with kernel 3.0, the computer freezes one or two seconds after I hit Enter in the Grub menu. The caps lock control LED on the keyboard doesn't respond to the caps lock button. The machine also doesn't react to Ctrl+Alt+Delete. This issue seems to have no relation to upgrading since booting from the LUbuntu 11.10 Desktop CD leads to the same results while it has always worked with the previous releases.

Additional Information:
alex@james:~$ lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

alex@james:~$ apt-cache policy linux-generic
linux-generic:
  Installiert: 3.0.0.12.14
  Kandidat: 3.0.0.12.14
  Versionstabelle:
 *** 3.0.0.12.14 0
        500 http://de.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
alex@james:~$

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: acpi (not installed)
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sat Oct 29 13:00:44 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: acpi
UpgradeStatus: No upgrade log present (probably fresh install)

Alexander Winizki (awinizki) wrote :

Machine: Desktop computer
Mainboard: Intel D865GBF
BIOS Version: latest available (***.P25)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-meta (Ubuntu):
status: New → Confirmed
Suman Guha (suman-iitk2003) wrote :

I have the exactly same problem. But in my case even with acpi=off it won't boot. I am using the kernel from previous distro to boot.

bartman2589 (bartman2589) wrote :

I'm posting this here because I'm not sure if subscribers to this bug report are also automatically subscribed to the duplicate bug #883441, if so please feel free to delete this post in favor of the one I made on #883441.

I had this same problem, after doing some digging around I found a workaround that allows booting the 3.0 series kernel without having to disable ACPI or Hyperthreading. The workaround involves adding a kernel parameter to your GRUB configuration:

   processor.nocst=1

This forces the kernel to use an older method of determining the processors 'c-state' (don't ask me what exactly that is, I have absolutely no idea, all I know is adding this to my GRUB configuration allowed me to finally boot without disabling ACPI or Hyperthreading on my D865GLC board (apparently this bug is prevalent on Intel D865GBF boards, the GLC is basically a mini-ATX version of the GBF and even uses the same BIOS)).

Rough System specs:
CPU: 2.8ghz Pentium 4 w/hyperthreading
Board: Intel D865GLC (from a Gateway computer, but flashed with newest Intel BIOS), board revision unknown
RAM: 2x 1Gb DDR & 2x 512Mb DDR
Video: nVidia 7600GS 8X AGP w/512Mb Video Memory
Linux Distro: Kubuntu 11.10 32 bit fully updated including backports

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers