Thinkpad Z60t wireless hotkey won't work

Bug #74908 reported by Christian Elkjaer on 2006-12-08
8
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Ubuntu Laptop Team
hotkey-setup (Ubuntu)
Undecided
Unassigned
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hotkey-setup

Using feisty 7.04 (Herd 1) I found that the wireless hotkey for turning on and off the wireless network card won't work on my Thinkpad T41.

Simply, nothing happens when pushing the button. No error messages appear in the syslog.

All other hotkeys seem to work flawless. It is worth noticing that the wireless hotkey worked in previous ubuntu releases.

hotkey-setup version: 0.1-17ubuntu3

Sebastian Heinlein (glatzor) wrote :

I only own a T60, but the kill switch seems to be hardware based.

Adi Roiban (adiroiban) wrote :

I think the best way to address this problem is by solving Bug #24680

Christian Elkjaer (c.elkjaer) wrote :

I can no longer reproduce this bug running latest feisty. Please make a quick test and report back so that we may close this bug report.

Christian Elkjaer (c.elkjaer) wrote :

Closing this bug report since a fix is released for a duplicate bug report. Also, a test on my thinkpad today revealed that the issue seems solved.

Changed in linux-meta:
status: Unconfirmed → Fix Released
Guillaume Duveau (guix) wrote :

This bug should be reopened, title changed to "Thinkpad Z60t...", affected to acpi-support and assigned to Ubuntu Laptop Team.
No key code is sent by Fn+5 on my Z60t with Feisty, 2.6.20-16-generic.

It occurs in gnome shortcuts, in xev, and also with this method :
sudo /etc/init.d/hotkey-setup stop
sudo showkey -u | tee -a hotkey-log.txt

Some info on my hardware :

sudo dmidecode -s system-manufacturer
IBM

sudo dmidecode -s system-product-name
2511EJG

sudo dmidecode -s system-version
ThinkPad Z60t

cd /var/lib/acpi-support/ ; grep . -r *-*
bios-version:77ET64WW (1.24 )
system-manufacturer:IBM
system-product-name:2511EJG
system-version:ThinkPad Z60t

Changed in hotkey-setup:
assignee: nobody → ubuntu-laptop
Guillaume Duveau (guix) wrote :

Although the bug #24680 has had a fix release, this one is still open because on Z60t 2511-EJG the Fn+F5 keys send nothing.

Changed in linux-meta:
status: Fix Released → Unconfirmed
Samuel Schluep (schluep) wrote :

I have a similar problem on a Thinkpad T42. Since upgrading to feisty Fn+F5 just doesn't do anything (installed version of acpi-support 0.95). The wireless hotkey worked in in the edgy release.

Benjamin Kraus (ben-benkraus) wrote :

I have a Thinkpad Z60m, and when using acpi_listen I can see an event generated when I press Fn+F5. However, there is a problem in another file that is preventing the toggle switch from working, see bug #120955 for details.

Adam Niedling (krychek) wrote :

Is this still an issue?

Would you like to update the testing page? It looks broken.
https://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadZ60t

RJ Clay (rjclay) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in linux-meta:
status: New → Incomplete
Daniel T Chen (crimsun) wrote :

Rejecting metapackage task, as it's unaffected.

Changed in linux-meta:
status: Incomplete → Invalid
Changed in hotkey-setup:
status: New → Incomplete
RJ Clay (rjclay) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in hotkey-setup:
status: Incomplete → Invalid
RJ Clay (rjclay) on 2008-09-27
Changed in hal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers