Kernel meta packages are built for wrong architectures.

Bug #720139 reported by Tim Gardner on 2011-02-16
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Tim Gardner
Lucid
Undecided
Tim Gardner
Maverick
Undecided
Tim Gardner
Natty
Undecided
Tim Gardner

Bug Description

Some kernel meta packages are built for architectures for which the dependent packages do not exist. For example, linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-server is only built for amd64, yet the associated meta package linux-backports-modules-wireless-lucid-server is built for amd64 _and_ i386.

Tim Gardner (timg-tpi) on 2011-02-16
Changed in linux-meta (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux-meta (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux-meta (Ubuntu Maverick):
status: New → In Progress
assignee: nobody → Tim Gardner (timg-tpi)
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: extraneous meta packages make CDROM/DVD creation difficult because of uninstallable packages.

 Feb 15 15:01:22 <cjwatson> $ rmadison -s lucid-updates linux-backports-modules-wireless-lucid-server
 Feb 15 15:01:22 <cjwatson> linux-backports-modules-wireless-lucid-server | 2.6.32.28.32 | lucid-updates | amd64, i386
 Feb 15 15:01:29 <cjwatson> $ rmadison -s lucid-updates linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-server
 Feb 15 15:01:32 <cjwatson> linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-server | 2.6.32-28.27 | lucid-updates | amd64
 Feb 15 15:01:57 <cjwatson> there we see a difference, the underlying -server package is only built for amd64
 Feb 15 15:02:13 <cjwatson> similar situation for generic-pae
 Feb 15 15:02:23 <cjwatson> $ rmadison -s lucid-updates linux-backports-modules-wireless-lucid-generic-pae
 Feb 15 15:02:23 <cjwatson> linux-backports-modules-wireless-lucid-generic-pae | 2.6.32.28.32 | lucid-updates | amd64, i386
 Feb 15 15:02:23 <cjwatson> $ rmadison -s lucid-updates linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic-pae
 Feb 15 15:02:24 <cjwatson> linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic-pae | 2.6.32-28.27 | lucid-updates | i386
 Feb 15 15:02:43 <cjwatson> so I diagnose the problem here as being that the metapackages are just built for architectures where they shouldn't be
 Feb 15 15:03:19 <cjwatson> this is essentially harmless - the metapackages (linux-backports-modules-wireless-lucid-server/i386 and linux-backports-modules-wireless-lucid-generic-pae/amd64) are uninstallable on those architectures, but they're actually just supposed to be absent
 Feb 15 15:03:52 <cjwatson> annoying and certainly a bug but not really a big deal, I think

Tim Gardner (timg-tpi) wrote :

No fix required for Natty.

Changed in linux-meta (Ubuntu Natty):
status: In Progress → Invalid
Tim Gardner (timg-tpi) wrote :
Tim Gardner (timg-tpi) wrote :
Stefan Bader (smb) on 2011-02-17
Changed in linux-meta (Ubuntu Lucid):
status: In Progress → Fix Committed
Stefan Bader (smb) on 2011-02-17
Changed in linux-meta (Ubuntu Maverick):
status: In Progress → Fix Committed

Accepted linux-meta into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted linux-meta into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 2.6.32.29.35

---------------
linux-meta (2.6.32.29.35) lucid-proposed; urgency=low

  [ Tim Gardner ]

  * LBM generic-pae packages are only built for i386
    - LP: #720139
  * LBM preempt packages are only built for amd64
    - LP: #720139
  * LBM server packages are only built for amd64
    - LP: #720139
 -- Stefan Bader <email address hidden> Thu, 17 Feb 2011 11:56:28 +0100

Changed in linux-meta (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 2.6.35.27.35

---------------
linux-meta (2.6.35.27.35) maverick-proposed; urgency=low

  [ Tim Gardner ]

  * LBM generic-pae packages are only built for i386
    - LP: #720139
  * LBM server packages are only built for amd64
    - LP: #720139

linux-meta (2.6.35.27.34) maverick-proposed; urgency=low

  * Bump ABI - Maverick ABI 26

linux-meta (2.6.35.26.33) maverick-proposed; urgency=low

  * Bump ABI - Maverick ABI 26
 -- Stefan Bader <email address hidden> Thu, 17 Feb 2011 14:55:31 +0100

Changed in linux-meta (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers