atheros wifi doesn't work when resuming after suspend-to-memory

Bug #299641 reported by Jakob Lund on 2008-11-18
This bug report is a duplicate of:  Bug #275692: ath_pci must be reloaded after resume. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

In Intrepid [kernel 2.6.27-8-generic], my wireless card [Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)] will not work after suspending the laptop.

It will not work after restarting NetworkManager either (with sudo /etc/init.d/NetworkManager restart). It WILL work after removing and then inserting the drivers (with sudo rmmod ath5k ath_pci; sudo modprobe ath_pci; sudo modprobe ath5k).

At some point (after updating to intrepid, but before doing a dist-upgrade sometime last week) the resume operation worked. The dist-upgrade did update the kernel and drivers, but selecting the previous kernel version from the GRUB boot menu did not prevent the problem from happening, so I'm not sure exactly which package update introduced the error. Like I said, I can make the card work by modprobe'ing, so the problem must be with the state of the driver after resume, that's why I post it with linux-backports-modules.

Any info that I can provide that could clarify what happens? I glanced over /var/log/messages, but things looked kind of normal in there -- I guess this bit (from dmesg output) describes the failure:

[ 4855.524048] pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 4855.524054] pci 0000:00:02.0: setting latency timer to 64
[ 4855.525685] PM: resume devices took 2.316 seconds
[ 4855.525719] PM: Finishing wakeup.
[ 4855.525722] Restarting tasks ... done.
[ 4862.193366] eth0: link down
[ 4862.194066] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 4862.199840] ADDRCONF(NETDEV_UP): ath0: link is not ready
[ 5936.820585] eth0: link down
[ 5936.820954] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 5936.834492] ADDRCONF(NETDEV_UP): ath0: link is not ready

Tomasz Rzepecki (nub) wrote :

i have similar problem with atheros 5007eg.
i'm not sure if the problem was ever not present, however it may matter that i'm using a third party driver from madwifi site (see http://madwifi-project.org/ticket/1192 ).
reloading the drivers does solve the problem in my case, as well.
i'll try compiling the latest snapshotof the madwifi drivers to see if it changes anything.

Tomasz Rzepecki (nub) wrote :

installing the latest snapshot didn't help.

schmolch (saschaheid) wrote :

same here.
Intrepid on a Thinkpad T42 with atheros wlan.
Wifi is broken after suspend (ram and disk).

[rant]
Suspend and resume is such a sad joke on linux, how many more decades will it take?
And finally it worked in Hardy and now the stupid little networkmanager renders it useless again.
[/rant]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.