Upgrade to kernel 2.6.24-19 renders system unbootable

Bug #238789 reported by giovanni on 2008-06-10
4
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Dimitrios Symeonidis

Bug Description

Binary package hint: linux-backports-modules-hardy-386

Ubuntu Hardy
Kernel 2.6.24-19
PC DOES NOT BOOT

Dimitrios Symeonidis (azimout) wrote :

Dear Giovanni, we're going to need some more information in order to identify and solve this bug.

1) Did you do a clean install of Hardy, or upgrade from an earlier version?
2) Can you boot with an Ubuntu LiveCD?
3) Where does the boot process stop? What error messages can you see?

Thank you for your help in making Ubuntu better.

Changed in linux-meta:
status: New → Incomplete
giovanni (giolombardo) wrote :

Hi dimitrios:
1. I upgraded from Ubuntu 7 via Internet
2. I haven't it
3. At the beginning. I then rebooted manually, pressed ESC, chose the previous kernel (-18). Then via gedit I blinded the new one (#).

Dimitrios Symeonidis (azimout) wrote :

Dear Giovanni, thank you for reporting this bug and helping make Ubuntu better.

Ok, so you can boot with kernel version 2.6.24-18 but not 2.6.24-19.

We are going to need to know the hardware included in your system, and any error messages the kernel issues.
Booting the working -18 kernel, please run the following 4 commands, and attach the resulting files.
 * uname -a > uname-a.log
 * cat /proc/version_signature > version.log
 * dmesg > dmesg.log
 * sudo lspci -vvnn > lspci-vvnn.log

It would also help to know any error messages from the -19 kernel. In /boot/grub/menu.lst, you don't need to comment out the -19 kernel, just change the "default" option (right at the top) from 0 (1st kernel in the list) to probably something like 2, which should be the -18 kernel (3rd in the list). Then try booting the -19 kernel without the "quiet" and "splash" options, and tell us any error messages you see (taking a screenshot with a digital camera, or even writing them down by hand and typing them in here is also fine...

Thank you for your help

giovanni (giolombardo) wrote :

dear Dimitrios

I didn't understand when I have to run the following 4 commands you mentioned in your response.

From Terminal:
giovanni@giovanni-desktop:~$ uname -a > uname-a.log
giovanni@giovanni-desktop:~$ cat /proc/version_signature > version.log
giovanni@giovanni-desktop:~$ dmesg > dmesg.log
giovanni@giovanni-desktop:~$ sudo lspci -vvnn > lspci-vvnn.log
[sudo] password for giovanni:
Sorry, user giovanni is not allowed to execute '/usr/bin/lspci -vvnn' as root on giovanni-desktop.
giovanni@giovanni-desktop:~$ su
Password:
root@giovanni-desktop:/home/giovanni# uname -a > uname-a.log
root@giovanni-desktop:/home/giovanni# cat /proc/version_signature > version.log
root@giovanni-desktop:/home/giovanni# dmesg > dmesg.log
root@giovanni-desktop:/home/giovanni# lspci -vvnn > lspci-vvnn.log
root@giovanni-desktop:/home/giovanni#

Dimitrios Symeonidis (azimout) wrote :

Ok, don't worry, it just means your "giovanni" account doesn't have administrative priviledges...
Now, the commands you just ran should have created 4 files in your home directory (uname-a.log, version.log, dmesg.log and lspci-vvnn.log). Can you attach them to this bug?

giovanni (giolombardo) wrote :

ok.

giovanni (giolombardo) wrote :
giovanni (giolombardo) wrote :
giovanni (giolombardo) wrote :
giovanni (giolombardo) wrote :

I would add that I cannot upgrade and I missed Synaptic.
Furthermore, Ubuntu hardy new kernel has seemingly destroyed my mic settings (I cannot use Skype any longer).
Long life to Mr. Windows?!?

Dimitrios Symeonidis (azimout) wrote :

The system setup seems pretty normal:
Dual core Intel CPU, Intel ICH5 southbridge, AC97 audio, Ati Radeon graphics, Realtek 8139 ethernet.
The only suspicious item is the TI ACX111 wifi, which needs the acx100 driver.

A lot of bugs related to acx reported:
https://bugs.launchpad.net/bugs/+bugs?field.searchtext=acx&orderby=-datecreated
However, non seem serious enough to make a system unbootable.

Giovanni, your latest comment is not clear: do you mean that update manager and synaptic package manager have disappeared from the system menu?

Also, can you check if your wifi card works with the -18 kernel? What about the microphone?

Finally, I am going to need you to try booting the -19 kernel (without the 'quiet' and 'splash' options) and tell me the error messages of the kernel log...

Changed in linux-meta:
assignee: nobody → azimout
giovanni (giolombardo) wrote :

I cannot update, when I try I get this error message:

Fallita l'esecuzione di /usr/sbin/synaptic '--hide-main-window' '--non-interactive' '--parent-window-id' '37748739' '--update-at-startup' come utente root.

Il meccanismo di autorizzazione sottostante (sudo) non permette di eseguire questo programma. Contattare l'amministratore di sistema.

(trans.: failed to implement usr/sbin/synaptic '--hide-main-window' '--non-interactive' '--parent-window-id' '37748739' '--update-at-startup' as root.
The authorization's mechanism (sudo) does not allow to launch this implement this program. Contact the administrator).

I confirm that Synaptic package disappeared from menu and I cannot restore it.

I will try to reboot as -19 and I will revert to you.

Meanwhile thanks for your assistance.

giovanni (giolombardo) wrote :

I add that the microphone does not work. I tried to record a message via Audacity but I could not hear it later.

giovanni (giolombardo) wrote :

Ok, I freed -19. this is the initial message

QUOTE
Booting 'Ubuntu 8.04, kernel 2.6.24-19 generic' root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.24-19
generic root=UUID=338510e3-2cbd-49a9-91ef-63938 abd 3759 ro quiet splash locale=it_IT
UNQUOTE

Then nothing else. I have to reboot manually, press ESC and choose the previous version.

Dimitrios Symeonidis (azimout) wrote :

To me it seems that a lot of things went wrong during your last update. There's something wrong with sudo...

First of all, run 'id' and see if your account is part of the 'admin' group.

Also, try running: dpkg --configure -a
See if this fixes anything.

You could also try:
sudo aptitude update (this will update your package list) and then
sudo aptitude full-upgrade

In the meantime, check if the -19 kernel is there: check if the file /boot/vmlinuz-2.6.24-19 exists.

I am also a volunteer here...

giovanni (giolombardo) wrote :

giovanni@giovanni-desktop:~$ id
uid=1000(giovanni) gid=1000(giovanni) gruppi=29(audio),1000(giovanni)
giovanni@giovanni-desktop:~$ dpkg --configure -a
dpkg: l'operazione richiesta necessita dei privilegi di superuser
giovanni@giovanni-desktop:~$ su
Password:
root@giovanni-desktop:/home/giovanni# dpkg --configure -a
root@giovanni-desktop:/home/giovanni# find .|grep /boot/vmlinuz-2.6.24-19
root@giovanni-desktop:/home/giovanni#

I killed gksu - suggested by an italian "expert" on the forum. Maybe is this the reason for which I cannot see Synaptic?
I did full-upgrade and it worked fine.
In any case the new kernel really sucks...
Kalispéra

Dimitrios Symeonidis (azimout) wrote :

Dear Giovanni, it seems your account is a very limited one; you are a member of only 2 groups.
Take for example the output of my 'id' command:
uid=1000(azimout) gid=1000(azimout) groups=4(adm),20(dialout),21(fax),24(cdrom),29(audio),30(dip),44(video),46(plugdev),104(scanner),108(lpadmin),110(admin),115(netdev),117(powerdev),1000(azimout),1002(usrp)
You should at least add your account to the admin group, by running: 'sudo usermod -a -G admin giovanni'

I see that dpkg finished fine, so that was not the problem.

Can you run 'ls /boot > bootdir.log' and attach the resulting bootdir.log file here? I'm curious about the installed kernels... What would also be interesting is the contents of /lib/modules and /lib/firmware

Kalispera

giovanni (giolombardo) wrote :

kalimera Dimitrios

here is the log. Please consider that I ghosted my pc, restoring a previous image, so I don't know if it helpful.

How can i find the contents of /lib/modules and /lib/firmware?

Dimitrios Symeonidis (azimout) wrote :

Giovanni, it is rather obvious that the ghost/restoration procedure went wrong.

My advice to you is to backup all your documents (on cd/dvd, on a different hard drive, on a flash disk, it's up to you). Then download and burn the Hardy iso image, and make a clean install of the system.

You can find detailed instructions about the procedure here:
https://help.ubuntu.com/community/GraphicalInstall

For any further help, you can ask questions at UbuntuForums.

I am closing this bug report as invalid.

Dimitrios Symeonidis (azimout) wrote :

The problem occured after restoring the image of an Ubuntu partition using (apparently) Norton Ghost. This is not a Ubuntu bug

Changed in linux-meta:
status: Incomplete → Invalid
giovanni (giolombardo) wrote :

I used Clonezilla.

Why do you say it went wrong?

Dimitrios Symeonidis (azimout) wrote :

Because what you describe are multiple issues that seem unrelated to one-another, e.g. unbootable kernel, microphone settings, programs disappearing from the menu, limited user-account priviledges...

Your problem seems a support problem (that's what the forums are for) and not a bug in Ubuntu.

By the way, for help using Clonezilla, you can read this:
https://help.ubuntu.com/community/Clonezilla_Server_Edition

  • unnamed Edit (1.5 KiB, text/html; charset=ISO-8859-1)

Indeed you are right. But everything started with the newest kernel.
I will back up my files and programs and then install a clear image of
Ubuntu.
Let's hope it works.

On Thu, Jun 12, 2008 at 2:51 PM, Dimitrios Symeonidis <email address hidden>
wrote:

> Because what you describe are multiple issues that seem unrelated to
> one-another, e.g. unbootable kernel, microphone settings, programs
> disappearing from the menu, limited user-account priviledges...
>
> Your problem seems a support problem (that's what the forums are for)
> and not a bug in Ubuntu.
>
> By the way, for help using Clonezilla, you can read this:
> https://help.ubuntu.com/community/Clonezilla_Server_Edition
>
> --
> Upgrade to kernel 2.6.24-19 renders system unbootable
> https://bugs.launchpad.net/bugs/238789
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Giovanni Lombardo
via Gorizia, 1
20097 San Donato Milanese MI
02 55602257 casa
02 92878665 mailfax
3358029632 cellulare

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers