[intrepid] linux-restricted-modules-server metapackage not present in repository

Bug #220781 reported by Conn O Griofa on 2008-04-22
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Stefan Bader
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Stefan Bader

Bug Description

SRU justification:

Impact: Missing dependency causes lrm not to be upgraded when the Linux server image is ABI bumped. Since Intrepid this won't affect the binary gfx drivers but some wireless modules still provided through lrm.

Fix: Simple addition to the meta-package to include the missing dependency

---

Edit: This is still happening in Intrepid (in my case, up-to-date Intrepid x86_64). I'm leaving the description below for history.

===

System: Hardy x86 (fresh install from RC, latest updates & using main repository)

Test case:
install -server kernel via: sudo apt-get install linux-server

Expected results:
All necessary packages are installed, including linux-restricted-modules-server and the actual restricted modules package, linux-restricted-modules-2.6.24-16-server.

Actual results:
The linux-restricted-modules-server metapackage does not exist in the repository, and thus linux-restricted-modules-2.6.24-16-server will not get installed.

Note: my system uses the nvidia driver via nvidia-glx-new which requires restricted modules, and so the -server kernel will boot to the failsafe X configuration, unless I remember to manually install linux-restricted-modules-2.6.24-16-server.

Conn O Griofa (psyke83) wrote :

Fixed in linux-meta 2.6.24.17.19

Changed in linux-meta:
status: New → Fix Released
James Rice (james-rice2) wrote :

This bug states that the fix is released, but linux-restricted-modules-server still does not exist in hardy, which I believe is the problem, and one I still have. Am I not understanding the process?

Conn O Griofa (psyke83) wrote :

James,

If you enable the hardy-proposed repository you will find it has been fixed in kernel 2.6.24-17. If you do not want to enable this repository, I assume this fix will be included in the next kernel update.

You can see the metapackage now exists from here: https://lists.ubuntu.com/archives/hardy-changes/2008-May/011439.html

Brice Terzaghi (terzag) wrote :

While this bug is marked as "fix released", the restricted-modules-server metapackage is still not present in Intrepid (kernel 2.6.27-9) ! The user has to install and update manually the latest package available.

Has it been forgotten ?

Bogdan Butnaru (bogdanb) wrote :

Still happening on Intrepid.

Changed in linux-meta:
status: Fix Released → Confirmed
description: updated
Nexus (nexus-hoth) wrote :

Still not present in Intrepid (2.6.27-8, 2.6.27-9, 2.6.27-10, 2.6.27-11)..
(I am using -server branch for 4G RAM and -restricted module is required for my Nvidia GFX and Broadcom WiFi)

Yannis Tsop (ogiannhs) wrote :

I have the same problem. Where is linux-restricted-modules-server? Every time I update any pc X server is broken since there is no dependency for the new kernel restricted modules.

http://packages.ubuntu.com/intrepid/allpackages

No entry there!

Bart de Koning (bratdaking) wrote :

There is still no linux-restricted-modules-server metapackage available, only one for the generic kernel.
I have a server running, that also needs a desktop with a nvidia card. This means the nvidia driver gets broken each time there is a kernel update, because it does not update the restricted modules automatically. Having a meta-package would make life a bit easier :-)
(Besides the description of the individual packages also recommends installing the metapackage that is not there, a bit sloppy to my opion)

Cheers,
Bart

Stefan Bader (smb) wrote :

Not sure how this is an issue with Intrepid. The only drivers still in restricted are wireless drivers and ltmodem. The binary gfx drivers are in separate DKMS package which will get rebuild when a new kernel is installed.

Changed in linux-meta:
assignee: nobody → stefan-bader-canonical
Yannis Tsop (ogiannhs) wrote :

since with every server kernel there is a linux-restricted-modules-2.6.x.xx there should be a meta. if there is no need for restricted there should be no package for linux-restricted-moudules-2.6.x.xx

Stefan Bader (smb) on 2009-04-05
description: updated
Bart de Koning (bratdaking) wrote :

Sorry for my late reply. However you were right I was a bit too quick in my post. The binary drivers are indeed not included in this metapackage, and installing them did not work out for my video card. But that does not eliminate that there is a need for a metapackage to my opion, like Yannis also mentioned. It makes life easier for people that have to use the modules and still it is a bit sloppy to point at a package that does not exist.
Thanks for your reply though, it made me aware of were to look for my drivers.

Martin Pitt (pitti) wrote :

Please fix in Jaunty ASAP.

Changed in linux-meta (Ubuntu Jaunty):
status: Confirmed → Triaged
Changed in linux-meta (Ubuntu Intrepid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux-meta into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Stefan Bader (smb) wrote :

Fix included in 2.6.28.11.15 for Jaunty

Changed in linux-meta (Ubuntu Jaunty):
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

linux-meta (2.6.28.11.15) jaunty; urgency=low

  * Adding linux-restricted modules for server
    - LP #220781

 -- Stefan Bader <email address hidden> Wed, 15 Apr 2009 18:23:18 +0200

Changed in linux-meta (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Steve Beattie (sbeattie) wrote :

This change now causes linux-server (in main) to depend on linux-restricted-modules (in restricted) (bug 364266). Doesn't linux-server also need to move to restricted (a la linux-generic)?

Steve Langasek (vorlon) wrote :

thanks, moving linux-server to restricted; will reroll the ubuntu-server ISOs.

Steve Langasek wrote:
> thanks, moving linux-server to restricted; will reroll the ubuntu-server
> ISOs.
>
Steve, does this require/should we change the section in linux-meta for
linux-image-server to restricted/metapackages?

Steve Langasek (vorlon) wrote :

On Tue, Apr 21, 2009 at 07:47:29AM -0000, Stefan Bader wrote:
> Steve Langasek wrote:
> > thanks, moving linux-server to restricted; will reroll the ubuntu-server
> > ISOs.

> Steve, does this require/should we change the section in linux-meta for
> linux-image-server to restricted/metapackages?

Ideally, yes, but it's not required since the authoritative source for
sections is in soyuz.

Cheers,
--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Steve Beattie (sbeattie) wrote :

On Mon, Apr 20, 2009 at 11:39:15PM -0000, Steve Langasek wrote:
> thanks, moving linux-server to restricted; will reroll the ubuntu-server
> ISOs.

For the record, I caught this by running edos-debcheck. When looking
to report the issue, I looked at the component-mismatches report at
http://people.ubuntu.com/~ubuntu-archive/component-mismatches.txt and
did not see it listed there; it may be worth exploring why the script
that generates component-mismatches didn't catch it.

--
Steve Beattie
<email address hidden>
http://NxNW.org/~steve/

Steve Beattie (sbeattie) wrote :

What should be done here about the linux-server/linux-meta package in intrepid-proposed? It has the same issue, that linux-server in -main depends on linux-restricted-modules in -restricted (which I can confirm that the package in proposed does indeed do), which I assume we want to avoid, but we also don't want to move the linux-server package to -restricted in a released archive either.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 2.6.27.14.18

---------------
linux-meta (2.6.27.14.18) intrepid-proposed; urgency=low

  * Add dependencies to linux-restricted modules for server
    - LP: #220781

 -- Stefan Bader <email address hidden> Mon, 06 Apr 2009 01:37:00 +0200

Changed in linux-meta (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers