appletouch does not recognize trackpad in macbook3,1

Bug #162090 reported by Chris Irwin
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-meta (Ubuntu)
Undecided
Andy Whitcroft
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6-amd64-generic

The macbook3,1 ("Santa Rosa") has a trackpad that appears to be identical to previous generations, but with new IDs.

Attached is a patch adding the new IDs to the appletouch driver.

Revision history for this message
Chris Irwin (chrisirwin) wrote :
Revision history for this message
Chris Irwin (chrisirwin) wrote :

Adding comment to have word macbook with spaces around so it will turn up in more generic searches.

Revision history for this message
cleentrax (cleentrax) wrote :

This patch worked well for me. Trackpad now recognized and customizable in xorg.conf and gsynaptics.

Revision history for this message
Ian Ohr (munk3h) wrote :

This patch did not work for me. I don't have amd64 architecture. Is there anything in the patch that makes it architecture specific?

When the Xorg log says "synaptics module", is that a kernel module, or a module in Xorg?

Revision history for this message
Chris Irwin (chrisirwin) wrote :

This applies to 2.6.24-2.3 from Hardy as well. Can we get this included for Hardy?

Ian, can you attach the output of 'lsusb' ?

Revision history for this message
Chris Irwin (chrisirwin) wrote :

Changed to Confirmed (it has been)
Assigned to Ubuntu-kernel-team (I think this is where it should go)

Changed in linux-meta:
assignee: nobody → ubuntu-kernel-team
status: New → Confirmed
Revision history for this message
Robert Nasiadek (robzon) wrote :

Please include the patch in Hardy kernel. Thanks.

Revision history for this message
Joe Jaxx (joejaxx) wrote :

Here is a git diff against the latest Hardy kernel with the patch for this bug.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks Joe,

Will reassign to the kernel team to try to get this into the final Hardy release. I doubt it will be backported to Gutsy but I'll leave it to their discretion. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux:
assignee: ubuntu-kernel-team → colin-king
Changed in linux:
status: Triaged → Fix Committed
Revision history for this message
Tim Gardner (timg-tpi) wrote :

2.6.24-8.14

Changed in linux:
assignee: colin-king → nobody
status: Fix Committed → Fix Released
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Revision history for this message
Rafaël Carré (funman-videolan) wrote :

The fix isn't in 2.6.24-10.8 , i see no 2.6.24-8.14 release

Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Revision history for this message
Andy Whitcroft (apw) wrote :

This is a kernel issue which has since been fixed and released. Closing off the linux-meta task as invalid.

Changed in linux-meta (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers