Gutsy hangs at boot with COMRESET failed error (kernel 2.6.22-13 and 2.6.22-14)

Bug #150259 reported by Mahdi on 2007-10-07
20
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

After gutsy updates on Oct. 6 to kernel version 2.6.22-13, my T61 Thinkpad does not boot any more. It shows the error:
ata1: COMRESET failed (errorno=-16). 2.6.22-14 does not fix this error.

Mahdi (mmirzaza) on 2007-10-07
description: updated
Joseph Wakeling (webdrake) wrote :

Ditto on a ThinkPad R61.

I wonder if this is a regression to a bug in the Feisty kernel, since that would often hang on boot in a similar manner.

Temporarily of course you can boot by selecting the earlier kernel from GRUB.

Joseph Wakeling (webdrake) wrote :

Looks like the latest updates fix this. :-)

Mahdi (mmirzaza) wrote :

No, for me the error is still appearing, but not at every reboot. Once in every two reboots, maybe.

Nirav Patel (nrpatel) wrote :

The same error is occuring for me at boot on my T61 with the newest kernel. The sequence of errors is as follows:

ata1: SATA link up 1.5 Gbps (Sstatus 112 Scontrol 300)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1: port is slow to respond, please be patient (Status 0x80)
ata1: COMRESET failed (errno=-16)

It repeats that loop a few times, gives an error about not being able to find the disk, and then drops into busybox. The /dev/disk directory does not exist when I try to visit it in busybox. When I boot using an older kernel, it works.

Joseph Wakeling (webdrake) wrote :

Yes, I spoke too soon. :-(

Here's the sequence of errors for me on my R61:

irq 20: nobody cared (try booting with the "irqpoll" option)
handlers:
[<f888a6a0>] (usb_hcd_irq+0x0/0x60 [usbcore])
Disabling IRQ #20
ata3: COMRESET failed (errorno=-16)

Just updated the report to confirm it also affects 2.6.22-14.

Query: should this bug affect "linux-meta" or should we change it to linux-generic and confirm the version numbers?

description: updated
nowshining (nowshining) wrote :

i also have a hanging bug - someone posted on mine and well it looks the same error as cmonkey on the SATA part, i didn't have the errors and .13 kernel itself was working just fine and then i did some updates and wamo all was lost

if u see my bug report there is an update history to what updates might have caused it because one of them in that list caused it and After every updates I ALWAYS do a soft reboot.

dawa (danwal) wrote :

ive got a thinkpad R61

kernel 2.6.22-12 runs without problems.
but at kernels higher than ...-12, i get exactly the same error like the thread starter

Mahdi (mmirzaza) wrote :

All the people commented here have this important problem, but nobody from Ubuntu team has cared about that. Why is that? Is anything that we should do to notify them of the problem, other than what we have already done?

dawa (danwal) wrote :

today i made an ubuntu update, and now the newer kernel works after a restart :)

Mahdi (mmirzaza) wrote :

No, it still fails too boot sometimes for me!

dawa (danwal) wrote :

only sometimes ??

Mahdi (mmirzaza) wrote :

Yes, sometimes! and some times it boots up without any problem. Maybe it happens for you if you try restarting your machine a couple of times :)

dawa (danwal) wrote :

you're right :( now my laptop dont want to start anymore ^^

dawa (danwal) wrote :

i tried surely 20 times to boot... no chance anymore :( when i saw .14 was running i deleted the .12 kernel
not anymore recovery mode of .14 kernel is possible to boot

You can try compatibility mored for hard disk in the system BIOS setup. I
think that would work.

-Mahdi

On 10/15/07, dawa <email address hidden> wrote:
>
> i tried surely 20 times to boot... no chance anymore :( when i saw .14 was
> running i deleted the .12 kernel
> not anymore recovery mode of .14 kernel is possible to boot
>
> --
> Gutsy hangs at boot with COMRESET failed error (kernel 2.6.22-13 and
> 2.6.22-14)
> https://bugs.launchpad.net/bugs/150259
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Joseph Wakeling (webdrake) wrote :

The reason for the lack of attention might be several things:

(i) there is a long bug list right now for linux-meta: https://bugs.launchpad.net/ubuntu/+source/linux-meta

(ii) We haven't defined the bug precisely enough. Should it be linux-meta or linux-sources or something else? We're not talking about sources here but about the compiled kernel.

(iii) The bug simply hasn't been confirmed yet.

Does anyone else recall the same problem with Feisty? I certainly experienced it on my machine although not to the same degree (it would boot most of the time and just hang occasionally, whereas now it hangs most of the time and boots rarely).

Ravi S (s-ravi-in+ubuntu) wrote :

I upgraded my feisty to gutsy yesterday (Oct 15). I am getting the same error on 2.6.22-14. Once in every 4 or 5 boot, this error is shown up. Please let us know if there are any workaround.

Joseph Wakeling (webdrake) wrote :

Ravi S wrote:
> I upgraded my feisty to gutsy yesterday (Oct 15). I am getting the same
> error on 2.6.22-14. Once in every 4 or 5 boot, this error is shown up.
> Please let us know if there are any workaround.

Probably the easiest workaround is to install kernel 2.6.22-12, the last
known version without this bug. I think you can do this via Synaptic or
Adept or via,

sudo apt-get install linux-image-2.6.22-12-generic

(you may also need to add some further stuff with 2.6.22-12 in the
title: linux-headers-2.6.22-12, linux-headers-2.6.22-12-generic,
linux-restricted-modules-2.6.22-12-generic,
linux-ubuntu-modules-2.6.22-12-generic. I'm not sure.)

Then pick 2.6.22-12 as the kernel to use when booting.

Hope that works, let us know.

nowshining (nowshining) wrote :

2.6.22.12 is not available from the last time I checked.

Joseph Wakeling (webdrake) wrote :

2.6.22-12 is probably available on the Gutsy Beta CD (you could add this as a temporary APT resource). Otherwise I don't know, I didn't realise it had been removed from the repos.

You are searching for this right, aren't you? 2.6.22-12 (note the hyphen, not full stop, between the last two numbers).

If you type at the command prompt,

sudo apt-get install linux-image

and hit the TAB key to see the options available, what do you see? I get the following list:

linux-image linux-image-debug-2.6.22-14-generic
linux-image-2.6 linux-image-debug-2.6.22-14-server
linux-image-2.6.22-12-generic linux-image-debug-2.6.22-14-ume
linux-image-2.6.22-13-generic linux-image-debug-2.6.22-14-virtual
linux-image-2.6.22-14-386 linux-image-debug-386
linux-image-2.6.22-14-generic linux-image-debug-generic
linux-image-2.6.22-14-rt linux-image-debug-server
linux-image-2.6.22-14-server linux-image-debug-ume
linux-image-2.6.22-14-ume linux-image-generic
linux-image-2.6.22-14-virtual linux-image-rt
linux-image-2.6.22-14-xen linux-image-server
linux-image-2.6-386 linux-image-ume
linux-image-386 linux-image-virtual
linux-image-debug-2.6.22-14-386 linux-image-xen

... but of course I already had 2.6.22-12 installed, which may be why I see it.

Joseph Wakeling (webdrake) wrote :

Lack of compliance to the requirements for Kernel-related bugs may be why we have seen no interest:
https://wiki.ubuntu.com/KernelTeamBugPolicies

Joseph Wakeling (webdrake) wrote :

Nobody else seems to have mentioned this, but if (as the error suggests:-) you pass the "irqpoll" option to the kernel, it does boot. This makes me think this is a duplicate of the following bug:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/123617

To pass the option to the kernel at boot, you can hit the 'e' key while the relevant kernel is highlighted in the GRUB menu. Once booted you can edit the file
/boot/grub/menu.lst

Look for a section like this,

title Ubuntu 7.10, kernel 2.6.22-14-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=62026ec1-9a6b-4e23-9bf7-b6482997fb3e ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet

Add "irqpoll" (without the quotes) to the end of the line beginning "kernel", so afterwards you will have,

title Ubuntu 7.10, kernel 2.6.22-14-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=62026ec1-9a6b-4e23-9bf7-b6482997fb3e ro quiet splash irqpoll
initrd /boot/initrd.img-2.6.22-14-generic
quiet

This should fix things. Do the same for all the other kernels this problem is showing up with.

thoughtbox (th+ubuntubugs) wrote :

For what it's worth, I just upgraded from Feisty to Gutsy and found that the default kernel (2.6.22-14-i386) did NOT boot (with irqpoll and pci=noacpi), but stopped at Busybox complaining that it couldn't find the drive ID.

I changed to 2.6.22-14-generic with the same boot options and it worked fine.

/tb

nowshining (nowshining) wrote :

okay i FINALlY got 2.6.22-14-generic installed However it ran fast on the CD but not on this upgrade :( the drives DID INDEED change from SCSI ones to back to HDA and when running hdparm -t /dev/hda1 it shows

/dev/hda1:
 Timing buffered disk reads: 10 MB in 3.22 seconds = 3.10 MB/sec

/dev/hda
/dev/hda:
 Timing buffered disk reads: 10 MB in 3.27 seconds = 3.05 MB/sec

..............
when i tried setting DMA on HDA1 (hard drive mounted as that) it shows the following

 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Invalid argument
 using_dma = 0 (off)

/dev/hda
setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma = 0 (off)

..................
After doing a search on clusty I found out that when a kernel when trying to hdparm dma on it throws out the operation not permitted error, well it means that a PARTICULAR Chipset is NOT compiled into the kernel itself..Yes I got my CDs today and YES I kind of installed from that and also it did have to go out and download 18mb or such or I probably didn't add the apt-cdrom right and the last was from a last download i don't know tho..

Mirko Nasato (mirko-nasato) wrote :

I had the same problem on my T61. I initially changed the SATA config in the BIOS to "compatibility" as a workaround.

Then I found this other bug

  https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/162536

where it says it's actually a BIOS problem.

So I did the BIOS upgrade (and a drive firmware upgrade as well for good measure), set SATA mode back to "AHCPI" and now it seems to be working fine.

JoE (johan-eneland) wrote :

I have upgraded to Ubuntu 7.10 (2008-01-13) and got this (old) bug.

The kernel 2.6.22-14-386 is never booting for me.
If I use the kernel 2.6.20-16-386 it works as expected.

The boot is stuck when the window with the Ubuntulogo is opening.
after about 3 minutes it changes to some kind of text mode with the cursor
(initramfs)
sometimes it dont respond for keyboard.
Sometimes it is possible to type for example ls.
If I type exit the response can be "BusyBox v1.1.3 (Debian 1:1.1.3-5 ubuntu7)..."

Note: The attached files
      uname -a > uname-a.log
      cat /proc/version_signature > version.log
      dmesg > dmesg.log
      sudo lspci -vvnn > lspci-vvnn.log
are generated after booting with a working kernel.

JoE (johan-eneland) wrote :

the files

JoE (johan-eneland) wrote :
JoE (johan-eneland) wrote :

lspci-vvnn.log

JoE (johan-eneland) wrote :
JoE (johan-eneland) wrote :

I had some trouble to send the attached files but here is the last of them

Caroline Ford (secretlondon) wrote :

The Hardy Heron Alpha series is currently under development and contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to test the new kernel using the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks.

Changed in linux-meta:
status: New → Invalid
Changed in linux-source-2.6.22:
status: New → Incomplete
JoE (johan-eneland) wrote :

I tested Hardy Heron Alpha as LiveCD and it booted correctly.
(It also mounted USB memories with FAT32 automatically. Bug #151025 in gnome-mount (Ubuntu))
So it seems like at least 2 bugs are solved.

Caroline Ford (secretlondon) wrote :

I'm going to close this bug as fixed in the current Ubuntu. If it returns please re-open :)

Changed in linux-source-2.6.22:
status: Incomplete → Fix Released

Same issue here on a Thinkpad T60.

A BIOS upgrade to current version 2.21 did not help. The problem only occurs with the 2.6.22-14-rt kernel, 2.6.22-14-generic boots fine. I also tested with 2.6.24-12-rt from hardy alpha, which shows the same symtomes: The system freezes after printing "Loading saved-state of the serial devices". The -generic kernel prints "Too much work for IRG 3" after this message and boots up nicely. Adding "pci=noacpi" to the -rt kernel commandline gives me

ata1: SATA link up 1.5 Gbps (Sstatus 112 Scontrol 300)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1: port is slow to respond, please be patient (Status 0x80)
ata1: COMRESET failed (errno=-16)

already much earlier during the boot process. Using SATA compatibility mode in BIOS also does not help.

Re-opening since this bug still occurs with current Hardy kernel on my machine

Changed in linux-source-2.6.22:
status: Fix Released → Confirmed

I just tried using Feisty's 2.6.20-16-lowlatency kernel. It boots nicely and I am able to use jackd in realtime mode without problems. I still have to get fglrx running again, though.

The problem was indeed related to the "Too much work for IRQ 3" message I received during boot of the -generic kernel. Switching the Infrared in BIOS from IRQ3 to IRQ4 solved all my problems! I will therefore re-close.

Changed in linux-source-2.6.22:
status: Confirmed → Fix Released
Martha (mlee10) wrote :

Well this bug has been well reported. Has anyone ound a fix for it?

Caroline Ford (secretlondon) wrote :

Are you still using gutsy?

Sent from a mobile device.

On 27 Jul 2009, at 00:29, Martha <email address hidden> wrote:

> Well this bug has been well reported. Has anyone ound a fix for it?
>
>

Martha (mlee10) wrote :

I have just downloaded Ubuntu 9.04 for desktops (the latest version)maintained until 2010 from the University of Tennessee. I dont know what whether this is gutsy or not. I assumed it was the latest version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers