linux-meta: enable linux-crashdump for ppc64el

Bug #1341475 reported by bugproxy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
High
Chris J Arges
Trusty
High
Chris J Arges
Utopic
High
Chris J Arges

Bug Description

SRU Justification:

[Impact]
Users of ppc64el hardware need the ability to use crashdumps to do kernel debugging.

[Test Case]
Taken from:
https://wiki.ubuntu.com/Kernel/CrashdumpRecipe
https://help.ubuntu.com/14.04/serverguide/kernel-crash-dump.html

1) apt-get install linux-crashdump
2) increase crashdump size:
sudo vim /etc/default/grub.d/kexec-tools.cfg
set crashkernel=1024M
sudo update-grub
3) reboot the machine
4) sudo sed -i 's/USE_KDUMP=0/USE_KDUMP=1/g' /etc/default/kdump-tools
5) kdump-config show # should return no errors
6) echo 'c' | sudo tee /proc/sysrq-trigger
7) This should crash the machine and we should kexec into another kernel to dump the core, then on the next reboot we should see a crash in /var/crash/*

[Regression Potential]
Part of the fix involves adding a NEW package for ppc64el to allow linux-crashdump binary package to be built from linux-meta.

--

Problem Description :
====================
I was trying to configure kdump and got below link

https://help.ubuntu.com/12.04/serverguide/kernel-crash-dump.html
As per above link we need to install linux-crashdump pckg but it seems it is not included in repo as when I tried to install it then it failed with that unable to locate it .

root@flyg4:~# apt-get install linux-crashdump
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-crashdump
root@flyg4:~#

root@flyg4:~# uname -a
Linux flyg4 3.13.0-30-generic #55-Ubuntu SMP Fri Jul 4 21:29:58 UTC 2014 ppc64le ppc64le ppc64le GNU/Linux
root@flyg4:~#

bugproxy (bugproxy)
tags: added: architecture-ppc64 bugnameltc-113066 severity-high
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1341475/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Chris J Arges (arges)
affects: ubuntu → linux-meta (Ubuntu)
Brad Figg (brad-figg)
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Revision history for this message
Chris J Arges (arges) wrote :

- The linux-crashdump binary package in linux-meta needs to be adjusted for this arch.
- In addition the dependencies will need to be arch depended properly.
- Finally we'll need to ensure that the bootloader for this arch is adjusted properly to provide the 'crashkernel=X' parameter much like grub is already instrumented.

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1341475

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty
Chris J Arges (arges)
tags: added: bot-stop-nagging
Chris J Arges (arges)
Changed in linux (Ubuntu):
status: Incomplete → Triaged
affects: linux (Ubuntu) → linux-meta (Ubuntu)
bugproxy (bugproxy)
tags: added: targetmilestone-inin1404
Changed in linux-meta (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2014-08-19 06:59 EDT-------
Hi Ubuntu,
any updates on the bug ?

Thanks.

tags: added: architecture-ppc64le
removed: architecture-ppc64
Diane Brent (drbrent)
Changed in linux-meta (Ubuntu):
assignee: nobody → Taco Screen team (taco-screen-team)
Changed in linux-meta (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Chris J Arges (arges)
Chris J Arges (arges)
summary: - Ubuntu 14.04:linux-crashdump pckg is missing from ubuntu repository
+ enable linux-crashdump on ppc64el
Chris J Arges (arges)
description: updated
Revision history for this message
Chris J Arges (arges) wrote : Re: enable linux-crashdump on ppc64el
Changed in linux-meta (Ubuntu):
importance: Medium → High
status: Triaged → In Progress
Changed in linux-meta (Ubuntu Trusty):
assignee: nobody → Chris J Arges (arges)
importance: Undecided → High
status: New → In Progress
Revision history for this message
Chris J Arges (arges) wrote :

There is also another issue:
Starting kdump-tools: Cannot open `/boot/vmlinuz-3.16.0-19-generic': No such file or directory
 * failed to load kdump kernel

Need to adjust for vmlinux.

Chris J Arges (arges)
Changed in makedumpfile (Ubuntu Trusty):
assignee: nobody → Chris J Arges (arges)
importance: Undecided → High
Changed in makedumpfile (Ubuntu Utopic):
importance: Undecided → High
assignee: nobody → Chris J Arges (arges)
Changed in makedumpfile (Ubuntu Trusty):
status: New → In Progress
Changed in makedumpfile (Ubuntu Utopic):
status: New → In Progress
Revision history for this message
Chris J Arges (arges) wrote :

Once we successfully configure makedumpfile/linux-meta with the proper settings, when we do actually try to crash with echo'ing c to sysrq-trigger we get crash then the machine hangs on the following:

[ 513.470444] Sending IPI to other CPUs
[ 513.471585] IPI complete
I'm in purgatory

I've also noticed that kexec works perfectly fine.

description: updated
Chris J Arges (arges)
no longer affects: makedumpfile (Ubuntu)
no longer affects: makedumpfile (Ubuntu Trusty)
no longer affects: makedumpfile (Ubuntu Utopic)
summary: - enable linux-crashdump on ppc64el
+ enable linux-crashdump for ppc64el
Chris J Arges (arges)
summary: - enable linux-crashdump for ppc64el
+ linux-meta: enable linux-crashdump for ppc64el
Revision history for this message
Chris J Arges (arges) wrote :

patch sent to ubuntu kernel-team ML

description: updated
Chris J Arges (arges)
description: updated
Revision history for this message
Chris J Arges (arges) wrote :

This has been committed to utopic/trusty ubuntu-*-meta trees.

Changed in linux-meta (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in linux-meta (Ubuntu Utopic):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 3.16.0.21.22

---------------
linux-meta (3.16.0.21.22) utopic; urgency=medium

  * UBUNTU: Make linux-crashdump build for ppc64el
    -LP: #1341475
  * linux ABI 3.16.0-21
 -- Tim Gardner <email address hidden> Mon, 06 Oct 2014 16:47:04 +0100

Changed in linux-meta (Ubuntu Utopic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 3.13.0.39.46

---------------
linux-meta (3.13.0.39.46) trusty; urgency=medium

  * linux ABI 3.13.0-39

linux-meta (3.13.0.38.45) trusty; urgency=medium

  [ Tim Gardner ]

  * UBUNTU: Make linux-crashdump build for ppc64el
    -LP: #1341475

  [ Luis Henriques ]

  * linux ABI 3.13.0-38
 -- Luis Henriques <email address hidden> Tue, 28 Oct 2014 13:16:51 +0000

Changed in linux-meta (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers