kernel update requires change fstab syntax sdxx to hdxx

Bug #117373 reported by S Citrin
2
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
New
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6-386

Automatic update from kernel 2.6.20-15-generic to 2.6.20-16-generic. System will start to boot but then hangs with message "Resume: could not stat the resume device, please type the file name to try again" (spelling error in quotes verbatim). If you hit return, system boots, but drives other than the root drive fail to mount(including the swap drive). If run update-initramfs, still same behavior.

Problem can solved by editing fstab and changing entries from sdxx to hdxx, for example, /dev/sda5 to /dev/hda5. Apparently, the kernel update failed to include the recent feisty change from /dev/hdx to /dev/sdx syntax. Note on the system on which this occurred the drives are PATA, not SATA, yet when feisty was installed that fstab generated was with the sdx syntax (which worked with kernel 2.6.20-15, but not the 2.6.20.16 version)

Revision history for this message
Michael Kofler (michael-kofler) wrote :

Feisty 7.04 i386, all updates installed

I can confirm this. At least on my hardware (Centrino notebook IBM T42p), libata for IDE does not work any longer. My IDE disks are now /dev/hda and /dev/hdc (former /dev/sda and /dev/sdb).

This is a mayor bug which really should not happen in an automatic update!

Revision history for this message
Michael Kofler (michael-kofler) wrote :

see also #117314

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers