cannot build wacom-kernel-source kernel modules

Bug #103652 reported by Joachim Beckers on 2007-04-06
2
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Unassigned
wacom-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source

with the latest feisty kernel (2.6.20-14.22), I cannot compile the wacom kernel modules... this didn't occur with 2.6.20-13.21, so there has to be some regression in 2.6.20-14.22.

more precisely: I'm trying to use m-a to build, but the build stops, saying that there are no targets for make found.

root@madkeunnen:/home/joachim # m-a -t a-i wacom-kernel-source
.
Updated infos about 1 packages
Getting source for kernel version: 2.6.20-14-lowlatency
Kernel headers available in /lib/modules/2.6.20-14-lowlatency/build
apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
The following packages were automatically installed and are no longer required:
  module-assistant
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Done!
unpack
The source tarball could not be found!
Package wacom-kernel-source not installed?
Running "m-a -f get wacom-kernel-source" may help.
"/usr/share/modass/packages/default.sh" build KVERS=2.6.20-14-lowlatency KSRC=/lib/modules/2.6.20-14-lowlatency/build KDREV=2.6.20-14.22 kdist_image
dh_testdir
dh_testroot
rm -f *-stamp
dh_clean
dh_testdir
dh_testroot
/usr/bin/make clean;
make[1]: Entering directory `/usr/src/modules/wacom'
make[1]: *** No rule to make target `clean'. Stop.
make[1]: Leaving directory `/usr/src/modules/wacom'
make: [kdist_clean] Error 2 (ignored)
rm -f debian/wacom-kernel-modules-2.6.20-14-lowlatency.* debian/control
/usr/bin/make -f debian/rules binary-modules
make[1]: Entering directory `/usr/src/modules/wacom'
sed -e 's/${kpkg\:Kernel\-Version}/2.6.20-14-lowlatency/' \
        debian/wacom.control > debian/control
# Is this needed for setting up a Depends?
#echo "kpkg:Package-Version=1:0.7.7.7-0ubuntu1+2.6.20-14-lowlatency" \
        # >> debian/.substvars
echo "kpkg:Kernel-Version=2.6.20-14-lowlatency" > \
                debian/wacom-kernel-modules-2.6.20-14-lowlatency.substvars
# The substvars mechanism seems slightly broken, hack to get around it
# stolen from the qce-ga package.
# We do this above instead so control exists when the clean targets
# are run.
#sed -e 's/${kpkg\:Kernel\-Version}/2.6.20-14-lowlatency/' \
        #debian/cpad.control > debian/control
# Make sure we've had a chance to get a control file before doing this:
dh_testdir
dh_testroot
dh_clean -k
# Set up per package control files with suitable names
for f in modules templates; do \
            cp -a debian/wacom.$f debian/wacom-kernel-modules-2.6.20-14-lowlatency.$f; \
        done
for f in postinst config; do \
            echo "#!/bin/sh" | cat - debian/wacom.$f > debian/wacom-kernel-modules-2.6.20-14-lowlatency.$f; \
        done
# Build the modules
/usr/bin/make
make[2]: Entering directory `/usr/src/modules/wacom'
make[2]: *** No targets specified and no makefile found. Stop.
make[2]: Leaving directory `/usr/src/modules/wacom'
make[1]: *** [binary-modules] Error 2
make[1]: Leaving directory `/usr/src/modules/wacom'
make: *** [kdist_image] Error 2
BUILD FAILED!
See /var/cache/modass/wacom-kernel-source.buildlog.2.6.20-14-lowlatency.1175852124 for details.
Build failed. Press Return to continue...

root@madkeunnen:/home/joachim #

Joachim Beckers (jbeckers) wrote :

Notice the "The source tarball could not be found!" message. It's weird that that message is displayed. It makes it seem like the problem is in wacom-kernel-source, but it was not there with kernel 2.6.20-13. I didn't upgrade wacom-kernel-source. It's exactly the same as before.

Joachim Beckers (jbeckers) wrote :
Joachim Beckers (jbeckers) wrote :
Download full text (6.2 KiB)

root@madkeunnen:/home/joachim # dpkg -L wacom-kernel-source
/.
/usr
/usr/src
/usr/src/modules
/usr/src/modules/wacom
/usr/src/modules/wacom/AUTHORS
/usr/src/modules/wacom/ChangeLog
/usr/src/modules/wacom/GPL
/usr/src/modules/wacom/LGPL
/usr/src/modules/wacom/Makefile.am
/usr/src/modules/wacom/Makefile.in
/usr/src/modules/wacom/NEWS
/usr/src/modules/wacom/README
/usr/src/modules/wacom/acinclude.m4
/usr/src/modules/wacom/aclocal.m4
/usr/src/modules/wacom/bootstrap
/usr/src/modules/wacom/config.guess
/usr/src/modules/wacom/config.h.in
/usr/src/modules/wacom/config.sub
/usr/src/modules/wacom/configure
/usr/src/modules/wacom/configure.in
/usr/src/modules/wacom/depcomp
/usr/src/modules/wacom/install-sh
/usr/src/modules/wacom/ltmain.sh
/usr/src/modules/wacom/missing
/usr/src/modules/wacom/mkxincludes.in
/usr/src/modules/wacom/src
/usr/src/modules/wacom/src/wacom.4x
/usr/src/modules/wacom/src/2.6.9
/usr/src/modules/wacom/src/2.6.9/wacom.c
/usr/src/modules/wacom/src/2.6.9/Makefile.in
/usr/src/modules/wacom/src/2.6.9/hid-core.c
/usr/src/modules/wacom/src/2.6.10
/usr/src/modules/wacom/src/2.6.10/wacom.c
/usr/src/modules/wacom/src/2.6.10/Makefile.in
/usr/src/modules/wacom/src/2.6.10/hid-core.c
/usr/src/modules/wacom/src/2.6.14
/usr/src/modules/wacom/src/2.6.14/wacom.c
/usr/src/modules/wacom/src/2.6.14/Makefile.in
/usr/src/modules/wacom/src/2.6.14/hid-core.c
/usr/src/modules/wacom/src/2.4.22
/usr/src/modules/wacom/src/2.4.22/mousedev.c
/usr/src/modules/wacom/src/2.4.22/evdev.c
/usr/src/modules/wacom/src/2.4.22/Makefile.am
/usr/src/modules/wacom/src/2.4.22/wacom.c
/usr/src/modules/wacom/src/2.4.22/Makefile.in
/usr/src/modules/wacom/src/2.4.22/hid-core.c
/usr/src/modules/wacom/src/include
/usr/src/modules/wacom/src/include/Xwacom.h
/usr/src/modules/wacom/src/2.4.30x86-64
/usr/src/modules/wacom/src/2.4.30x86-64/mousedev.c
/usr/src/modules/wacom/src/2.4.30x86-64/usbmouse.c
/usr/src/modules/wacom/src/2.4.30x86-64/evdev.c
/usr/src/modules/wacom/src/2.4.30x86-64/wacom.c
/usr/src/modules/wacom/src/2.4.30x86-64/hid-core.c
/usr/src/modules/wacom/src/2.6.18
/usr/src/modules/wacom/src/2.6.18/wacom.h
/usr/src/modules/wacom/src/2.6.18/Makefile.in
/usr/src/modules/wacom/src/Makefile.am
/usr/src/modules/wacom/src/xdrv
/usr/src/modules/wacom/src/xdrv/wcmFilter.c
/usr/src/modules/wacom/src/xdrv/wcmSerial.h
/usr/src/modules/wacom/src/xdrv/Makefile.am
/usr/src/modules/wacom/src/xdrv/wcmUSB.c
/usr/src/modules/wacom/src/xdrv/wcmFilter.h
/usr/src/modules/wacom/src/xdrv/wcmISDV4.c
/usr/src/modules/wacom/src/xdrv/wcmCompat.c
/usr/src/modules/wacom/src/xdrv/wcmSerial.c
/usr/src/modules/wacom/src/xdrv/wcmConfig.c
/usr/src/modules/wacom/src/xdrv/xf86Wacom.c
/usr/src/modules/wacom/src/xdrv/xf86Wacom.h
/usr/src/modules/wacom/src/xdrv/wcmCommon.c
/usr/src/modules/wacom/src/xdrv/Makefile.in
/usr/src/modules/wacom/src/2.4
/usr/src/modules/wacom/src/2.4/mousedev.c
/usr/src/modules/wacom/src/2.4/usbmouse.c
/usr/src/modules/wacom/src/2.4/evdev.c
/usr/src/modules/wacom/src/2.4/Makefile.am
/usr/src/modules/wacom/src/2.4/wacom.c
/usr/src/modules/wacom/src/2.4/hid-input.c
/usr/src/modules/wacom/src/2.4/Makefile.in
/usr/src/modules/wacom/src/2.4/hiddev.c
/usr/src/modules/wacom/src/2.4/hid-core.c...

Read more...

Joachim Beckers (jbeckers) wrote :

rejecting this myself. there's no need to build the module since it's in the kernel package

Changed in linux-meta:
status: Unconfirmed → Rejected
Changed in wacom-tools:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers