openssh-server package does not start sshd on a live CD boot

Bug #1015348 reported by Thomi Richards on 2012-06-19
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

When booting into a live CD image (either quantal or precise), installing the openssh-server package does not start the ssh daemon. I get the following output while installing the package:

Preconfiguring packages ...
Selecting previously unselected package openssh-server.
(Reading database ... 154905 files and directories currently installed.)
Unpacking openssh-server (from .../openssh-server_1%3a6.0p1-1ubuntu1_i386.deb) ...
Selecting previously unselected package ssh-import-id.
Unpacking ssh-import-id (from .../ssh-import-id_2.12-0ubuntu1_all.deb) ...
Processing triggers for ureadahead ...
Processing triggers for ufw ...
Processing triggers for man-db ...
Setting up openssh-server (1:6.0p1-1ubuntu1) ...
Creating SSH2 RSA key; this may take some time ...
Creating SSH2 DSA key; this may take some time ...
Creating SSH2 ECDSA key; this may take some time ...
initctl: Unknown job: ssh
start: Unknown job: ssh
Setting up ssh-import-id (2.12-0ubuntu1) ...

Trying to start it manually produces the same result:

ubuntu@ubuntu:~$ sudo start ssh
start: Unknown job: ssh
ubuntu@ubuntu:~$ sudo /etc/init.d/ssh start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service ssh start
initctl: Unknown job: ssh

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start ssh

Thomi Richards (thomir) wrote :

FWIW you can get it to work manually with a bit of fiddling:

ubuntu@ubuntu:~$ sudo /usr/sbin/sshd
Missing privilege separation directory: /var/run/sshd
ubuntu@ubuntu:~$ sudo mkdir /var/run/sshd
ubuntu@ubuntu:~$ sudo /usr/sbin/sshd
ubuntu@ubuntu:~$ netstat -nlt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp6 0 0 :::22 :::* LISTEN

Thomi Richards (thomir) wrote :

This seems to be an inotify issue - initctl isn't being notified of the new configuration. If I run:

$ initctl reload-configuration

...then everything works as expected.

affects: openssh (Ubuntu) → linux-meta (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-meta (Ubuntu):
status: New → Confirmed
Eric Shattow (eshattow) wrote :

Confirmed with ubuntu-12.04.2-desktop-i386.iso in kvm virtual machine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers