[HP EliteBook 8540p] linux-crashdump not producing coredump nor rebooting

Bug #1010854 reported by Christoph Paasch on 2012-06-09
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux-meta (Ubuntu)
Medium
Unassigned

Bug Description

Since Ubuntu Precise, linux-crashdump isn't working anymore for me. When I trigger a crash with:
echo 'c' > /proc/sysrq-trigger

the machine freezes. I see the disk-light blinking for a short time. But then, the host does not reboot automatically, and no dump-file is in /var/crash. With Oneiric everything worked as expected.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu9
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: christoph 3120 F.... pulseaudio
 /dev/snd/controlC0: christoph 3120 F.... pulseaudio
CRDA:
 country BE:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd7520000 irq 54'
   Mixer name : 'IDT 92HD75B3X5'
   Components : 'HDA:111d7603,103c1521,00100202 HDA:11c11040,103c3066,00100200'
   Controls : 19
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3000000 irq 16'
   Mixer name : 'Nvidia GPU 0a HDMI/DP'
   Components : 'HDA:10de000a,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=92b841ca-8d28-483f-857f-831a55bd39b0
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard HP EliteBook 8540p
NonfreeKernelModules: nvidia
Package: linux (not installed)
PccardctlStatus:
 Socket 0:
   3.3V
  16-bit
  PC Card
   Subdevice 0 (function 0) bound to driver "pata_pcmcia"
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-25-mptcp root=UUID=f86b03ff-e7eb-4ba4-9009-1ec1b5856035 ro vga=773 crashkernel=384M-2G:128M,2G-:128M
ProcVersionSignature: Ubuntu 3.2.0-25.42-mptcp 3.2.18
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-25-mptcp N/A
 linux-backports-modules-3.2.0-25-mptcp N/A
 linux-firmware 1.79
StagingDrivers: mei
Tags: precise staging
Uname: Linux 3.2.0-25-mptcp x86_64
UpgradeStatus: Upgraded to precise on 2012-04-29 (40 days ago)
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare uml-net
dmi.bios.date: 08/23/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68CVD Ver. F.0B
dmi.board.name: 1521
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 32.32
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68CVDVer.F.0B:bd08/23/2010:svnHewlett-Packard:pnHPEliteBook8540p:pvr:rvnHewlett-Packard:rn1521:rvrKBCVersion32.32:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8540p
dmi.sys.vendor: Hewlett-Packard

Brad Figg (brad-figg) on 2012-06-09
affects: linux-meta (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1010854

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected precise staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
affects: linux (Ubuntu) → linux-meta (Ubuntu)
Brad Figg (brad-figg) on 2012-06-11
affects: linux-meta (Ubuntu) → linux (Ubuntu)
affects: linux (Ubuntu) → linux-meta (Ubuntu)
Brad Figg (brad-figg) on 2012-06-11
affects: linux-meta (Ubuntu) → linux (Ubuntu)

ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lukasz 2135 F.... pulseaudio
DistroRelease: Ubuntu 12.10
InstallationDate: Installed on 2013-02-18 (47 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
Lsusb:
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 04f2:b374 Chicony Electronics Co., Ltd
MachineType: Acer Aspire E1-531G
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-27-generic root=UUID=63262429-0c63-48cc-a4b6-d3907e268362 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-27.46-generic 3.5.7.7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/lukasz not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-27-generic N/A
 linux-backports-modules-3.5.0-27-generic N/A
 linux-firmware 1.95.1
Tags: quantal
Uname: Linux 3.5.0-27-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/15/2012
dmi.bios.vendor: Acer
dmi.bios.version: V2.07
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: EA50_HC_HR
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V2.07
dmi.modalias: dmi:bvnAcer:bvrV2.07:bd10/15/2012:svnAcer:pnAspireE1-531G:pvrV2.07:rvnAcer:rnEA50_HC_HR:rvrType2-BoardVersion:cvnAcer:ct10:cvrV2.07:
dmi.product.name: Aspire E1-531G
dmi.product.version: V2.07
dmi.sys.vendor: Acer

tags: added: quantal

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I have experienced the same issue, I want to produce a crach for bug report and I can not.
Fresh install of 12.10

The issue remains on Ubuntu 13.04. Please, does anybody has any hints for me?

I tried out removing the arguments as explained in https://wiki.ubuntu.com/Kernel/CrashdumpRecipe#Troubleshooting, without success.

Thanks!
Christoph

tags: added: bios-outdated-f.0f
tags: removed: quantal
tags: added: raring
tags: added: regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - linux-crashdump not producing coredump nor rebooting
+ [HP EliteBook 8540p] linux-crashdump not producing coredump nor
+ rebooting

Hello,

I had already the F.0F-Bios installed:

christoph:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
[sudo] password for christoph:
68CVD Ver. F.0F
03/09/2011

I will run again an "apport-collect" to update the info about my system.

Cheers,
Christoph

apport information

tags: added: saucy
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tags: added: latest-bios-f.0f
removed: bios-outdated-f.0f
description: updated
description: updated

Christoph Paasch, thank you for providing the requested information. No need to further apport-collect unless requested specifically.

Despite this, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

affects: linux (Ubuntu) → linux-meta (Ubuntu)

I did test upstream 3.13-rc3 and it is still failing. I updated the tags.

You think it's a kernel-bug? If that's the case, I can try a git bisect to see what commit caused it.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.13.0-rc3

Christoph Paasch, given the problem is a regression going from Oneiric to Precise, it wouldn't hurt to bisect the kernel via https://wiki.ubuntu.com/Kernel/KernelBisection to shed more light on the issue. Be careful as the proprietary nvidia drivers many not work out using the mainline, or previous Ubuntu kernels.

tags: added: kernel-bug-exists-upstream-3.13-rc3
removed: kernel-bug-exists-upstream-3.13.0-rc3

I finally found the commit who causes the bug:

commit 3c607d27c818cf4a5d28f2c73b18a88f8fbdfa33
Author: Don Fry <email address hidden>
Date: Fri Sep 30 11:40:20 2011 -0700

    iwlagn: rename iwlagn module iwlwifi and alias to iwlagn.

    Rename the iwlagn module as iwlwifi in preparation for future
    changes. Add an alias to iwlagn for backward compatibility.

    Signed-off-by: Don Fry <email address hidden>
    Signed-off-by: Wey-Yi Guy <email address hidden>
    Signed-off-by: John W. Linville <email address hidden>

Looks really strange to me, that this one is causing the bug.

Christoph Paasch, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel#KernelTeam.2BAC8-KernelTeamBugPolicies.Overview_on_Reporting_Bugs_Upstream ?

Please provide a direct URL to your post once you have made it so that it may be tracked.

Thank you for your understanding.

tags: added: bisect-done
Changed in linux-meta (Ubuntu):
status: Incomplete → Triaged
To post a comment you must log in.